Help - Search - Members - Calendar
Full Version: Packaging Ruby And Svn
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
ltrm
I've built Ruby 1.8.4 and SVN 1.1.4 and they both seem to be working great. I've even managed to get Rails installed via gem. Nice smile.gif

These are the first packages that I've built for pdaXrom and it seemed very easy but packaging them up is proving to be a bit of a problem though. I'm getting the following:-

CODE
tar: --exclude=CONTROL: Cannot stat: No Such file or directory
tar: Error exit delayed from previous errors


As far as I can tell the control file looks ok. I've been following the been following the tutorial for making ipkgs but I could do with a few more pointers. Any ideas on what I should try checking next? If the problem is definetly with the control file I think I'll just start from scratch again.... sad.gif
desertrat
QUOTE(ltrm @ Feb 16 2006, 10:38 PM)
CODE
tar: --exclude=CONTROL: Cannot stat: No Such file or directory
tar: Error exit delayed from previous errors

Not sure but it looks like you haven't created the directory "CONTROL"

QUOTE
As far as I can tell the control file looks ok.  I've been following the been following the tutorial for making ipkgs but I could do with a few more pointers.  Any ideas on what I should try checking next?  If the problem is definetly with the control file I think I'll just start from scratch again....  sad.gif


Make sure you have followed the instructions at http://mail.pdaxrom.org/contrib/docs/making_ipkg_howto.html in particular your directory structure should look like:
CODE
ipkg-temp/
|-- CONTROL
|   `-- control
|-- etc
|   `-- foo.conf
`-- usr
   |-- bin
   |   `-- foo
   `-- share
       |-- applications
       |   `-- foo.desktop
       `-- pixmaps
           `-- foo.png


The odd thing is that the mkipkg script should have caught the error about the missing CONTROL directory (if indeed that is the problem) and would not have gotten to the tar stage.

It might be because you're not using the latest version of mkipkg?

-- cheers
pgas
QUOTE
It might be because you're not using the latest version of mkipkg?


Most probably it is.
The older script doesn't like newer version of gnu tar
Dobby
Hi ltrm, did you ever get ruby/gem/rails/svn etc packed into ipks. I'd like to get all of this working on my Z. Also if you're using sqlite I'd like to know where you got the ruby-sqlite bindings. I'm struggling a bit to find the right ipks. I downloaded Fabians ipk of ruby 1.8.4 but it doesn't seem to include gem as stated in the announcements post.

Any help would be appreciated. Thanks.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.