Help - Search - Members - Calendar
Full Version: Transparent Aterm... For Fun And Profit.
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
cal
This worked better then I expected, so I thought I would share.

If you have already created an .Xdefaults add the following lines

CODE
aterm*loginShell:true
aterm*transparent:true
aterm*shading:60
aterm*background:Black
aterm*foreground:White
aterm*scrollBar:true
aterm*scrollBar_right:true
aterm*transpscrollbar:true

fire up aterm (restart aterm)



or can use the easy way... (this will replace your .Xdefaults if you made your own. if you don't know what .Xdefaults is then you should be safe with this method)

Easy way:
go the a terminal and type this comand

CODE
wget hcfolds.com/.Xdefaults

start a new aterm

Add an awsome little editor called nano, which looks great trasnparent... which I know is a funny statement

CODE
wget http://www.pdaxrom.org/unstable/nano_1.2.3_arm.ipk
ipkg install nano_1.2.3_arm.ipk
ipkg -d sd install nano_1.2.3_arm.ipk



have fun

:::
This was tested on:
C1000
1.1.0beta1
Rox Desktop

Can't see why it wouldn't work on just about any pdaxrom... might even work on other roms with aterm.

Screen shots soon.
+EDIT:::
I should really have given credit to the guide I stole most of that from... http://linuxreviews.org/software/x11-terms/aterm/
If you use their how to instead of this one, remember to skip the part about setting fonts, unless you know what you are doing, they set the fonts a little too bit to use on the Z
cal
And the screen shots...
jerrybme
You can do the same with mrxvt (unstable feed at pdaXrom.org), which has the added advantage of multiple tabs so you can have several terminals open and easily switch to them on the same desktop. Attached is a screenshot and also my .Xdefaults which has my settings for both aterm & mrxvt. I've got mrxvt set to open with 2 terminals, the second of which has Midnight Commander running (the "mrxvt*vt1*command: mc -a" line.)

CODE
#aterm Terminal Settings

# Settings posted by jerrybme Dec 28 2004

aterm*loginShell:true
aterm*transparent:true
aterm*shading:50
aterm*scrollBar:true
aterm*scrollBar_left:true
aterm*transpscrollbar:true
#aterm*geometry:55x23+0+0
aterm*geometry:60x25+0+0
# 786 lines = 500 KB of memory
aterm*saveLines:300

# Aterm Font Settings, selected using 'xfontsel'
#aterm*font:-*-*-bold-*-*-*-15-*-*-*-*-*-*-*
aterm*font:-misc-fixed-bold-r-normal-*-15-*
#aterm*font:-artwiz-*-*-*-*-*-15-*-*-*-*-*-*-*


# Aterm Color Settings

aterm*background:  black
aterm*foreground:  green
aterm*cursorColor: green

# I got these colors from using gnome-terminal's color
# dialogue. under Palette, i selected 'linux console'
# and just middle-mouse copied the values over--a swell hack

aterm*color0:      #000000
aterm*color1:      #AA0000
aterm*color2:      #00AA00
aterm*color3:      #AA5500
aterm*color4:      #0000AA
aterm*color5:      #AA00AA
aterm*color6:      #00AAAA
aterm*color7:      #AAAAAA
aterm*color8:      #555555
aterm*color9:      #FF5555
aterm*color10:     #55FF55
aterm*color11:     #FFFF55
aterm*color12:     #5555FF
aterm*color13:     #FF55FF
aterm*color14:     #55FFFF
aterm*color15:     #FFFFFF
!!!!!!!!!!!!!!!!!!!!!!!
! MRXVT configuration !
!!!!!!!!!!!!!!!!!!!!!!!
mrxvt*vt0*saveLines:   1000
mrxvt*initTermNumber:   2
mrxvt*vt1*command:  mc -a
mrxvt*protectSecondary:   true
mrxvt*loginShell:   true
mrxvt*scrollBar:   false
mrxvt*transparent:   true
mrxvt*shading: 35
mrxvt*transparentScrollbar: true
mrxvt*transparentTabbar:    true
mrxvt*transparentMenubar:   true
mrxvt*foreground:   green
mrxvt*background:   black
mrxvt*backgroundFade:   70
mrxvt*tabForeground:   white
mrxvt*itabForeground:   white
mrxvt*font:-misc-fixed-bold-r-normal-*-15-*
mrxvt*cursorBlink:   true
mrxvt*cursorBlinkInterval:500
mrxvt*geometry:60x25+100+0
mrxvt*bottomTabbar: true
ma401
QUOTE(cal @ Feb 19 2006, 08:42 AM)
:::
This was tested on:
C1000
1.1.0beta1
Rox Desktop


Works perfectly on my C-760 running 1.1.0beta1, thanks!

One more way to one-up my snooty PPC friends biggrin.gif

Click to view attachment
Antikx
QUOTE(ma401 @ Mar 2 2006, 04:41 PM)
One more way to one-up my snooty PPC friends biggrin.gif

Click to view attachment
*


Amen! smile.gif
kenko
I've make the .Xdefaults under /home/root but it doesn't make any different. Am I have to "activate" it or change any permission?

Thanks.
Armagon
QUOTE(kenko @ Apr 6 2006, 02:36 AM)
I've make the .Xdefaults under /home/root but it doesn't make any different. Am I have to "activate" it or change any permission?

Thanks.
*


Does running "aterm" within a console open up a new aterm that is transparent, as you wanted?

If so, then running "ps | grep aterm" should show you that one of the aterms has been started with additional command-line parameters that override what you put in .Xdefaults. To fix this, you need to edit /usr/share/applications/aterm.desktop. [You don't need to back it up first, but you sure could.] Find the line that starts with "Exec=aterm" and remove all the command line parameters (ie. everything after "Exec=aterm").

I believe that'll do it.

Armagon
jerrybme
QUOTE(kenko @ Apr 6 2006, 04:36 AM)
I've make the .Xdefaults under /home/root but it doesn't make any different. Am I have to "activate" it or change any permission?

Thanks.
*

Also, if you're using the matchbox icon to launch, it'll over-ride some settings. I've removed the options from the aterm.desktop file in /usr/share/applications
CODE
Exec=aterm


That way it'll look to my .Xdefaults for the values.

One way to test is to run aterm from an already open terminal. If it opens with your desired options, it's the aterm.desktop file is causing you problems.
kenko
Thanks for advice. I did try running aterm within console. But only the font color change from green to white and the scroll bar gone. The content of my .Xdefaults is exactly the same as cal's code above. What else could be the problem?
Meanie
QUOTE(kenko @ Apr 8 2006, 12:23 PM)
Thanks for advice. I did try running aterm within console. But only the font color change from green to white and the scroll bar gone. The content of my .Xdefaults is exactly the same as cal's code above. What else could be the problem?
*


i had to kill all the aterms, even the zombies in order for the transparent background to work. maybe a simpler solution would be just restart X?
kenko
Problem solved. This is my fault of stupid typo error. tongue.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.