Help - Search - Members - Calendar
Full Version: Problems With Bluetooth Ppp Under Cacko 1.23b1
OESF Forums > General Forums > General Support and Discussion > Security and Networking
daniel3000
Hello,

does anyone know what the reason could be or where to look for the reason?

I have a Nokia DTL-4 BT CF card and by modifying the /etc/pcmcia/bluetooth.conf file the card is now recognized and drivers are loaded on insertion (bluez).

I have created a configuration for a PPP connection via Nokia 6310 phone in the network config of QTopia.

In the list of configurations of the network config tool this new setup appears.

However, in the list of available connections it does not appear!

So how can I use that new configuration?
I have successfully created many WLAN and two IrDA setups without any problems.

In which files are these configuratoins and connection listings stored?

thanks
daniel
daniel3000
One idea:
When I have no WLAN card inserted, the WLAN configuratoins are not shown in the connection dialog.

So probably when the Bluetooth card is not inserted, the Bluetooth configurations are not shown.

I.e. if a BT configuration is not shown, the network applet probably does not know that there is a BT card in the slot.

How does it know about the cards inserted? What can be wrong here?

cardctl ident shows

Socket 0:
product info: "Nokia Mobile Phones", "DTL-4"
manfid: 0x0124, 0x1000
function: 254 ((null))

could it be that "function" tells the network applet what kind of card it is and since it's "null" here, the applet doesn't know about the card?

How is the function set? Why do I get "null"?

Thanks
daniel
daniel3000
More results, but still no success:

1. If I delete all IrDA configurations from the network settings, the Bluetooth configuration is finally shown! So IrDA configs somehow have priority it seems.
Any idea how both could live besides each other in the QTopia network settings?

2. But still, a connection is not possible. Phone asks for password, but if I enter it (as stored in /etc/bluetooth/pin) the connection is not estabilshed.

So I tried to connect on the command line.
CODE
rfcomm connect /dev/rfcomm0 xx:xx:xx:xx:xx:xx


--> Phone asks for pin. I enter wrong pin: rfcomm quits with "Can't connect RFCOMM socket: COnnection refused. --> OK (since PIN was wrong).

If I call the rfcomm command and enter the correct pin, it takes a while, then rfcomm quits with "Can't connect RFCOMM socket: Resource temporarily unavailable" and the phone continues to show the "Connecting" screen forever.

Any idea what is going wrong here? What does the "Resource unavailable" message cause?

Thanks for any help!
daniel
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.