Help - Search - Members - Calendar
Full Version: Battery And Charging Issue, Is Battery Done? Fuse?
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > 5x00 Hardware
antikristian
My poor old zaurus has been collecting dust in a drawer for allmost a year now, and I thought it would be time to either resurect it or sell it off.

Ever since it was new (refirbished) I have been having an issue with the charging. The zaurus would charge for a while, then suddently stop and not start charging again. Since I did not bother returning it (bought it in GB and I live in Norway) I partially solved the problem by adding a timer to my charger, the timer is like the ones you plug between the wall outlet and the charger, and i set it to turn of he charger at regular intervals.

This is not a problem with the charger itself, I have the exact same problem while charging from usb with a cable I bought.

A year ago the battery was diminishing (but not broken) and the zaurus would last maybe an hour or thirty minutes on battery, then I read about the servicemenu and accidentaly reset the battery level so that it did not work for a full five minutes sad.gif I did not manage to fix this then, since I had no multimeter lying around, and still don't. But yesterday I plugged the battery directly to the charger and left it there, tried to reflash and still no cigar though.

My battery is a ea bl06 3.7 v

it's flashed at level 590 (3.7v)
CODE
Battery Voltage Check



Main Bat AD: 582 (3.7v)

Flashed Delta: 590
delta + 62

Adjust AD: 582 -> 644
         :   (4,1v)


Is it supposed to be charged higher than this? 4.2v? is it possible to make the zaurus allways stay on when connected to mains? Mine obviously does not since it cuts out when the charging stops.


edit: after trying the usb cable again it seems it is able to keep the z powered on, and battery seems better after my trials with charging the battery externally and resetting level in service menu. So it seems to be an issue with direct charging through the charger, fuse issue? Ill come back with updates later
zaurus-rules
I have an 860 and I have a very similar battery problem!

First, my original Zaurus charger stopped working. I checked with a voltmeter and there was tiny voltage at the output. I took apart the charger and discovered that the internal fuse had blown. I couldn't find a replacement fuse at the electronics shop.

I bought a 3rd-party replacement charger that said it could be used with the Zaurus. It worked fine for a long time. Now, though, my battery stops charging after just a few minutes. I leave it plugged in all night but the next day the battery is only 25%, and the Zaurus charging light is off.

Only today I discovered that plugging/unplugging the charger starts the Zaurus charging again - exactly like you describe.

Did you ever fix your problem? I'm going to look at the NAND menus, I'm not too familiar with the battery options there.
Ferret-Simpson
Have you tried a different battery?

The 850mAh Nokia BL-5C and 750mAh BL-4C can be used on the 5500 and 860 with some very simple modification. (basically, to make it the right shape and put the terminals in the right places and order.)
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.