Help - Search - Members - Calendar
Full Version: Totally Bricked C3000
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
lareya
Okay,
I have been trying now for two days straight to get into the diagnostic menu. I have HDD2 Error, and I can't get past it. I have done the OK & Power on thing. (menu 3 -1-Y) I have done it extensively. But i still get the same error. I have gone to the page for Restoring a C3000 from scratch I am trying to do that also. I can't get into the DB menu or the DM menu. I have been trying over and over and over. I took my batteries out for overnight even - still, can't get into any of the useful diagnostic menus. mad.gif

what is the trick? I have all my files on the CF card (512mb)

I'm really frusterated! dry.gif I had Cackobeta on and X/QT from when I received the Zaurus. I tried to re-install cacko, the first part worked on that, but when I tried the Second part (3-1-Y) I get the same error:

error Hdd2,
EXT3-fs unable to read superblock
hdc2: bad access: block=2, count=2

any more ideas? I am getting tired of yanking out the battery and trying to do a DM or DB

Lareya sad.gif
lareya
Okay, then if this is hopless (after another round of trying to get the DM menu up by removing batterty overnight, plugging in the electric (cuz no lights if I don't), and then only way to do get anything to work is to turn on the machine & press D+M at the same time. It just boots up with the linux guy and gives me this error:

EXT-FS unrecognized mount option quiet
hda: hda1
hda: hda1
cramfs: wrong magic
hda: hda1
hda: hda1
VFS: Can't find a Minix or Minix V2 fileyststem on device 03:01.
hda: hda1
hda: hda1
MSDOS FS: IO charset utf8
Trying to free nonexistent resource <7000000-f700000f>
hdc: ST68022CF, ATA DISK drive
ide1 at0xf7000000-0xf7000007,0xf700000e on irq 136
hdc: 15625008 sectors (8000 MB) w/128kiB Cache, CHS=15501/16/63
hdc: [PTBL ] [972/255/631] hdc1
ide_cs: hdc: Vcc = 3.3, Vpp = 0.0
hdc: hdc1
hdc: hdc1
kjournald starting. Comit interval 5 seconds
EXT3-fs: mounted filesytem with ordered data mode.
hdc2: bad access: block=2, count=2
EXT#-fs: unable to read superblock
mount: Mounting /dev/hdc2 on /hdd2 failed: Invalid argument
HDD2 Error!! start check battery !

If no one can help me, can you please recommend a place where I can send my Z to get fixed?
I bought it second hand, so have no warranty. wink.gif

Lareya
stbrock
This thread might help.
lareya
Thinks for your reply. I will try all those types of codes. This is really frusterating. I am about to just toss this whole thing out my window! mad.gif

Is there any other way I can do a nand backup? can I take out the card (yes open case) and do it from my pc?

Lareya
lareya
Okay here is what I get when I try to flash cacko beta1 with the ok key + On/Off 4-1-y (menu)


Zaurus CF updater
kernel

0% 100%
Sucess!
RO file system
Flash erasing ... done
0% 100%

Sucess
Master Version
Success!

HDD RO filesystem
Now formatting ....
Now Extracting ...

then it blacks out after a while, and boots to the ol' familiar error that I copied so laborously above that no one seems to tell me what it means - my hard drives are hosed? my drives are not mounted? I have no flash memory? I don't know. But it is the same always. wink.gif

I still can't seem to get into a NAND menu - altho with the last help from stbrock, I have more keys to try over and over again.....ad nauseaum. I think I am going to go stark raving mad mad.gif

Lareya
lareya
sad.gif Okay here is what I get when I do the ok key + On/Off 2-2-Y (menu)

[System HDD check]
Now checking HDD1...
/dev/hdc1: 3182/977280 files (0.1% non-contiguous), 55091/1951889 blocks
ok

Now checking HDD2...
fsk.ext3: Invalid argument while trying to open /dev/hdc2
/dev/hdc2:
the superbolock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:

e2fsck -b 8193 <device>

Error!

File system errors left uncorrected.

I would love to run e2fsck, but can't get to a prompt to do it in!!!

(I hope it is okay to keep posting my details/errors) smile.gif

Lareya
stbrock
The 3000 works a good bit differently from my 860, so I'm just guessing here. Using Fn+D+N I got to a somewhat different group of diagnostic menus than I'd seen before and tried a number of different things and was not sure exactly what finally worked or why. In my case, I got a lot of messages which sounded like trashed hardware and was about to throw the 860 in the garbage more than once, but ultimately the messages seemed to be artifacts of scrambled OS files that went away once I got the NAND restore to quit failing.

You might try flashing the Sharp ROM instead of Cacko. I believe both Conic and Trisoft have original NAND files. Flashing from different brands of CF card seemed to make a difference for me. Then there is erasing using the diagnostic menu and other exciting menu options to try in desperation. You probably can't make things worse -- its already bricked and none of the menus will make it explode on you AFAIK. wink.gif

If all this fun eventually wears thin, Trisoft might be more likely to undertake a repair in your situation than some other dealers from what I've seen posted.
Mjolinor
I think I would take the microdrive out and check the file system on a PC with a card reader. If it isn't OK then repartition it on the PC.

You will need a Linux PC to do it but a live boot one such as Knoppix or Ubuntu will work.
Meanie
You should boot into the DMR using the D+B key option. Once you get in there, you can use fdisk and e2fsck to check your disk and partitions.

Unplug everything from your Zaurus, then pull out your battery. Press and hold D and B keys and reinsert battery. Make sure you keep both keys depressed while putting the battery back in and after locking the lid, press the on button. The Zaurus should now boot into the DMR partition and you can login using root with no password.

fdisk -l /dev/hda

should show you your partition table and you should have 3 partitions.
/dev/hda1 should be ext3
/dev/hda2 should be ext3
/dev/hda3 should be vfat

if you dont have them, then you need to recreate the partitions using fdisk.

if they exist, then you can use e2fsck to check /dev/hda2 and fsck.vfat to check /dev/hda3
or you can just reformat the partitions which probably would be faster if you dont want to keep what is on those partitions.
lareya
some how I was able to get a zaurus prompt, and I login as root.
Now I did this command

fdisk -l /dev/hda and I got this message sad.gif
modprobe: modprobe: Can't locate module block-major-3

I ran this command: e2fsck -b 8193 /hda
The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains and ext2filewywtem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

When I tried this:
fdisk /dev/hda I get this Again -
modprobe: modprobe: Can't locate module block-major-3
modprobe: modprobe: Can't locate module block-major-3

fdisk /hda again tried this
Unable to open /hda

fsck.vfat -a /dev/hda I get this -
modprobe: modprobe: Can't locate module block-major-3
open /dev/hda: No such device or address


I am not going to turn this Zaurus off, so please someone help me.
Is there something else I can use? run off my CF or SD card?
I just want to reformat my drive and set it with the three partitions like meanie said.

Lareya
lareya
I was able to get into the NAND menu. I followed the instructions found Returning Your Zaurus SL-C3000 To It's Factory Settings regarding placing the NAND file on a CF card for my c3000, however when I hit return/OK twice it has this on the menu
file:systc300.dbk
Execute restore?
and then it seems to be hanging. I don't see/hear anything going on. It seems frozen. dry.gif

Any susgestions?

Lareya
distortion
this sounds not good at all, sorry to hear about your troubles. looks like you have tried most of the things i would go for, im a long way from being an expert but here are a few other things i would try:
cacko and pdaxrom have a lot of usefull nand utilities in there install scripts. it could be worth trying to at least get something working with them. if you can even get a bootstrap image to go into flash rom then you will have more tools to get things going.
it sounds to me like your hard drive is either dead or the has a very broken layout. im on a windoze pc at the mo and cant check what i had to use to raise disks from the dead before but there is a huge amount of info on this for linux in general. fdisk should find something and dmesg should tell you if not, why not.

will try and follow your post and also see if i can find anything out this evening. best of luck with it.
stan
distortion
there is a link to trisoft on this page

http://www.oesf.org/forums/index.php?showtopic=9038

the pdf manual is good and only heard good reports about trisoft. the restore script 'might' get things back to the origional state.
Mjolinor
QUOTE(lareya @ Mar 14 2006, 05:23 AM)
I was able to get into the NAND menu.  I followed the instructions found Returning Your Zaurus SL-C3000 To It's Factory Settings regarding placing the NAND file on a CF card for my c3000, however when I hit return/OK twice it has this on the menu
file:systc300.dbk
Execute restore? 
and then it seems to be hanging.  I don't see/hear anything going on.  It seems frozen.  dry.gif

Any susgestions?

Lareya
*


You did tell it to "execture restore" I assume? It can take a while.
lareya
Yes, I did tell it to execute restore. That is when it just hung - nothing, no indicator, nothing. Stayed that way until I left for home (30 -40 minues). I had to take the batteries out for it to do something.

Regarding the okay/On menu: I get the japanese prompts, but am unable to do anything here either. It is selected on the number 1, and no amount of coaxing can get it to move to the 3rd option. I try to move it with arrow keys, try to move it with sylus, try to move it with the number. Nothing....just sets there. I hit the okay key, and it still sits there (it is my understanding that 1. is the cancel prompt. Will nothing works except to pull the batteries out again.

I am going to try and get into the other menu (D + M/B) and see if I can do anygood (damage) there. It is upsetting, cuz I got it with cacko beta, and XQT second hand - without a SD/CF card in it. I didn't flash it . But, it seemed to choke on removal of the CF card cuz I was trying to put in a CF wireless card and it froze. I couldln't get it to boot up after that in cacko beta. I have been trying ever since then to get it to flash or Nand with the info on trisoft, and the other sites I have mentioned in my above posts. With my 860, it was easy to flash between roms. I never seemed to have this much problems with it, and I was BRAND new with linux then.

So I am able to login as root, but my partitions are not there. what are the commands to repartition my hard drive? fdisk -l /dev/hda yields this info
/dev/hda: 512mb (it finds my CF card)
Device /dev/hda1
Boot *
Start 1
End 991
Blocks 499432+
ID 6
System Fat16

/dev/hda2
Boot
Start 1
End 1
Blocks 0
ID 0
System Empty


Partition 1 has different physical/logical endings:
phys=(991,15,63) logical=(990,15,63)

/dev/hda2
Partition 2 has different physical/logical beginnings (non-Linux?):
phys=(0,0,0) logical=(0,0,1)
Partition 2 has different physical/logical endings:
phys=(0,0,0) logical=(4260880,4,4)
Partition 2 does not end on cylinder boundary.

Because my 4g mdrive was toast, I put in a 8g CF card - since I read that you could just re-partition the drive. The orginal 4g mdrive did the same thing. Both cards act the same.

Lareya.
(thinking about to give up and sell them for a Dell Axiom or an OQ00)
lareya
Okay, may be getting somewhere.... wink.gif
I am able to get back into the NAND Restore menu : I have systc300.dbk on my CF card, I have the prompt execute restore? and I have pressed the enter key, and the okay key. There isn't a change, but I am going to let it stay for a while in this state. It appears to be just frozen but I can't seem to get anywhere else on this.

how long does this usually last? someone know who has done this?

wish me luck blink.gif


Lareya
andresgriego
Hi,

I would suggest repartitioning your HDD with a CF card in the CF slot. I read elsewhere that when there's no card in the slot, your HDD will appear as 'hda'. It should be 'hdc' for the repartitioning stage.

Not sure if this helps, but this is what I think I need to do to get rid of my HDC3 error, 'Error!!! HDD not initialized!!!' on boot-up.


GL,

Andres

*EDIT*

Fixed my problem with this.
lareya
Thanks for your help. That is probably the only thing I have not tried. I do have the c3000 NOT the C3100, but I tried it anyway. I saw a lot of Japennese stuff, but I still can't do anything.

The only thing I can do is use the login as root, and run commands from there. I am unable to mount the /dev/hda1

but I am able to create/delete partitions. But I am unable to use the other diagnosis menu's, they come up, but then freeze. I am unable to select the different numbered menus - on both of the menu's.

I am stuck with just the menu stuff. I am at a loss. I need really detailed instructions, because when I think things can't get any better - they just get worse. I have worked on this for the past few weeks, and now again for 4 hours.

Please can someone walk me thru how to in the command line restore my C3000? I am desparate! I am begining to HATE linux and Zaurus! What I would like to do is just copy an image from my CF drive to my hda? drive (internal CF 8g card). But, then again, I can't mount it. I did change the whole thing to linux partition number 1 primary, and let it do the default cylinder stuff from start to end. Okay.... I know I am babbling now, I just don't know what else to do?!?

I use winxp on all my other computers (work & home), can anyone give me commands to do this on windose? OR I have my cl860. can someone walk me thru doing it there? I already took out the CF card and CFdisk it in my 860, but the Cl3000 doesn't have that. I liked that (Cfdisk), cuz it is easy to see what I am doing w/ a gui.

Lareya
andresgriego
1. Blow away your partitions.

2. Make new partitions with a CF in the slot (so HDD registers as HDC)

3. Format partitions appropiately.

4. Mount partitions.

5. Copy needed files to HDD1 and HDD2.

6. Reboot.


The specific instructions for these steps are found in this thread and the pages linking off of it.


GL,

Andres cool.gif
lareya
1. Okay fdisk doesn't see my hard drive at all (8g hard CF drive) mad.gif
I try to mount (just stupid error codes)

Want more info? I have put all the stupid error codes in all my posts. People tell me the same thing. I CAN"T USE THE MENUS! How many frickking times can I say that! mad.gif All I have access to is the prompt from the DB Menu.

Now, if someone can help me with this I would greatly appreciate it. Yes I have checked every link to the above postings (probably about 100 times!)

Obviously I am a dumb smuck that needs a little more help than that.

Do I sound pissed? YES! this is a frusterating experience that I care not to experience again. And as soon as I get this stupid piece of crap machine working again, I will sell it and get something more stable like the MS CRap everyone talks about here. At least it works.

Lareya mad.gif
Mjolinor
Have you tried preparing the card in a PC then putting it back in the Zaurus?
lareya
Yeah, I have taken the 8gCF card out and put it in my slc860 and CFdisk it. I tried to make 3 types of partitions two ext2 , and one fat. My sl860 reads it in the CF slot just fine.



My home computer is a windose and I couldn't find a way to do the linux partition with it, and didn't have a stick handy to even do a live linux of some kind. Keep in mind I am pretty much a newbie, and this is a huge learning curve for me. I think the 860 is easier to use with cacko. I am trying out the PXD Rom, but it remains pretty much not used. I guess I need more of a PIM then the other stuff. I just wanted to run gnome bible study, or something like that. the QTsword is okay for reading, but not really that good for study.

Laryea
DoTheDog
lareya,
Sorry to hear about your troubles. The only thing I can add is my experience. I have a c3100 and I know that the hd partitions etc. are very different but this may help. I tried repartitioning my drive so that I had a larger hdd2 as an ext3 partiton (for Pocketworkstation) and a smaller hdd3 in vfat. After I had done that the z wouldn't boot. Gave me hdd initialization errors and I could only boot to a command prompt. What I found is: (again this is for a c3100)

1. check your /root/etc/rc.d/rc.rofilesys file. Make sure that all references to mount ... ${IDE1}1, ${IDE1}2, and ${IDE1}3. have the correct filesystem associated (I think there are two references for each partition). Also make sure that $LINUXFMT is defined correctly (either ext2 or ext3) .

2. On the c3100 on hda1 /hdd1/.sys make sure you have hdimage2.tgz hdlist1.dat files or it won't boot.

Again, this worked for the c3100 YMMV.

Good luck.

DoTheDog
lareya
Okay, dry.gif
Is this possible? Can someone copy their internal microdrive and then send it to me? I can't use the menus, I can't move up or down in the diferent numbers. (They come up, but I can't select anything in their. )

I have the original 4g md and I just want to copy appropriate files, and pop it back into my C3000, and hope/pray it works. So far nothing I have tried will "unbrick" it. see the previous messages I have posted ad nauseam

All this because I pulled out my CF card, but evidently it was not unmounted at the time. I was running the cackobeta and X/QT. I was not doing anything weird with it. Now, I have been screwed. and am very frusterated with this process.

thanks wink.gif

Lareya
ads
Now thats interesting. I had the following happen to me running 1.23 cacko on 750.

i was interchanging wifi and cf cards and allof a sudden....the cf was recognised (or rather not recognised as hddx)when i clicked on this i find garbage as the contents of my cf card. Thinking i had corrupted it...I checked in a card reader and then rebooted the Z. All was fine. Im thinking the same happened to you.....and as the 3000 boots of the Hd? you find yourself in trouble....

The previous post seems spot on.....if you can check your mounts and then download a fresh c3000 image to ur md....and then reflash.

If you have done all this.....then I`m sorry

good luck.

ads
Mac
If everything fails, wich hapened to me a LOT in the past, just read this
site

I have done this a few times now and it's easy. One thing to mention, folow the instructions but also do the folowing while booted with db
dd if=/dev/zero of=/dev/hdc1
dd if=/dev/zero of=/dev/hdc2
dd if=/dev/zero of=/dev/hdc3

don't ask me why, but without this my zaurus was still unstable with a fresh install (no backup)

it will take some time (30 minutes) but is worth it, so no need for someone to send you a 4gb image biggrin.gif

Good luck, I know how you feel having a 700 € paperweight
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.