Help - Search - Members - Calendar
Full Version: Pma400 Sdk And Qtopia 1.7 Sdk Linking Error
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Zaurus - Everything Development > Qt/Qtopia
I'm tring to build a console app on pma400, and i simply included "audiodevice.h". The following lines are compiler commands and error messages.

arm-linux-g++ -c -pipe -DQWS -fno-exceptions -fno-rtti -Wall -W -O2 -DNO_DEBUG -I/opt/Qtopia/arm/include -o ArchosAudio.o ArchosAudio.cpp
arm-linux-g++ -o ArchosAudio ArchosAudio.o -L/opt/PMA400/lib -larchos -lcsl -laimaging -L/opt/Qtopia/arm/lib -lqtopia -lqte -lqpe -ljpeg -luuid

/opt/PMA400/lib/ undefined reference to `QExclusiveLock::unlock(QExclusiveLock::Type)'
/opt/PMA400/lib/ undefined reference to `QWSDisplay::fblock'
/opt/PMA400/lib/ undefined reference to 'QExclusiveLock::lock(QExclusiveLock::Type)'

anyone has any idea how this happened. plz help sad.gif

I've solved the problem myself. Ironically, I found some useful information from a French website; even worse, French and I don't know each other very well. Anyway, i copied libqte.2.3.6 from /opt/Qtopia.rom/lib on Archos PMA400, which is the lower version of current libqte supplied in Qtopia 1.7 SDK. And i changed the links to point instead of libqte.2.3.7. After that, the compiler complained that libz is required, however, this libz doesn't exist in both PMA400 SDK and Qtopia SKD. I found it on the Archos PMA again under /usr/lib. Eventually, the problem solved. Hope this is helpful to whoever has the same problem. biggrin.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.