Help - Search - Members - Calendar
Full Version: Sync/samba Issues
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > 5x00 General discussions
zauruspimp
QUOTE
No matter what I've tried I can't seem to connect to my SL-5500 from my PC.
Info:
1. Tried both wifi and cradle connections with no success.
2. I can ping in both directions
3. In terminal mode, executed ps -ef and determined both samba processes, nmbd and smbd are running.
4. Reconfigured the smb.conf file to match the workgroup name and changed the interfaces = to my pc ip with no success (also commented out the interfaces line with no success as well).
5. Performed the required file changes, as stated in the How To section, to get a connection via wifi (with netbios line additions) with no success.
6. Changed the ip address to that noted in ipconfig with no success.
7. Hard booted the unit and reperformed the above with no success.

In short, the connection is up since I can ping each way. And Samba is running when the unit is in the cradle since nmbd and smbd are running. I've probably tried a lot of other things not listed above to no avail.

I'm sure I don't have a hardware problem as I did the above on different PC's both running Windows ME.

Any advice would be appreciated. I'm a novice to Linux and terminal commands and learned everything I know via this website.

Thanks.


zaurusstan posted the above in september of last year and got no replies. I have the exact same problem except I'm running WinXP-SP2 on my machines. Also i dont have the CFWI-FI yet so that hasnt been tried. I am running ROM 3.10 And i realize that doing ANYTHING with it (move files to/from, sync, ROM Update) requires that i get this working first. so..... suggestions?

tia,
Rick
bluedevils
you can ping both directions? what are the IPs of the interfaces? Does XP have the firewall turned on for that network connection? What are the error messages when you try to sync or move files?
zauruspimp
the Z is its default @ 192.168.129.1 and the PC is @ 192.168.129.1

I **never** have windows firewall turned on, i have an external one for that.

The error message on the zaurus is "Communication was aborted."

The error on Intellisync is that the zaurus is not there
zauruspimp
oops Z *is* default...
192.168.129.201
bluedevils
Are you using tcp/ip mode? I could never get the other one working.

Can you telnet to the sync port 4242 on the Z and establish a connection?
zauruspimp
"the connection was refused" when i attempted that

also intellisync file transfer error below
zauruspimp
I am using TCP/IP mode (the only one I can find support for)

OK, so I was surfing around in the file manager app, and I saw that every network.conf file and "network" (no .conf) file was pretty much blank.

Anyone have anyclue as to what *should* be in these?

tia,
Rick
zauruspimp
anybody have any new clues? unsure.gif I'm stuck. The Z Ninja ph34r.gif has got me!!

wink.gif
DaemonsGR
QUOTE(zauruspimp @ Mar 10 2006, 10:40 PM)
the Z is its default @ 192.168.129.1 and the PC is @ 192.168.129.1

*


Z and PC @ the same IP??????
bluedevils
read further and you will see he made a typo.

I did a search for network.conf and couldn't find it on the 3100
bluedevils
actually I didn't see a reply stating that you were able to ping the each other. Does that work?
zauruspimp
yes pinging works in both directions
freizugheit
It presumes that Windows XP's ICS is already in place. And the PC is connected to Internet.


Try the following commands at SL-5500:

su route add default gw 192.129.168.1
su route add -host 192.168.129.1 usb0d

edit /etc/resolv.conf and add the follwing line:

nameserver IPofNameServerOfYourISP


I hope the above will help
zauruspimp
hey all, thanks for all of your replies! I got this working by using the largest "CD Contents Download" I could find. its 65 MB, and if anyone else has this problem, I would be more than happy to forward the files to you. I also had to figure out how to reflash the Z with ROM 3.10. after all of that, it now works flawlessly.

Thanks for all of your help again!

Rick
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.