Help - Search - Members - Calendar
Full Version: Sound In Kismet
OESF Forums > General Forums > General Support and Discussion > Security and Networking
mandjab
Hello,

I just install kismet on my new SL-C3100, and when a new network is discover, i have no sound.
i remenber last year with my Sl c760, kismet have sound. Whats the problem?
however, I modified the conf file and activated the sound in.
But it doesn't work anymore. Any ideas?

Version of Kismet :
Kismet 2005-08-R1-2
Kismet-qt 2.0.0-3

Thank's
speculatrix
check your kismet.conf has "sound=false" and kismet_ui.conf has "sound=true". then check the latter has the right program for the sound player, and run it at the command line.
BarryW
Might want to see if the sounds even exist. I thought we had to copy them out of an older release.
speculatrix
the version out of the box with cacko1.23 does have the sound files... hmmm, will get back to you.
xjqian
the latest Kismet 2005-08-R1-2 didn't come with "play" and "sox" and the wav files. I don't know wether cacko includes the following in their package (hope they had).

CODE
Run the latest Kismet with sound

12) Unzip and untar the old kismet ipk to extract the playback binaries and wav files

mkdir temp
cp Location/kismet_3.0.1c-20031228_arm.ipk temp
cd temp

tar zxvf kismet_3.0.1c-20031228_arm.ipk
gunzip data.tar.gz
tar xvf data.tar

cp ./usr/local/bin/play /usr/local/bin
cp ./usr/local/bin/sox  /usr/local/bin
chmod 755 /usr/local/bin/play
chmod 755 /usr/local/bin/sox

prepare the directory (mkdir ***) /usr/local/share/kismet/wav
cp ./usr/local/share/kismet/wav/*.wav /usr/local/share/kismet/wav



Ref the how-to http://www.oesf.org/index.php?title=How_to...on_the_SL-6000L
speculatrix
QUOTE(speculatrix @ Mar 29 2006, 08:24 AM)
the version out of the box with cacko1.23 does have the sound files... hmmm, will get back to you.
*


sorry for the delay, I was away on holiday. Yes, kismet as part of cacko1.23 feed DOES install the sound files BUT the kismet config file refers to the wrong place.

this is the magic command you have to do so kismet can find them. Start a console, use "su" command to become root and then enter

ln -s /home/QtPalmtop/share/kismet /usr/local/share/kismet

easy!
speculatrix
p.s. you can always run this command

find / -name "*.wav" -print | more

to find all the wav files on your zaurus. that's how I found out where all the kismet sound files were
mandjab
Ok thank's for your reply, i'm going to test it tonight.

I really prefer kismet With sound. laugh.gif


QUOTE(speculatrix @ Apr 9 2006, 10:04 PM)
p.s. you can always run this command

find / -name "*.wav" -print | more

to find all the wav files on your zaurus.  that's how I found out where all the kismet sound files were
*
speculatrix
did it work?
speculatrix
I'm just trying to get kismet running on my "new" c3100 newly flashed to cacko1.23, it's been 8 months since I sold my 860, so I am like a newbie.

I thought I would post what I learned to do.

install kismet and ncurses package:
* ipkg install kismet
* ipkg install ncurses

put kismet conf files in easy to find place
* ln -s /opt/Qtopia/etc/kismet /etc/kismet

fix the location of the sound files
* ln -s /opt/Qtopia/share/kismet /usr/local/share/kismet

turn off gps and sound in the server, turn sound on in client
* vi /etc/kismet/kismet.conf and disable gps and sound
* vi /etc/kismet/kismet_ui.conf and enable sound, change the sound player from /usr/bin/play to /opt/Qtopia/bin/wavplay

now, it nearly runs, but the client doesn't come up. must have missed something, and it leaves the server running. kismet_client isn't executable by user zaurus, but if I do make it so, I get the following problem:
$ kismet_client
NOTICE: Group file did not exist, it will be created.
Looking for startup info from localhost:2501.... found.
Connected to Kismet server 2005.08.R1 on localhost:2501
Reading AP manufacturer data and defaults from /usr/local/etc/ap_manuf
Reading client manufacturer data and defaults from /usr/local/etc/client_manuf
Error opening terminal: linux.

I have tried changing TERM to linux, vt100, xterm with no joy. I have tried too as user root. Hmm.
speculatrix
hmmm. very odd, kismet runs fine from qtopia icon, it's just the command line that fails. very odd... but I do remember that the kismet shell wrapper for qtopia is a replacement for the command line script.
xjqian
QUOTE(speculatrix @ Nov 15 2006, 01:16 PM)
Error opening terminal: linux.

I have tried changing TERM to linux, vt100, xterm with no joy. I have tried too as user root. Hmm.
*

Did you export TERMINFO before export TERM
CODE
export TERMINFO=/usr/share/terminfo
export TERM=linux
speculatrix
aha, that appeared to do the trick... I've now realised that the k.sh script provided for the icon in qtopia is a completely separate thing to the kismet script.

thanks!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.