I am trying to get a JRE working in Pocket Workstation so that I can run applets from Konqueror/Firefox but there seem to be some missing dependencies in Debian arm:

#apt-get install kaffe
The following packages have unmet dependencies:
kaffe: Depends: kaffe-pthreads (-2:1.1.5-3) but it is not installable or
kaffe-jthreads (-2:1.1.5-3) but it is not installable
E: Broken packages

I have searched all over for precompiled packages but there doesn't seem to be a Blackdown build for Debian ARM, however, there is this ipaq build: http://mirrors.sunsite.dk/java-linux/JDK-1.3.1/arm/rc1/

How would I compile this for the Zaurus? I'm assuming that cross-compiling would be a good way to go, perhaps with something like http://scratchbox.org.

I'm happy to give it a go, just wondering if anyone has tried this already or has a good reason why it wouldn't work?