Help - Search - Members - Calendar
Full Version: Wpa With Linksys Wcf11 And Sharp Rom 3.13?
OESF Forums > General Forums > General Support and Discussion > Security and Networking
nax
I'm trying to connect to wpa AP but having problem to get working copy of hostap drivers. 3.13 Sharp rom running kernel 2.4.18-rmk7-pxa3-embedix. I'll also need to flash my linksys wcf11 because
ident: nic h/w: id=0x800c 1.0.0
ident: pri f/w: id=0x15 1.0.4
ident: sta f/w: id=0x1f 1.0.3

I already have installed wpa_supplicant, hostapd and hostap-utils from this feed:
http://mail.pdaxrom.org/contrib/Zaurus-5000D-5500/
but installation of hostap-driver fails with unresolved symbols. So I understand that I need other copy of hostap drivers.

Is it possible with 3.13, sl5500 and linksys wcf11 connect to WPA network?

Thank you
Hrw
if you will update card firmware to 1.7.4, get working hostap drivers and wpa-supplicant then yes.

But I do not know does anyone prepared them for SharpROM. OpenZaurus 3.5.4 should work with WPA out-of-box.
nax
I have tried Cacko 3.10 Rom with /home on SD card and Opera installed later. I also found hostap drivers compiled with firwmare upgrade support.

I have added to /etc/pcmcia/hostap_cs.conf this:
CODE
card "Linksys WCF12 11Mbps 802.11b WLAN Card"
  version "The Linksys Group, Inc.", "Wireless Network CF Card", "ISL37300P", "RevA"
  bind "hostap_cs"

(second line is grabed from output of 'cardctl ident'). Now I can see eth0 in ifconfig -a

But I still can't upgrade firmare, because strange errors:
CODE
# prism2_srec -v -f eth0 PK010101.HEX SF010802.HEX
... some outputs omitted ...

ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not permitted
Missing wlan component info
Could not read wlan RIDs


Anyone had same problems?
nax
I have upgraded firmware of CF card on my notebook, but I still can't make it working with this hostap. I thing 1.12 is too old for supporting wpa. With other (newer) hostap modules I'm getting unresolved symbols.

I have tried new OZ 3.5.4 but I'm feeling more comfortable with cacko 3.10 sl5500 rom. So it seems I'm going to rebuild cacko kernel after I find out kernel config.
nax
Now I have OpenZaurus 3.5.4 OPIE installed on my SL5500, upgraded firmware to this:

CODE
wifi0: NIC: id=0x800c v1.0.0
wifi0: PRI: id=0x15 v1.1.1
wifi0: STA: id=0x1f v1.8.4


but I sthill having problem to make it working on my home AP. I'm using Asus WL500G hw AP with WPA-PSK and TKIP. Problem is that zaurus see my AP as it don't support WPA:
CODE
Received 144 bytes of scan results (1 BSSes)
Scan results: 1
Selecting BSS from priority group 5
0: 00:11:d8:32:68:c7 ssid='nax.home' wpa_ie_len=0 rsn_ie_len=0
  skip - no WPA/RSN IE
No suitable AP found.
Setting scan request: 5 sec 0 usec


If I try to connect by my notebook (ipw2200 card, driver wext) it works:
CODE
Received 616 bytes of scan results (3 BSSes)
Scan results: 3
Selecting BSS from priority group 4
0: 00:11:d8:32:68:c7 ssid='nax.home' wpa_ie_len=26 rsn_ie_len=22 caps=0x11
  selected based on WPA IE
Trying to associate with 00:11:d8:32:68:c7 (SSID='nax.home' freq=0 MHz)


wpa_supplicant.conf is exactly same:
CODE
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
network={
       ssid="nax.home"
       psk="89977...dd4"
       key_mgmt=WPA-PSK
       pairwise=TKIP
       priority=5
}


Anyone know what might be problem?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.