Help - Search - Members - Calendar
Full Version: Alt-boot Sd Oz 3.5.4
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > OpenZaurus/Opie/Qtopia
Mase
Wow , lots of work went in to 3.5.4. Just tried it today and it's fantastic. Opie is very responsive, haven't had any errors / crashes and wifi just works. Thanks for a great release.

I am the proud owner of a 5500 which means i don't have enough memory to install konqeror and utilize my new found wireless goodness. I tried to install it with altboot using Advanced-> 8 in the boot menu, but it complained that it couldn't find rootfs.tar.gz

which file is the rootfs.tar.gz ? I downloaded the bootstrap-image-3.5.4-collie.initrd.bin on the OZ site , do i just rename this ?

thanks in Advance
Mase
Hrw
Hmm.. I have to repack tar.bz2 to tar.gz then

use files from images/collie/tarballs/ as rootfs.tar.gz
Mase
QUOTE(Hrw @ Mar 18 2006, 04:09 PM)
Hmm.. I have to repack tar.bz2 to tar.gz then

use files from images/collie/tarballs/ as rootfs.tar.gz
*



thanks HRW, the new .tar.gz files seem to make altboot happy, and i can do an install , but when it comes to actually booting it i get a whole heap of

/etc/init.d/rcS: 95 [: Input/output error
/etc/rcS.d/S40networking 9: [:Input/output error
...and so it goes on until the login prompt.

does my sd card need to be formatted vfat ? at the moment its ext2, i had it working with hentges 3.5.3 rom ok and the card seems fine when i write to it with various desktop machines.

do i need to copy the rootfs.tar.gz to the sd card? i was trying to install it from the cf card which i used to flash the zaurus to the sd card.
burned
hey speaking of vfat, I can't find mkfs.vfat anywhere to reformat my SD card -- which package contains it (i've pored through the list unable to find anything that sounds like it'd have filesystem utils)?

while i'm almost changing subjects, does a card need to be vfat to be recognized by the new (and really cool) card management icon? i've got socket 0 and 1, and when my collie has both SD and CF, it only says there's a CF even though I can mount & access the SD no problem.
CoreDump
QUOTE(Mase @ Mar 19 2006, 01:42 PM)
QUOTE(Hrw @ Mar 18 2006, 04:09 PM)
Hmm.. I have to repack tar.bz2 to tar.gz then

use files from images/collie/tarballs/ as rootfs.tar.gz
*



thanks HRW, the new .tar.gz files seem to make altboot happy, and i can do an install , but when it comes to actually booting it i get a whole heap of

/etc/init.d/rcS: 95 [: Input/output error
/etc/rcS.d/S40networking 9: [:Input/output error
...and so it goes on until the login prompt.


That sounds like a broken FS on that card, reformat and try again.
Hrw
mkfs.vfat is in dosfstools package
nax
Am I right that by altboot I can make my zaurus don't use internal flash for root but use sd as harddisk? But I still have to flash opie to internal flash memory (and kernel 0-64) and then set booting from my ext2 SD?

By this I'm able to make OpenZaurus last thing I really like on Cacko sl5500 3.10 ROM - SD is seen as internal memory.
telemetric_au
QUOTE(nax @ Mar 21 2006, 07:36 AM)
Am I right that by altboot I can make my zaurus don't use internal flash for root but use sd as harddisk? But I still have to flash opie to internal flash memory (and kernel 0-64) and then set booting from my ext2 SD?

.
*


yep thats the idea, except i cant get it to boot...
so at the moment im trying out hentges cardfs

[edit] its working now
http://www.oesf.org/forums/index.php?showtopic=18467&hl=
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.