Help - Search - Members - Calendar
Full Version: Usb Networking 5500 <-> Xp Oz 3.5.4
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
DavidFong
Dear all,

I have just installed 3.5.4 onto my old 5500, and can't wait to install OpenZaurus onto my C3100 when 3.5.4.1 is available!

I am having trouble networking my 5500 (with the OpenZaurus 3.5.4 ROM and Opie) to my Windows XP using the USB connection. I noticed that a linux.inf from Documentation/usb/ is available from the 2.6.x kernel source, which I tried to use. I modified all the references to 0525:a4a2 to 04dd:8004 in the linux.inf file (see attached, except the file is named linux.inf rather than linux.inf.txt). Windows XP accepts that the modified linux.inf file is for my 5500 machine, but later complains that the USB device (the 5500) is not working "a problem occurred during hardware installation, your new hardware may not work properly."

Trying to start usbd0 or usb0 on the 5500 fails to work, as could be expected, after Windows XP reports that the USB device is not working.

Any help would be appreciated, I would really like to access those 3.5.4 software feeds!

Otherwise, 3.5.4 looks really good!
Great work OZ team!

Cheerio, David.
lardman
The release for the 5500 uses 2.4.18, so the usb driver will be the same as it always was - use the inf file and driver that came with the original 5500 2.xx images. See the pinned thread in OZ/Common for a download link (iirc).

Si
DavidFong
Thanks lardman, and also a very special thanks to GenericAnimeBoy, who posted on 21st March 2006 into that 'pinned' thread 'USB Connection Howto' in this forum. AnimeBoy's instructions were detailed and precise, including information about creating a network bridge in Windows XP which I would never have guessed.

Sadly, the link to Zaurus 5xxx Windows network drivers is broken on the ZaurusUserGroup site. Thankfully, I still have my original Sharp SL5500 Windows CD. I think two drivers needed to be installed from that CD-ROM, Windows asked for another driver after installing the first one.

I found it helpful to untick and retick the 'DHCP' tickbox in usbd0's configuration window of the Settings->Network program. The Zaurus then, on my system, always seems to pick up a network address which is always in use (such as 192.168.1.12). Windows XP complains angrily. To fix up that problem, I untick and re-tick that DHCP box again, and another address is allocated.

Cheerio, David.

QUOTE(lardman @ Mar 19 2006, 10:22 AM)
The release for the 5500 uses 2.4.18, so the usb driver will be the same as it always was - use the inf file and driver that came with the original 5500 2.xx images. See the pinned thread in OZ/Common for a download link (iirc).

Si
*
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.