Help - Search - Members - Calendar
Full Version: New To Oz Questions
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
steven999
Hi All,

I've been a Zaurus user for a few years now (5600) and decided to try the new 3.5.4 OZ - Opie out. I think I have things beginning to work, but coming from Sharp based roms I have some questions.

I am using the package installer application and I tried to install kopi from the feed to SD. After installing, it gave me a lot of errors saying things like:

"Error Linking '/media/card/packages/opt/QtPalmtop/pics/kdepim/korganizer/fileexport.png' to '/opt/QtPalmtop/pics/kdepim/korganizer/fileexport.png'

and a whole list of other files which did not link. Is there something I'm not aware of I need to do? (My SD card is a vfat card, if it's of any use to know)

Also, is it possible to remove the bluetooth manager and applets? I tried but it always seems to fail in the package manager.

And is there a way to edit the applets bar to hide ones I'm not interested in?

Much thanks to everyone who put this together, I am thus far enjoying learning and exploring OZ! (And the progress since the last time I tried is noticable!)

steven
scheck.r
QUOTE
"Error Linking '/media/card/packages/opt/QtPalmtop/pics/kdepim/korganizer/fileexport.png' to '/opt/QtPalmtop/pics/kdepim/korganizer/fileexport.png'

and a whole list of other files which did not link. Is there something I'm not aware of I need to do? (My SD card is a vfat card, if it's of any use to know)

I think you need to format your card as EXT2 to support links.
steven999
So, if I don't want to format to ext2, I can't really install anything to SD? That seems strange as I can installl to SD with vfat using Sharp-based ROMS.

QUOTE(scheck.r @ Mar 20 2006, 02:07 PM)
QUOTE
"Error Linking '/media/card/packages/opt/QtPalmtop/pics/kdepim/korganizer/fileexport.png' to '/opt/QtPalmtop/pics/kdepim/korganizer/fileexport.png'

and a whole list of other files which did not link. Is there something I'm not aware of I need to do? (My SD card is a vfat card, if it's of any use to know)

I think you need to format your card as EXT2 to support links.
*

steven999
I used ipkg and ipkg-link to install to home instead of SD and that worked out alright. I guess this will be fine. Do most people install to home if there SD's are not formated ext2?
lardman
Yes, I'd install stuff to /home/packages (or similar) for your 5600.


Si
steven999
Thanks Lardman for the reply! I spent a good amount of time yesterday night tweaking and getting comfortable with OZ. I think things are working fairly well except the suspend/resume issue and so will be following the bugtracker and any info here very carefully.

QUOTE(lardman @ Mar 21 2006, 02:19 AM)
Yes, I'd install stuff to /home/packages (or similar) for your 5600.


Si
*
DavidFong
For some reason, using the 'package manager' to install software onto the SD card, I get similar errors...

Linking packages installed in : sd
Error linkling '/media/card/packages/opt/QtPalmtop/help/en/html/calculator.html' to '/opt/QtPalmtop/help/en/html/calculator.html'

and similar errors. Incidently, that 'linkling' is not my mis-spelling. It is the way it is actually spelt in the 'package manager'. Where do I lodge that bug-report?

My SD card is ext2 format. The 'calculator.html' file does exist on the /media/card, but the 'help' directory does not exist on /opt/QtPalmtop

Sometimes the package seems to have installed correctly anyway.

But 'ipkg-link list /media/card' does not work because "/media/card/usr/lib/ipkg/info/*.list" does not exist. In fact, the only directory on my /media/card is 'packages'

Does that help anyone know what is going wrong?

Cheerio, David.
lardman
QUOTE
But 'ipkg-link list /media/card' does not work because "/media/card/usr/lib/ipkg/info/*.list" does not exit. In fact, the only directory on my /media/card is 'packages'

Does that help anyone know what is going wrong?


Try:

ipkg-link list /media/card/packages


Si
DavidFong
Thanks lardman for such a quick reply, your suggestion works!

Well, I think I found the reason for the 'package manager' error.
Using the shell, I created the 'help/en/html' directory in /opt/QtPalmtop. The next time I installed a package using 'package manager', the calculator.html link was created without fuss.

Where can I report this error?

Postnote : I have submitted this as bug # 1755 on the Opie bugzilla.

Cheerio, David.

QUOTE(DavidFong @ Mar 23 2006, 02:14 AM)
For some reason, using the 'package manager' to install software onto the SD card, I get similar errors...

Linking packages installed in : sd
Error linkling '/media/card/packages/opt/QtPalmtop/help/en/html/calculator.html' to '/opt/QtPalmtop/help/en/html/calculator.html'

and similar errors. Incidently, that 'linkling' is not my mis-spelling. It is the way it is actually spelt in the 'package manager'. Where do I lodge that bug-report?

My SD card is ext2 format. The 'calculator.html' file does exist on the /media/card, but the 'help' directory does not exist on /opt/QtPalmtop

....
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.