Help - Search - Members - Calendar
Full Version: 5600 - 3.5.4 - Suspend With On/off = Freeze
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
steven999
Hi All,

I've been scouring the forum for info on OZ now that I have it installed. So far, certain things are working well, other things are problematic, but I'm interested to keep with it for a few days to see if I can get it working smoothly. Right now I'm experiencing something which I thought was fixed (but I guess I'm wrong) and that is if I try to suspend the 5600 with the On/Off button it just freezes hard and I have to open up the battery pack to hard restart it. I have an SD card and a Microdrive card in if that's of any useful knowledge.

Is there any logs I should check to see what is going on?

Any help appreciated!
steven
grog
I assume you're using OPIE? If so, we know smile.gif. I believe the menu Suspend option should work ok. That's all I can offer right now.
Hrw
http://www.oesf.org/forums/index.php?showtopic=17632 is good summary about SL-5600 'poodle' situation in OpenZaurus.
steven999
Thanks grog. I noticed in the bugtracker someone saying they installed an older version of apm/apmd and reported that worked but the bug was not closed out. Have you happened to try that? (I don't know where to find older OZ packages.)


QUOTE(grog @ Mar 21 2006, 04:29 AM)
I assume you're using OPIE? If so, we know smile.gif. I believe the menu Suspend option should work ok. That's all I can offer right now.
*
Hrw
steven: if opie then you can try apm/apmd/libapm* from OZ 3.5.3 as older packages. if you use GPE then this will not help.

But I think that this will not help at all. Did you flash correct kernel on poodle? pxa255 can be used only on pxa255 powered machines, pxa250 on any.
grog
The problem doesn't happen in GPE at all. Only when using OPIE.
steven999
Czesc Marcin,

I am using OZ-Opie 3.5.4 release now on 5600 with pxa250 which is correct for my model. It seems grok also has the same problems with Opie too.

BTW: The time is always reset when I restart the PDA after a crash or even if I initiate myself. Is this normal and a known issue?

Thanks all,
steven


QUOTE(Hrw @ Mar 21 2006, 07:40 AM)
steven: if opie then you can try apm/apmd/libapm* from OZ 3.5.3 as older packages. if you use GPE then this will not help.

But I think that this will not help at all. Did you flash correct kernel on poodle? pxa255 can be used only on pxa255 powered machines, pxa250 on any.
*
hvontres
QUOTE(steven999 @ Mar 21 2006, 12:01 PM)
Czesc Marcin,

I am using OZ-Opie 3.5.4 release now on 5600 with pxa250 which is correct for my model.  It seems grok also has the same problems with Opie too.

BTW: The time is always reset when I restart the PDA after a crash or even if I initiate myself.  Is this normal and a known issue?

Thanks all,
steven


If you are very carefull not to hold down the power switch for more than 2 seconds it can work. However, I would recomend using the menu or "apm --suspend" to turn off your 5600. Also, I have noticed that suspending it in the cradle and resuming it out of the cradle can cause problems.

Since the Poodle does not have a seperate hardware clock, the date will be lost on reset.
steven999
Yes, so far I am just using the suspend from menu and trying very hard to remember not to impulsively use on/off as I used to. As for hardware clock, I wonder then how it was possible for Sharp-based roms to keep time on restart?

I know on my laptop during suspend/resume I had to add some calls to hwclock to sync the system time to clock and back. I wonder if that could somehow be done with some services, stored in a file so that on a restart, the time will only have drifted a little so that the user has to maybe adjust a minute or two rather than having to enter in the whole hour/min/month/day/etc.

steven


QUOTE(hvontres @ Mar 21 2006, 11:43 AM)
If you are very carefull not to hold down the power switch for more than 2 seconds it can work. However, I would recomend using the menu or "apm --suspend" to turn off your 5600. Also, I have noticed that suspending it in the cradle and resuming it out of the cradle can cause problems.

Since the Poodle does not have a seperate hardware clock, the date will be lost on reset.
*
Hrw
We already keep date in /etc/timestamp which is loaded on boot and stored on reboot.

And all Zaurus models newer then collie does not have hardware clock.
grog
QUOTE(Hrw @ Mar 21 2006, 02:12 PM)
We already keep date in /etc/timestamp which is loaded on boot and stored on reboot.

And all Zaurus models newer then collie does not have hardware clock.
*

Not that I'm trying to hijack the thread, but at least for me this doesn't seem to be working. /etc/timestamp hasn't been touched in all of the clean reboots I've done:

CODE
grog@poodle[/etc]$ ll timestamp
-rw-r--r--    1 root     root           13 Dec 31  1969 timestamp
grog@poodle[/etc]$ cat timestamp
031415512006

I've checked the /etc/init.d/reboot script & it's coded properly, so as long as /sbin/reboot util is called without parameters, and that just sets the run level to 6, then init should take over & the init.d script is called. But that doesn't seem to be happening.
steven999
Hi Grog,

I checked too and the timestamp file wasnt updated for me either. I ran the date line in the reboot script from the commandline and that updated so the script seems fine. I shutdown the PDA using the shutdown menu option from the O menu and on restart it used the updated time from timestamp, but it set it 8 hours behind what it was (I am in GMT -8:00). So, it seems that either the reboot script needs to write the GMT time and not local time, or on restart whatever script is setting the time from the timestamp needs to know the timezone.

Should we enter this into one of the bugtrackers, and if so, which one?

steven


QUOTE(grog @ Mar 21 2006, 12:47 PM)
I've checked the /etc/init.d/reboot script & it's coded properly, so as long as /sbin/reboot util is called without parameters, and that just sets the run level to 6, then init should take over & the init.d script is called. But that doesn't seem to be happening.
*
steven999
Question: should there be an /etc/localtime file that points to one in /usr/share/zoneinfo? I was reading around about the date function and it defaulting to UTC if none is found, but I don't know exactly what the /etc/localtime file is and am only guessing.

QUOTE(steven999 @ Mar 21 2006, 01:44 PM)
Hi Grog,

I checked too and the timestamp file wasnt updated for me either.  I ran the date line in the reboot script from the commandline and that updated so the script seems fine.  I shutdown the PDA using the shutdown menu option from the O menu and on restart it used the updated time from timestamp, but it set it 8 hours behind what it was (I am in GMT -8:00).  So, it seems that either the reboot script needs to write the GMT time and not local time, or on restart whatever script is setting the time from the timestamp needs to know the timezone. 

Should we enter this into one of the bugtrackers, and if so, which one?

steven


QUOTE(grog @ Mar 21 2006, 12:47 PM)
I've checked the /etc/init.d/reboot script & it's coded properly, so as long as /sbin/reboot util is called without parameters, and that just sets the run level to 6, then init should take over & the init.d script is called. But that doesn't seem to be happening.
*

*

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.