Help - Search - Members - Calendar
Full Version: Cl4/t-sinuspad Support
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > SIMpad forum
fredyd
Here's a message from that topic, can anyone help identify that bootloader?
Berend, could you please transfer it back to the PC, using the "save" bootloader command (see http://www.handhelds.org/handhelds-faq/bootldr.html), so that we can archive it somewhere?
Concerning a modern image suitable for the CL4/TSinuspad, what do you (CL4 users) think of this one: http://devernay.free.fr/hacks/opensimpad/2...ad.rootfs.jffs2

I removed games, some themes, etc. so that it's now under 13Mb. It still has the wonderful gpe-mini-browser. After installation, you can still customize it by adding/removing packages. (for the future: if the link above is dead, try browsing from http://devernay.free.fr/hacks/opensimpad/ )

QUOTE(Berend @ Mar 18 2006, 02:03 PM)
I've put some personal CL4 notes below, For now I'll await reactions here.

QUOTE
I was wondering if the following was the most recent version of the hh.org bootloader:
http://opensimpad.org/bootldr-simpad/blupdater.img
Do you remember if you finally got it to work on the CL4/sinuspad?
*


the bootloader does work on the CL4's with a bit of effort, but I'm not sure anymore which one I'm using, I find it hard to keep all the versions apart and I've tried several of them. It identifies itself as:
CODE
>> Compaq OHH BootLoader, Rev 2-21-13 [BIG_KERNEL] [MD5] [MONO]
>> 04-11-20_15:58
>> Last link date: Sat Nov 20 15:58:14 GMT 2004
>> Contact: bootldr@handhelds.org


Before loading a new image, the partitions must be set by hand to prevent the pad from erasing beyond its memory boundaries. After the first boot the partition table can be put into /boot/params and it will boot without further trouble. I'm thinking maybe this could be packaged into an image?

Then there's the problem of finding an image. Most images won't fit in the 16MB, I build a standard gpe-image which resulted in 20 MB. After leaving most of the GPE apps out it is possible to get it down to about 14MB, but such an image is hardly usable. If it's much larger the first boot will fill all space left with the initial configuration.

Plucker works, but I'm not real friends with it and have to resort to reading plain text in a console. Cumbersome, but at least I can read in bed. Also there's some strange freeze/crash which I haven't reproduced yet.

CODE
boot> partition delete root
boot> partition delete home
boot> partition define root 0x40000 0xe00000 16
boot> partition define home 0xe40000 0x1c0000 0
boot> load root
(load image via ymodem, the pad will check the image, erase flash and write it)
boot> boot

I'm not sure what the partition types should be but I found these somewhere and they work.

/boot/params
CODE
set linuxargs "mtdparts=sa1100:0x00040000@0x00000000(bootldr)ro,0x00fc0000@0x00040000(root) noinitrd root=/dev/mtdblock1 init=/linuxrc console=ttySA0 rootfstype=jffs2 jffs2_orphaned_inodes=delete mem=32M"

*

Berend
Hi Fred,

I really appreciate the effort, 13MB sounds nice. But I'm afraid I can't try the image anymore, see my other topic.

I looked through some notes and I'm sure blupdater.img (this one) is the bootloader I was running. Since I think a lot of opensimpad's would be running this one, someone could still check their terminal to see what it says.
Olle
Hi,

i'm using a Swisscom WP50 and checked my BL.

and this is printed out

>> Compaq OHH BootLoader, Rev 2-21-13 [BIG_KERNEL] [MD5] [MONO]
>> 04-11-20_15:58
>> Last link date: Sat Nov 20 15:58:14 GMT 2004
>> Contact: bootldr@handhelds.org


i loaded this bl from opensimpad.org
http://opensimpad.org/bootldr-simpad/blupdater.img

[Edit]
I tested your GPE-image and it stops while configuring

--------------------------

blahblah........
$** can't synthesize pci hotplug events
Setting up IP spoofing protection: rp_filter.
Configuring network interfaces... done.
Starting portmap daemon: portmap.
Mon Mar 20 22:09:00 UTC 2006
Configuring base-files
ln: /etc/resolv.conf: File exists
Configuring dbus-1
System startup links for /etc/init.d/dbus-1 already exist.
Configuring gdk-pixbuf-loader-jpeg
Configuring gdk-pixbuf-loader-png
Configuring gdk-pixbuf-loader-xpm
Configuring hostap-modules-2.4.27-vrs1-pxa1-jpm1
Configuring hostap-modules-cs-2.4.27-vrs1-pxa1-jpm1
Configuring locale-base-de-de

----------------------------

thats all i got via console

[edit2]

just upload the opie-image and its works fine,
Berend
I've tried the opie image and it seemed to run fine.

The gpe image freezes on the first boot while configuring of the locales . I managed to complete the install by quickly pressing Ctrl-c before it locked up.
There was no mini-browser though. I tried osb browser but that has a lot more dependencies, dillo works fine (no CSS).

I've used MMC, irda, everything seems ok except that programs get killed a lot:
CODE
__alloc_pages: 0-order allocation failed (gfp=0x1d2/0)
VM: killing process matchbox-deskto
mcp: write timed out
mcp: write timed out
__alloc_pages: 0-order allocation failed (gfp=0x1f0/0)
__alloc_pages: 0-order allocation failed (gfp=0x1f0/0)
__alloc_pages: 0-order allocation failed (gfp=0x1d2/0)
VM: killing process gpe-conf
__alloc_pages: 0-order allocation failed (gfp=0x1d2/0)
VM: killing process Xfbdev
mcp: write timed out

Am I running out of memory? can I do something about that?

edit: and while MMC works fines it reports:
CODE
mmc: GPIO init
mmc: initialising MMC
GPIO_SD_CS dir: 1 alt: 0
GPIO_SD_DI dir: 1 alt: 0
GPIO_SD_DO dir: 0 alt: 0
GPIO_SD_CS dir: 1 alt: 0
mmc: card init 1/2
mmc: card init 2/2
mmc: card init 3/3
Size = 31360, hardsectsize = 512, sectors = 62720
Partition check:
mmca:end_request: I/O error, dev 79:00 (mmc), sector 0
end_request: I/O error, dev 79:00 (mmc), sector 2
end_request: I/O error, dev 79:00 (mmc), sector 4
end_request: I/O error, dev 79:00 (mmc), sector 6
end_request: I/O error, dev 79:00 (mmc), sector 0
end_request: I/O error, dev 79:00 (mmc), sector 2
end_request: I/O error, dev 79:00 (mmc), sector 4
end_request: I/O error, dev 79:00 (mmc), sector 6
unable to read partition table
FAT: bogus logical sector size 0
VFS: Can't find a valid FAT filesystem on dev 79:00.


What's this 'unable to read partition table'? Could the I/O errors be caused by an old (~6 years) MMC card?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.