Help - Search - Members - Calendar
Full Version: Is There A List Of All Packages By Priority
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
samac
I would like to free up a bit of space on /dev/root by unistalling some packages and the re-installing them to SD.

However, I am sure that there are some that cannot be moved, as it would interfere with the workings of OZ.3.5.4

So is there a complete list of packages that is available, and is it marked ESSENTIAL, RECOMMENDED, OPTIONAL

With the understanding that:

ESSENTIAL should not be moved
RECOMMENDED could be moved but will perform better if left alone
OPTIONAL put it on the SD or CF card

If there isn't a list would it be possible to get one started.

Samac
Hrw
First I usually remove what I do not need:
- kernel modules for cards which I do not own/use
- lrzsz
- everything related to ppp
- on collie I remove module-init-tools-depmod
- on 2.6 machines I remove modutils-depmod
- portmap and everything related to NFS (few kernel modules)
- if no wifi then remove everything WiFi related: wireless-tools, wpa-supplicant*, hostap*, orinoco*

Then start selecting what can be moved to card:
- whole opie (I usually move /opt/ dir and provide one symlink: /media/card/opt/ -> /opt/ so I can install to / and it end on SD)

I never used GPE for longer time so cannot tell what can be moved what not - with GPE I would rather move whole system to SD.
samac
Many thanks, I will get started.

I especially like the /opt move and symlink.

If you did feel a list that offered more detail like description, usefulness, kernel, opie/gpe, dependencies would be useful, just send me all the details over and I will see what I can do.

Samac
samac
OK I moved /opt and /home to /media/card and then symlinked back. Worked perfectly and released 7000K storage on /dev/root.

This could be added to a script at first start up.

Do you wish to move /opt and /home to your SD/CF card?

It would make sense.

Samac
samac
OK has not worked perfectly.

All the applications work, but the network is now down.

I can connect to the Zaurus by ping and ssh, but the Zaurus cannot get out to the internet via my gateway.

When I try to update ipkg I get the following error

QUOTE
ipkg_download: ERROR: Command failed with a return value 1: `wget --passive-ftp -q -p /tmp/ipkg-Aqedg http://feed name
An error ocurred, return value: 5.


I would hold off moving until this is figured out.

Samac

EDIT: Putting the /opt directory back on / fixed the problem, could it have been the way I linked the file, which operators do you use HRW.
Hrw
mount /media/card
mkdir /media/card/opt
mv /opt /media/card
ln -s /media/card/opt /opt

reboot
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.