Help - Search - Members - Calendar
Full Version: Networking, Updated Rom
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
microsoft/linux
I recently updated to the 3.5.4 GPE image, and my USB networking ceased to work. I reset the usb0 configuration to what it was before, but my computer's still not recognizing it. Suggestions?

I'm running Debian Etch on my laptop.
jan
QUOTE(Hrw @ Mar 23 2006, 09:34 AM)


Hrw, I appreciate all your work on OZ but this is NOT helpfull.

1. microsoft/linux knows how to set up usbnet in general. The problem lies either in OZ3.5.4 or in GPE. The linked thread is older than 3.5.4 and not GPE specific

2. in http://www.oesf.org/forums/index.php?showt...1785&pid=106068 lardman says clearly "this is a thread giving details about how to get connections working, not to ask about how to get them working; start a new thread." The thread doesn't seem to answer the problem

3. I had the same problem. While OZ3.5.3/OPIE worked, OZ3.5.4/GPE wouldn't. The solution for me was 'modprobe g_ether' and replug USB, but I'm not going to add this to a How-To unless someone confirms this is the "right way" to do it. For me, it's a bug work around. BTW: What is the USB applet in GPE supposed to do if not make sure that g_ether gets loaded?


jan
microsoft/linux
doing modprobe g_ether, is that on the desktop or the Z? Other suggestions?
Hrw
modprobe g_ether on Zaurus/2.6
modprobe usbnet on desktop

jan: Oz 3.5.3 was released with 2.6.11 for c7x0 - nothing changed since that release when it comes to usb networking on Zaurus side - 2.4.18 machines still has the same modules, 2.6 powered machines still has the same modules names - thats why I send to 'usb networking' thread. People often create new threads without checking others.
lardman
QUOTE
modprobe g_ether on Zaurus/2.6


Note that this is only for the 2.6.x kernel machines.

For the 5500, things are just as they used to be (though some scripts may have changed which might explain some troubles - I don't know) and you should base your settings on any of those listed in the HowTo (http://www.oesf.org/forums/index.php?showtopic=11785&pid=106068) for the 5500.

Cheers,


Si
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.