Help - Search - Members - Calendar
Full Version: Qpdf2 - 3.5.4 - Segfault
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
steven999
Hi All,

Using OZ 3.5.4 on 5600, trying out QPDF2 with PDF results in segfault when I get to a page that has text to render. Other PDF's seem to be fine when they are image only. Any one experience this or have ideas? Running from console, I don't get anything for an error message but Segmentation Fault.

Thanks,
steven
Greg2
QUOTE(steven999 @ Mar 23 2006, 02:43 AM)
Using OZ 3.5.4 on 5600, trying out QPDF2 with PDF results in segfault when I get to a page that has text to render.

It’s working just fine for me... I can even change from pdf to text format without any problems.

Have you installed the qpf-font-common and a qpf-font package with qpdf2?

Greg
steven999
Hi Greg,

QPDF2 was installed when I flashed the ROM, but no qpf packages at all were installed (seems like a bug?). I installed qpf-font-common, but there's a lot of qpf-font packages. Can you recommend one to use or should I install all of them?

Thanks,
steven


QUOTE(Greg2 @ Mar 23 2006, 08:19 AM)
QUOTE(steven999 @ Mar 23 2006, 02:43 AM)
Using OZ 3.5.4 on 5600, trying out QPDF2 with PDF results in segfault when I get to a page that has text to render.

It’s working just fine for me... I can even change from pdf to text format without any problems.

Have you installed the qpf-font-common and a qpf-font package with qpdf2?

Greg
*

Greg2
QUOTE(steven999 @ Mar 23 2006, 01:00 PM)
I installed qpf-font-common, but there's a lot of qpf-font packages.  Can you recommend one to use or should I install all of them?

I’ve only installed qpf-dejavusans-110 on my collie and poodle for this to work properly for the small screens. I ‘believe’ that whatever qpf font you prefer will work?

Greg
steven999
Hi Greg,

Thanks! I installed the same font package and am now able to read in text mode. In visual mode, I get some crashes when rendering with embedded fonts, but seem to get better results when not using embedded fonts. Otherwise, seems to be working now, so much thanks!

steven



QUOTE(Greg2 @ Mar 23 2006, 11:19 AM)
QUOTE(steven999 @ Mar 23 2006, 01:00 PM)
I installed qpf-font-common, but there's a lot of qpf-font packages.  Can you recommend one to use or should I install all of them?

I’ve only installed qpf-dejavusans-110 on my collie and poodle for this to work properly for the small screens. I ‘believe’ that whatever qpf font you prefer will work?

Greg
*

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.