Help - Search - Members - Calendar
Full Version: trying to get 3.3.6-pre1 on 860
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
b2bpro
I've been trying to flash 3.3.6-pre1 on my 860 without any luck.

I copied initrd-gcc3.bin, zimage-boxer.bin, updater.sh and the ipks dir from

http://www.openzaurus.org/official/experim...860/3.3.6-pre1/

Renamed appropriately to initrd.bin and zimage.bin (I've also tried zImage.bin, zimage and zImage)

I've repartitioned my memory back to 50 megs from the 25 megs used with tkc.

I've tried re-downloading the files and I've tried flashing from both my cf and my sd card.

Nothing works. It runs through the flash process, but then hangs at the black screen with the openzaurus logo with the little green dinosaur.

I've read through all the posts I've seen so far and there is nothing that has helped. Has anyone been able to get 3.3.6-pre1 running on an 860?
Anonymous
Probably you need to erase the user partition: enter the service menu and press 3 while powered on.
Though, oz336-pre1 doesn't run smoothly like other roms...but the work progressing.
b2bpro
Good idea, but still no go.

sigh
Anonymous
Please checkyou have exactly these three files on your cf/sd :

updater.sh , zimage.bin, initrd.bin, ipks.tar.bz2
Anonymous
Three + ipks.tar.bz2 = 4 of course....
b2bpro
interesting, but still not working. I had initially put the ipks directory on my sd card rather than the bz2 file so I tried again using the bz2 file.

Still just hangs at the OZ splash screen. Do I need to let it sit for a while ?

Also the way I am flashing is this.
1 - remove battery and power
2 - wait 10 seconds
3 - replace battery
4 - slide battery cover lock switch to closed
5 - plug in power
6 - press and hold ok button on keyboard
7 - press power on button on back of unit (still holding OK button)
8 - option 4 then sd then Yes (have also used cf)
9 - wait - hangs at openzaurus screen

since this hung, tried continuing with the following

10 - redo steps 1 to 7
11 - option 3 then Yes
12 - wait - hangs at openzaurus screen

I know this is a pre release version so I don't expect it to do everything right, but I had expected at least to be able to get it installed. My primary use of my Z is the pim apps. I am currently using tkc with the opie pim as it works better than the sharp ones. I was wanting to find out if some of the glitches in the pim have been corrected in this newer version. I also like the look of oz and wanted to give it a try (I could never get 3.3.5 to work right on my 860 either)

Is there any estimated release date for the 3.3.6 final version?
Mickeyl
There won't be a 3.3.6 final. As written in the OOO newsletter, the 3.3.x series has been abandoned. After the migration to the new build system OpenEmbedded has been completed, we're resuming work on OpenZaurus. The next OpenZaurus release will be OpenEmbedded/Zaurus 3.5.1.

Can't resist to invite all of you again to help us with OpenEmbedded and OpenZaurus. Look at the ToDo's @ openembedded.org biggrin.gif
Anonymous
>Still just hangs at the OZ splash screen. Do I need to let it sit for a while ? <

yes, it will need 3-4 minutes to uncompress the packages...
I've flashed OZ a month ago so I don't remember exactly but i believe "unpacking, please wait" or something similar should appears on the command prompt under the logo
alexy
Just a few suggestions. I myself was stuck in exactly the same
situation while flashing C760 with 3.3.6-pre1 - OZ logo and
forever flashing cursor. In my case the situation resolved easily -
my initrd.bin got corrupted and because there are no md5sums
on the website it was hard to detect. Re-downloading and
checking that the size is right helped.

If that doesn't help then there was some idea that badblocks in nand
might prevent OZ from flashing properly. Does your C860 have
any badblocks? In my personal opinion it is no problem for flashing
as my 760 has a badblock but still I managed to flash it many times.

--Alex Y.
b2bpro
how do you test for bad blocks in nand?

- I just tried and found that there are 2 bad blocks. Does this mean I am just out of luck? I suspect i'll just stick with what I have.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.