Help - Search - Members - Calendar
Full Version: Ipkg Update Problems
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
nick88
Hi,

I'm new to the Opie ROMS on my Zaurus 5500 (tried both 3.5.3 & 3.5.4). I got the system to boot and when I did and told the package manager to update the list of packages, it hung (package manger stop responding). I've been able to ping from the console to various sites on the internet (with DNS lookup working), so I know the system can hit the 'net, but when ikpg update runs it just sits there - I've literaly waited hours before giving up on the download. I'm running the 54+8 images, if that makes a difference.

Can anyone suggest what I might be doing wrong? I've looked at the various docs and what they seem to say is all I need to do (w/ the new ipkg.conf in 3.5.4) is to do a ipkg update to get the new candidate list.

Thanks.
lardman
You've run ipkg update from the command line?

How fast is your connection?


Si
nick88
My connection to the 'net is 1.2 Kbps/329 Kbps (ADSL), I'm using a serialio USB adapter from the Zaurus to Linux PC (which then goes to my DLINK 614 router) at 100 MBPS.

One thing I noticed is when I do start the ipkg update, ifconfig shows no new network traffic - so I'm thinking it is not retrying to connect to the site. If I ping from the Zaurus console, it does update the bytes sent/received count.
lardman
Are you behind a proxy?

I had some issues with proxies & wget (which is used by ipkg) - in the end it turned out I had to add a trailing / to my http_proxy (this is/was a bug with busybox).

So that I had http_proxy=http://www.someproxy.org.uk:3128/


Si
pgas
QUOTE
Are you behind a proxy?

it worked for me with

option http_proxy http://proxy.com:80

in /etc/ipkg.conf
nick88
AFAIK I'm not behind any proxy's - I've got a firewall that does NAT and the PC that has the Z connected is also NAT'd. Stupid question - do I need to configure anything more on the Z?

I have for my NAT rules on my PC:

iptables -t nat -F
iptables -t nat -A POSTROUTING -j SNAT -o eth0 --to-source $LOCAL_IP
echo 1 >/proc/sys/net/ipv4/ip_forward

I can wget the files from my PC that is also connected to the Z, but just not from the Zaurus.
nick88
Ok, it is something I'm doing wrong between the PC and the Zaurus - I connected up my 802.11 CF card and disabled WEP (I'll figure out why later) and was able to do a ipkg update over the wireless LAN.

Any suggestions? Here is the mode I was trying to make work:

Z <-> PC/NAT <-> Router <-> Internet

vs.

Z <-> Router <-> Internet
lardman
Not my area of expertise, you may get more views if you start a new thread with a title specific to the networking problem.

Also take a look at the pinned usb networking HowTo in the oz/common part of the forum, this has a number of Linux setups described.


Si
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.