Help - Search - Members - Calendar
Full Version: "no Space Left On Device" When Booting
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
VoiDeR
I keep getting "No Space left on device" messege when i try to boot a fresh install of OZ 3.5.4. I had pdaxrom on the before and that worked fine. I think it has something to do with the flash partition being the wrong size but im not sure how to restore it. I have a sl-c700 and the manual and cd are all in japanees so i dont know how to restore to factory settings. Im not sure where to go from here.
pgas
if you know the original partition size, you can try to use the pdaxrom installer and resize before installing openzaurus.

To go back to factory settings, you can try a Nand restore using the service menu:
http://downloads.conics.net/pda/zaurus-sl-.../service-menus/
VoiDeR
I tried using the pdaxrom installer to resize be no matter what size i tried it was always the same. Ill stick with pdaxrom but i cant get my connectplus wireless card working. But thats going to be another thread.
VoiDeR
I dont know understand what i could be doing wrong does anybody know what size it should be? I would do the nand restore but my cf card is only 64megs and the nand file is 67megs.
lardman
Try setting the rootfs parition to ~30MB then.

That ought to be about right and should fit the flash rootfs image.


Si

P.S. It may not work of course, but unless you can find a larger Cf card you can't do much else
hQuin
I got this too, coming from pdaxrom / cacko. Make sure your /home/root/Settings folder is actually a folder and not a broken symlink. If it IS a broken symlink, back up whatever you need and try

rm -rf /home/*

and reboot. Default settings will be created (lardman & hrw helped me with this one last week).

hQuin.
VoiDeR
I cant even get it to a login prompt to check! Ill try letting it sit and see if it will eventually get to tfhe login.
Hrw
Heh.. why people do not add info which exactly Zaurus they have into signatures... same for location sad.gif
VoiDeR
QUOTE(Hrw @ Mar 27 2006, 11:02 AM)
Heh.. why people do not add info which exactly Zaurus they have into signatures... same for location sad.gif
*


I posted what Z i have in the initial post at the top. Besides i dont see your Z model in your sig tongue.gif Oh and this is with the e-image.
Hrw
sorry - I read most of OZ related threads so forget what people wrote in first post. "No space left" is mostly collie problem so I'm suprised that this also can be shown on c7x0 machine.

And why I do not have Z in .sig? Do not remember - will add wink.gif
VoiDeR
Ok so it was getting to the log in propmt i just couldnt see it becuase the messeges written to the screen. I login and nothing. I got the root # and thats it. If i let it sit login for a min it logs it logs out automaticly. I tried to rm -rf /home/* and it says

Unable to handle kernel paging request at virtual address 50745133

then it spews a lot of numbers that fill the screen.
VoiDeR
Seems to be an e-image problem. Gpe installed just fine. Im going to give opie a try next and see how that works out.
VoiDeR
Opie works just fine to.
zmiq2
Hi,

these problems with e-image also happened to me and my c750. I reported it here,

http://www.oesf.org/forums/index.php?showtopic=18318

on posts #9 and #22, but got no response so far. I then tried GPE and worked like a charm too. I wonder if the problem is with our small-flash equipped models.

I really look forward to see my c750 running e17 !!
VoiDeR
I hope someone gets it working becuase i would like to see some screenshots.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.