I've created many access points with the hostap modules. I can't seem to get a client to associate to this here zaurus sl5500. Here's the basic testing lines...Oh, card is linksys wcf12.

zaurus
---------
ifconfig wlan0 10.0.0.1 up
iwconfig wlan0 essid kava
iwconfig wlan0 channel 6
iwconfig wlan0 mode master
iwconfig wlan0 key off

ifconfig wlan0 && iwconfig wlan0

wlan0 Link encap:Ethernet HWaddr 00:0C:41:DD:67:DE
inet addr:10.0.0.1 Bcast:10.255.255.255 Mask:255.0.0.0
inet6 addr: fe80::20c:41ff:fedd:67de/10 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 cool.gif TX bytes:360 (360.0 cool.gif
Interrupt:35

Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 16, therefore some driver features
may not be available...

wlan0 IEEE 802.11b ESSID:"kava"
Mode:Master Frequency:2.417 GHz Access Point: 00:0C:41:DD:67:DE
Bit Rate:11 Mb/s Sensitivity=1/3
Retry min limit:8 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:22 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:9671 Missed beacon:0

Kismet on future client sees him, open and ready for clients...

Then on client I do, as always and has worked till the zaurus testing...

ifconfig wlan0 10.0.0.2 up
/sbin/iwconfig wlan0 mode managed channel 6 essid kava key off

dmesg is status disconnected line after line...

This has always worked till now, so there's a gotcha in here somewhere with the zaurus, any clues forum?

thanks again,
cg