Help - Search - Members - Calendar
Full Version: 1.1.0beta1: Interactive Boot Sequence?
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
rrnwexec
Hi,

I did something (silly) and installed ntp to my working system (1.1.0beta1 on 6000). Now every time I boot the Z i get the following messages, then nothing... the system just hangs:

ntpdate[291]: no servers can be used, exiting

I suspect that this is due to ntp wanting/needing to query ntp servers on the internet. Instead of ntp timing out, it just hangs the whole boot process. Nasty.

Is there a way to boot interactively so I can tell the system not to launch ntp, then go in and remove it?

Failing that, any other suggestions?

thanks in advance,
Randall
karlto
QUOTE(rrnwexec @ Mar 28 2006, 10:26 AM)
Hi,

I did something (silly) and installed ntp to my working system (1.1.0beta1 on 6000). Now every time I boot the Z i get the following messages, then nothing... the system just hangs:

ntpdate[291]: no servers can be used, exiting

I suspect that this is due to ntp wanting/needing to query ntp servers on the internet. Instead of ntp timing out, it just hangs the whole boot process. Nasty.

Is there a way to boot interactively so I can tell the system not to launch ntp, then go in and remove it?

Failing that, any other suggestions?

thanks in advance,
Randall
*


That seems strange - normally it does exit fine. Are you sure it isn't the next command in the script hanging?

If it is ntp, can't you just connect up the Z so it has Internet access to get it booted?

I know of no way to get an interactive boot - normally something like this might be done by passing parameters to the bootloader prompt...
rrnwexec
QUOTE(karlto @ Mar 27 2006, 02:52 PM)
That seems strange - normally it does exit fine. Are you sure it isn't the next command in the script hanging?

If it is ntp, can't you just connect up the Z so it has Internet access to get it booted?

I know of no way to get an interactive boot - normally something like this might be done by passing parameters to the bootloader prompt...
*


Yeah, I'm pretty sure it's ntp. Unfortunately, I don't have the ability to connect to the internet as I normally invoke internal wifi manually using a script to change my ESSID and WEP parameters once the Z is booted up. It doesn't enable my wifi setup by default.

I was hoping there's an escape sequence that can get me into a shell to edit rc.d, or whatever is starting NTP... the boot sequence seems to progress far enough that some shell should be accessible (I hope)... yet I don't know how to get to it.

Cheers,
Randall.
rrnwexec
Some other observations:

The last several lines before the boot process hangs are:

CODE
Starting crond            [OK]
Looking for host time.nist.gov and service ntp
Error : Temporary failure in name resolution
28 Mar 00:56:37 ntpdate[283]: can't find host time.nist.gov
28 Mar 00:56:37 ntpdate[283]: no servers can be used, exiting


... then it hangs. I've left it for over 30 minutes to see if it will come back to life, but it doesn't. After 5 minutes or so, I noticed that the mail LED starts blinking. Maybe root has mail wink.gif

Any thoughts?
Bundabrg
Couple things. They're mostly shots in the dark and may be wrong, but I'm too tired to double check them right now: -
- Try 'Ctrl-C'. I think Ctrl is mapped to the calendar key at this time

- Grab the pdaXrom bootflash images, and boot with them. Then instead of reflashing, choose the option that drops to a terminal, mount your root and remove the offending entry.

- The above may also be achieved I think by entering the diagnostic boot (remove battery, hold D+B I think, put battery in again)

I think the middle option is the most likely to succeed ;-)

- Bundabrg
karlto
QUOTE(Bundabrg @ Mar 28 2006, 12:58 PM)
Couple things. They're mostly shots in the dark and may be wrong, but I'm too tired to double check them right now: -
  - Try 'Ctrl-C'. I think Ctrl is mapped to the calendar key at this time

  - Grab the pdaXrom bootflash images, and boot with them. Then instead of reflashing, choose the option that drops to a terminal, mount your root and remove the offending entry.

  - The above may also be achieved I think by entering the diagnostic boot (remove battery, hold D+B I think, put battery in again)

I think the middle option is the most likely to succeed ;-)

- Bundabrg
*


Good thought - just like a boot CD. I agree that the first option probably won't work because that's the problem to start with - everything's responding, but until it boots it doesn't accept input.
rrnwexec
Thanks Bundabrg and karlto.

For reasons unbeknownst to me, the Z "decided" to boot this morning. I didn't change anything, was planning to do that as soon as it hung once more. I guess it sensed that I was about to crash its party wink.gif

It came up with the usual error messages at boot:
CODE
28 Mar 00:56:37 ntpdate[283]: can't find host time.nist.gov
28 Mar 00:56:37 ntpdate[283]: no servers can be used, exiting


but this time it recovered after about 5 or 10 seconds.

So, now that I was able to get in and take a look around I noticed that I had installed ntp, ntpd and ntpdate in a strange way...
ntp was installed on /
ntpd was installed on /mnt/card
ntpdate was installed on /mnt card

Thinking that wouldn't be good, I removed the three packages above and reinstalled all of them to /

The install of ntpd gave me a warning:
CODE
Installing ntpd ... /etc/rc.d/init.d/ntpd : timezone not configured
Please create a symlink from /etc/localtime to your appropriate /usr/share/zoneinfo file.


so I dropped into the shell and made the following entry..

CODE
ln -s /usr/share/zoneinfo/US/Pacific /etc/localtime


typed reboot and crossed my fingers...

The reboot worked, but with errors...
CODE
.
.
.
Loading USB modules:             [  OK  ]
Synchronizing network time: ..........network is down.
Starting network time daemon: ntpd
Starting system message bus:  [  OK  ]
Starting crond:                        [  OK  ]
Looking for host time.nist.gov and service ntp
Error : Temporary failure in name resolution
28 Mar 00:56:37 ntpdate[593]: can't find host time.nist.gov
28 Mar 00:56:37 ntpdate[593]: no servers can be used, exiting

pdaXrom 1.1.0beta1 "Kathrin"
zaurus login:


Any suggestions on how to:

1) remove the delay after "Synchronizing network time..." (it's approx 10 seconds) ?
2) prevent ntpdate from looking for time.nist.gov at boot?
3) use crond to invoke a time adjustment at some predetermined time after boot, say 15 minutes, but only if there is an internet connection? Essentially, I don't want time checking at boot, only want it later.

Thanks,
Randall.
karlto
QUOTE(rrnwexec @ Mar 29 2006, 06:10 AM)
The reboot worked, but with errors...
CODE
.
.
.
Loading USB modules:             [  OK  ]
Synchronizing network time: ..........network is down.
Starting network time daemon: ntpd
Starting system message bus:  [  OK  ]
Starting crond:                        [  OK  ]
Looking for host time.nist.gov and service ntp[QUOTE]
Error : Temporary failure in name resolution
28 Mar 00:56:37 ntpdate[593]: can't find host time.nist.gov
28 Mar 00:56:37 ntpdate[593]: no servers can be used, exiting

pdaXrom 1.1.0beta1 "Kathrin"
zaurus login:


Any suggestions on how to:

1) remove the delay after "Synchronizing network time..." (it's approx 10 seconds) ?
2) prevent ntpdate from looking for time.nist.gov at boot?
3) use crond to invoke a time adjustment at some predetermined time after boot, say 15 minutes, but only if there is an internet connection? Essentially, I don't want time checking at boot, only want it later.

Thanks,
Randall.
*

Short of removing it from your startup scripts and running it manually?

Why not forget about ntpd and just run ntpdate in a cron script every 15 minutes, e.g.:

CODE
#!/bin/sh
if [ -n "$(ifconfig wlan0 | grep UP)" ]; then
  ntpdate
fi


You could also run it before or after suspend etc...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.