Help - Search - Members - Calendar
Full Version: Need Help Install 3.5.1-alpha
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
btanoue
Hi,

I got the 3 files and named them correctly
kernel->zImage.bin
opie->initrd.bin
updater.sh

After the flash, I see the kernel installed :-)

But the screen goes blank for a while, the mail led blinks rapidly.

Then I see a whole bunch of JFFS2 error saying, it can't read the drive or something.

Also I was using the latest cacko before, maybe that was the reason?

Please help.

btanoue
CoreDump
QUOTE(btanoue @ Apr 2 2006, 07:32 AM)
Hi,

I got the 3 files and named them correctly
kernel->zImage.bin
opie->initrd.bin
updater.sh

After the flash, I see the kernel installed :-)

But the screen goes blank for a while, the mail led blinks rapidly.

Then I see a whole bunch of JFFS2 error saying, it can't read the drive or something.

Also I was using the latest cacko before, maybe that was the reason?

Please help.

btanoue
*


That is exactly the reason. OpenZaurus requires you to use the exact same partitioning it had with Sharp ROM. IIRC Cacko allows to repartition your flash. The easiest and fastest way would be to do a NAND restore. After that you'll be able to flash OZ.
obergix
QUOTE(btanoue @ Apr 2 2006, 07:32 AM)
Hi,

I got the 3 files and named them correctly
kernel->zImage.bin
opie->initrd.bin
updater.sh

*


I'm sure you meant 3.5.4.1-alpha1, but in any case, it might be helpful to correct the post title, then wink.gif
btanoue
CoreDump,

How do I do a Restore?

Is it one of the options in Japanese?

Thanks for the help.

btanoue
CoreDump
QUOTE(btanoue @ Apr 2 2006, 04:47 PM)
CoreDump,

How do I do a Restore?

Is it one of the options in Japanese?

Thanks for the help.

btanoue
*


TRisoft to the rescue: http://trisoft.de/en_c1000howto.htm wink.gif
btanoue
QUOTE(CoreDump @ Apr 2 2006, 07:50 PM)
QUOTE(btanoue @ Apr 2 2006, 04:47 PM)
CoreDump,

How do I do a Restore?

Is it one of the options in Japanese?

Thanks for the help.

btanoue
*


TRisoft to the rescue: http://trisoft.de/en_c1000howto.htm wink.gif
*



Coredump,

It worked! Thanks! I never would have figured that one out. I thought the only way to flash was using the OK button and pression the On Button. I was a bit scared about the service menu thing I saw on
Trisoft_NAND_RESTORE

I tried GPE and now its time for OPIE. The 2.6 kernel seems zippier. Has anyone done a benchmark yet against the 2.4 Kernel?

btanoue
btanoue
Another Question,

How do I install software. It seems the default feeds don't exist?

Thank You,
btanoue
Hrw
OZ 3.5.4.1 should use packages for 3.5.4 - machine related packages will differ and there will be some updates in 3.5.4.1 which will get included in 3.5.4 feed with release.
btanoue
QUOTE(Hrw @ Apr 3 2006, 06:34 AM)
OZ 3.5.4.1 should use packages for 3.5.4 - machine related packages will differ and there will be some updates in 3.5.4.1 which will get included in 3.5.4 feed with release.
*


I keep getting errors with ipkg.

CODE
# ipkg update
Downloading http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/3.5.4/feed/base/Packages.gz
Inflating http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/3.5.4/feed/base/Packages.gz
Updated list of available packages in /usr/lib/ipkg/lists/base
Downloading http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/3.5.4/feed/machine/akita/Packages.gz
wget: server returned error 404: HTTP/1.1 404 Not Found
Downloading http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/3.5.4//feed/upgrades/machine/akita/Packages.gz
Inflating http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/3.5.4//feed/upgrades/machine/akita/Packages.gz
Updated list of available packages in /usr/lib/ipkg/lists/machine-upgrades
Downloading http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/3.5.4/feed/upgrades/Packages.gz
Inflating http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/3.5.4/feed/upgrades/Packages.gz
Updated list of available packages in /usr/lib/ipkg/lists/upgrades
Downloading http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/3.5.4.1-alpha1/feed/x11/Packages.gz
wget: server returned error 404: HTTP/1.1 404 Not Found
An error ocurred, return value: 2.
Collected errors:
ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp    -q -P /tmp/ipkg-EgOO7z http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/3.5.4/feed/machine/akita/Packages.gz'
ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp    -q -P /tmp/ipkg-EgOO7z http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/3.5.4.1-alpha1/feed/x11/Packages.gz'


There was a double // in a few of the files, so I decided to remove them and it didn't work.

Do i need to remove some of the feeds?

What am I doing wrong?

I would like to install firefox and get the gaim plugins to work.

btanoue
dolcex
You need to edit /etc/ipkg/x11-feed.conf and /etc/ipkg/machine-feed.conf because they have the wrong URL by default.

/etc/ipkg/x11-feed.conf should read:
CODE
src/gz x11 http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/3.5.4/feed/x11/


and /etc/ipkg/machine-feed.conf should read (choose the one that matches your machine):
CODE
src/gz c7x0 http://ewi546.ewi.utwente.nl/tmp/hrw/3.5.4.1-test/alpha1/c7x0/modules
src/gz akita http://ewi546.ewi.utwente.nl/tmp/hrw/3.5.4.1-test/alpha1/akita/modules
src/gz spitz-borzoi http://ewi546.ewi.utwente.nl/tmp/hrw/3.5.4.1-test/alpha1/spitz-borzoi/modules
btanoue
OK, I updated my sources.

Ipkg didn't die.

GPE package manger takes forever to read the list.

I do a Packages->Update Lists

I realized the last slash isn't need for the x11 feed.

I seem to get a RC =4 fro that one.

Any ideas?

btanoue

Another question,

I ran ipkg update on the command line and it said that it updated a file called x11 in
/usr/lib/ipkg/lists/x11

Could the Package Manager from GPE not handle this file too well?

Can I delete it and get a new one?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.