Help - Search - Members - Calendar
Full Version: Installing Cacko 1.23b1 Fails! Please Help!
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
daniel3000
Hello,

after today my main unit SL-C3000 with Cacko ROM was stolen and I tried to activate my backup unit, which ran with pdaXrom so far, I had no luck installing Cacko on that one.

Please help me!

Here is what I did:

1. Followed the zeroing instructions on http://www.xlfag.com/zaurus/ including NAND restore but without special kernel install --> unit booted into Japanese QTopia. Fine so far.

2. Followed Cacko 1.23b1 installation instructions. First stage runs fine, second one (after reboot) does not.
The step in the readmy described as "As soon as the install has completed re-enter the OK menu and select option 3, then 1. This will erase the user portion of the flash and hdd and extract the rest of the ROM. This will be encorporated into the user install process later.":
After going into the OK-On menu, choosing 3 then 1, a Linux kernel boots. During that an error message flashes by saying "HDD error! HDD not initialized" and "/hdd1/.sys/hdimage2.tgz missing" or similar.

Anyone knows what steps are missing?

Thanks for all advice! I need the Zaurus for work... I had two, but now I cannot use at least one of them! :-(

daniel
daniel3000
Strange...
I restored the /hdd1 from the file hdd1.tar.gz (zeroing page) so /hdd1/.sys/hdimage2.tgz was there again.

Then after the first step of flashing Cacko, it disappeared again so second boot did not work again! Does the Cacko installer install a wrong hdimage1.tgz which does not contain a hdimage2.tgz?

daniel
chyang
comfort daniel3000.
I'm so sorry to hear the lost.
daniel3000
I'm stuck...

Could some kind soul please, please post me the contents of /hdd1 and /hdd2 tar-gziped after a fresh Cacko 1.23b1 install?
This would help me a lot.


I have tried to restore Cacko until reboot (i.e. only hdd1), then reboot into D+B, put the /hdd1/.sys directory with contents from hdd1.tar.gz from the zeroing page into /hdd1, then do the OK-On / 3 / 1 option... to no avail.
hdimage2 is recognized now and apperantly extracted to here it belongs, but since now hdd1 and hdd2 don't fit together (hdd2 from Sharp original ROM, hdd1 from Cacko), QTopia isn't starting at all. I get the countdown "Wait... 5, 4, 3, 2, 1" over and over.

Cacko experts:
Where is the hdimage2.tgz of Cacko 1.23b1? Why is it missing after hdd1 install on my machine? How can I solve that problem?

Thanks a lot!
daniel
daniel3000
The issue has been solved.
My cacko ZIP was faulty, so hdimage1.tgz had CRC errors while manually unzipping on a Windows PC (why doesn't the Zaurus complain about that?!).

A new download of the ZIP archive and reinstalling Cacko the normal way solved the problem.

Bow I'll have to reinstall everything, as my hdd2 and /home backup went with the stolen SD card :-((

daniel
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.