I had Tetsu kernel v18a installed on my C3000. I restored the Trisoft backup from March 2005 and now after a few minutes of WiFi usage I get this startup:
CODE
ident: nic h/w: id=0x801b 1.0.0
ident: pri f/w: id=0x15 1.1.1
ident: sta f/w: id=0x1f 1.8.0
MFI:SUP:role=0x00:id=0x01:var=0x01:b/t=1/1
CFI:SUP:role=0x00:id=0x02:var=0x02:b/t=1/1
PRI:SUP:role=0x00:id=0x03:var=0x01:b/t=4/4
STA:SUP:role=0x00:id=0x04:var=0x01:b/t=1/14
PRI-CFI:ACT:role=0x01:id=0x02:var=0x02:b/t=1/1
STA-CFI:ACT:role=0x01:id=0x02:var=0x02:b/t=1/1
STA-MFI:ACT:role=0x01:id=0x01:var=0x01:b/t=1/1
Prism2 card SN: WL2513001366
linkstatus=CONNECTED

And this error:
CODE
hfa384x_docmd_wait: hfa384x_cmd timeout(2), reg=0x8000.
hfa384x_cmd_access: Call to hfa384x_docmd_wait failed (-110 49155)
prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-110
hfa384x_copy_to_bap4: copy_to_bap() failed.
hfa384x_copy_to_bap4: copy_to_bap() failed.
hfa384x_copy_to_bap4: copy_to_bap() failed.
hfa384x_copy_to_bap4: copy_to_bap() failed.
hfa384x_copy_to_bap4: copy_to_bap() failed.
hfa384x_copy_to_bap4: copy_to_bap() failed.
hfa384x_copy_to_bap4: copy_to_bap() failed.
hfa384x_copy_to_bap4: copy_to_bap() failed.
hfa384x_docmd_wait: hfa384x_cmd timeout(1), reg=0x810b.
hfa384x_cmd_access: Call to hfa384x_docmd_wait failed (-110 49155)
prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-110
hfa384x_docmd_wait: hfa384x_cmd timeout(1), reg=0x810b.
hfa384x_cmd_access: Call to hfa384x_docmd_wait failed (-110 49155)
prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-110
hfa384x_docmd_wait: hfa384x_cmd timeout(1), reg=0x810b.
hfa384x_cmd_access: Call to hfa384x_docmd_wait failed (-110 49155)
prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-110
hfa384x_docmd_wait: hfa384x_cmd timeout(1), reg=0x810b.
hfa384x_cmd_access: Call to hfa384x_docmd_wait failed (-110 49155)
prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-110
hfa384x_docmd_wait: hfa384x_cmd timeout(1), reg=0x810b.
hfa384x_cmd_access: Call to hfa384x_docmd_wait failed (-110 49155)
prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-110
hfa384x_docmd_wait: hfa384x_cmd timeout(1), reg=0x810b.
hfa384x_cmd_access: Call to hfa384x_docmd_wait failed (-110 49155)
prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-110
hfa384x_docmd_wait: hfa384x_cmd timeout(1), reg=0x810b.
hfa384x_cmd_access: Call to hfa384x_docmd_wait failed (-110 49155)
prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-110
hfa384x_docmd_wait: hfa384x_cmd timeout(1), reg=0x810b.
hfa384x_cmd_access: Call to hfa384x_docmd_wait failed (-110 49155)
prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-110
hfa384x_docmd_wait: hfa384x_cmd timeout(1), reg=0x810b.
hfa384x_cmd_access: Call to hfa384x_docmd_wait failed (-110 49155)
prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-110
hfa384x_docmd_wait: hfa384x_cmd timeout(1), reg=0x810b.
hfa384x_cmd_access: Call to hfa384x_docmd_wait failed (-110 49155)
prism2sta_mlmerequest: Failed to read wlan0 statistics: error=-110
hfa384x_copy_to_bap4: copy_to_bap() failed.
hfa384x_docmd_wait: hfa384x_cmd timeout(1), reg=0x810b.
pxa_pcmcia_suspend(0)
hfa384x_docmd_wait: hfa384x_cmd timeout(1), reg=0x8888.
hfa384x_drvr_start: Initialize command failed.
hfa384x_drvr_start: Failed, result=-110
prism2sta_ifstate: hfa384x_drvr_start() failed,result=-110

Any clues as to why this may be happening?