Help - Search - Members - Calendar
Full Version: Howto Build Packages For Tosa?
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Zaurus Distro Support and Discussion > Angstrom & OpenZaurus

I try to build package for tosa (the nano package like the sample) but it doesn't work mad.gif

I have installed the packages for debian (testing) as describe at this URL: . Then I follow this documentation:

When I try to build nano I get the folowing error:

$ bitbake nano_1.3.9
NOTE: Using cache in '/home/dom/oestuff/'
NOTE: Parsing finised. 2 cached, 0 parsed, 0 skipped, 0 masked.
NOTE: build 200604111157: started
Traceback (most recent call last):
File "/home/dom/oestuff/bitbake/bin/bitbake", line 1120, in ?
cooker.cook( BBConfiguration( options), args[1:] )
File "/home/dom/oestuff/bitbake/bin/bitbake", line 879, in ?, pkgs_to_build,
File "./lib/bb/", line 62, in fire
File "tmpHandler(e)", line 30, in tmpHandler
ValueError: substring not found

I think that is à configuration problem. Can someone help me?

use org.openembedded.oz354x branch and bitbake r329 (available in sdk/ directory of OZ 3.5.4)
QUOTE(Hrw @ Apr 11 2006, 10:23 AM)
use org.openembedded.oz354x branch and bitbake r329 (available in sdk/ directory of OZ 3.5.4)

I have the same error mad.gif !!!

On the bitbake web page I found an example like "bitbake -b". With this command something happend (but it is'nt OK)

Now I have 2 questions:

- How to say to bitbake that it must read my local.conf?

- The error with the build is:
$ bitbake -b
NOTE: package nano-1.3.5: started
NOTE: package nano-1.3.5-r0: task do_fetch: started
NOTE: package nano-1.3.5-r0: task do_fetch: completed
NOTE: package nano-1.3.5-r0: task do_configure: started
ERROR: function do_configure failed
ERROR: see log in /home/dom/oestuff/org.openembedded.oz354x/packages/nano/tmp/work/nano-1.3.5-r0/temp/log.do_configure.7053
NOTE: Task failed: /home/dom/oestuff/org.openembedded.oz354x/packages/nano/tmp/work/nano-1.3.5-r0/temp/log.do_configure.7053
NOTE: package nano-1.3.5-r0: task do_configure: failed
ERROR: TaskFailed event exception, aborting
NOTE: package nano-1.3.5: failed
ERROR: Build of 'nano' failed
Build statistics:
Attempted builds: 1
Failed builds: 1

In the log file I have the folowing error:

automake (GNU automake) 1.4-p6

Copyright © 1999, 2001 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO

Written by Tom Tromey <>
AUTOV is 1.4-p6
NOTE: Executing autoreconf --verbose --install --force --exclude=autopoint -I /home/dom/oestuff/org.openembedded.oz354x/packages/nano/tmp/work/nano-1.3.5-r0/nano-1.3.5/m4/ -I /home/dom/oestuff/org.openembedded.oz354x/packages/nano/tmp/staging/INVALID-INVALID/share/aclocal-1.4-p6 -I /home/dom/oestuff/org.openembedded.oz354x/packages/nano/tmp/staging/INVALID-INVALID/share/aclocal
/usr/bin/autoreconf2.50: unrecognized option `--exclude=autopoint'
Try `/usr/bin/autoreconf2.50 --help' for more information.
FATAL: autoreconf execution failed

Can somebody help me about this problem?

My dev computer is under debian testing (I made the update yesterday)

Thanks Dominique
Never EVER use "-b" if you do not know what it means.

set DISTRO="openzaurus-3.5.4"

and build "bitbake nano"
you should start bitbake from the build directory, btw., not from within the packages tree.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.