Help - Search - Members - Calendar
Full Version: Problems Getting Cramfs Images To Mount For Xqt
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > X/Qt
icruise
I'm following Meanie's instructions and using his packages so that I can use XQT and a variety of applications. I want to use the following cramfs images:

xqt-apps.cramfs
xqt-gtk-jumbo.cramfs
xqt-mozilla.cramfs
xqt-openoffice.cramfs

However, when I run the xqt-install script, it will only work with the first two cramfs images (whatever they may be) and for the others it will say:

Warning: ambiguous entry for <image name> (this is also displayed for the images that work)
mount: Could not find a spare loop device

Sure enough, when I look in /dev there are only two loop devices. I notice that the xqt-install script is running mknod, which I assume is to create the additional loop devices necessary. When I try running one of the lines from the script (like "mknod /dev/loop2 b 7 2") I get the error "mknod: /dev/loop2: No space left on device". I'm not sure what this means. I do know that I have plenty of free space on the device, however.

Can anyone help me with this? Aside from the fact that I can only mount two of these images at once, these cramfs images have been working very well, and I'd love to be able to use them all at once. Note that I am still pretty much a linux newbie, so I may very well be overlooking something very basic.

One other possibly related issue is that the script says that automounter is not installed, even though I have definitely installed it.
icruise
So can anyone tell me why I can't make extra loop devices for mounting these images?
Meanie
QUOTE(icruise @ Apr 14 2006, 02:44 AM)
So can anyone tell me why I can't make extra loop devices for mounting these images?
*


what model are you running? most zauri have 2 loop devices by default and a maximum of 7 loop devices is hardcoded in the kernel somewhere unless you have a special kernel with 2 loop device limit hardcoded.
icruise
QUOTE(Meanie @ Apr 14 2006, 07:52 AM)
QUOTE(icruise @ Apr 14 2006, 02:44 AM)
So can anyone tell me why I can't make extra loop devices for mounting these images?
*


what model are you running? most zauri have 2 loop devices by default and a maximum of 7 loop devices is hardcoded in the kernel somewhere unless you have a special kernel with 2 loop device limit hardcoded.
*



Sorry, it's a 3100 and I can't seem to create more than the default 2 devices.
icruise
Could something that I have installed caused this problem? What does "No space left on device" usually mean -- that there is actually no memory left, or something else? If it isn't possible to mount more than 2 images for me, is there a way to get one big image with all of the programs I need on it (without using a Linux box, since I don't have one)? Thanks!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.