Help - Search - Members - Calendar
Full Version: Missing Module Wpa / Wep With Oz 3.5.4.1alpha1/2?
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
enodr
It seems OZ3.5.4.1Alpha2 is missing some modules to have WEP / WPA work correctly:

For WEP, trying iwconfig wlan0 key myhexkey gives the following error:
CODE
Error for wireless request "Set Encode" (8B2A):
SET failed on device wlan0; Operation not supported


dmesg tells me: wlan0: could not initialize WEP: load module hostap_crypt_wep.o
So that must be the reason. Now let's find out where is this module...

For WPA, running wpa_supplicant gives:
CODE
skip - no WPA/RSN IE

when selecting my AP...

I see those files in the feed, but I don't know what they are used for (WEP support is supposed to be in the hostap module?)
kernel-module-ieee80211-crypt-ccmp-2.6_2.6.16-r5_spitz.ipk
kernel-module-ieee80211-crypt-tkip-2.6_2.6.16-r5_spitz.ipk
kernel-module-ieee80211-crypt-wep-2.6_2.6.16-r5_spitz.ipk
Hrw
report ALL bugs in bugtracker
WJMoore
I've run into this too. Did you post a bug report enodr?
JohnX
Looks like it's this bug. Seems that kernel-module-arc4-2.6 needs to be installed...
enodr
QUOTE(JohnX @ Apr 19 2006, 09:58 AM)
Looks like it's this bug. Seems that kernel-module-arc4-2.6 needs to be installed...
*


Solution is posted in another thread in this forum. Basically you need latest wpa_supplicant package from upgrade feed, then install all the necessary modules from your machine kernel feed:
ieee802*
rc4 (crypto module)
michael-mic (crypto module)

A very handy script has also been posted in the other thread for easy startup of wpa.
WJMoore
Any idea what the thread is? I did a search for hostap_crypt_wep and that gave nothing much newer than 2004.
enodr
QUOTE(WJMoore @ Apr 21 2006, 04:35 AM)
Any idea what the thread is? I did a search for hostap_crypt_wep and that gave nothing much newer than 2004.
*


http://www.oesf.org/forums/index.php?showtopic=18848
WJMoore
Thanks. I tried installing all the modules mentioned and I still get the error about not being able to find hostap_crypt_wep.o The following are the relevant modules I have installed. I don't need WPA, just WEP, any other ideas?

root@spitz:~# ipkg list_installed|grep ieee
kernel-module-ieee80211-2.6 - 2.6.16-r5 -
kernel-module-ieee80211-crypt-2.6 - 2.6.16-r5 -
kernel-module-ieee80211-crypt-ccmp-2.6 - 2.6.16-r5 -
kernel-module-ieee80211-crypt-tkip-2.6 - 2.6.16-r5 -
kernel-module-ieee80211-crypt-wep-2.6 - 2.6.16-r5 -
root@spitz:~# ipkg list_installed|grep arc
kernel-module-arc4-2.6 - 2.6.16-r5 -
root@spitz:~# ipkg list_installed|grep michael
kernel-module-michael-mic-2.6 - 2.6.16-r5 -
JohnX
depmod -a ; ifdown wlan0 ; ifup wlan0 ; echo it works!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.