Help - Search - Members - Calendar
Full Version: Success With Wpa-psk On 3.5.4
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
spectral
Just wish to inform everyone that I have succeeded with WPA-PSK
on 3.5.4. I earlier reported (and perhaps its the same issue reported by some
of the others) that I was getting "no WPA/RSN len" error.

The problem was because OZ feed was still using wpa_supplicant 0.2.6 which
is not compatible with the hostap version in use (version 0.3.9 before upgrade
and 0.4.7 after upgrade). I recompiled wpa_supplicant 0.4.8 which was released
together with hostap 0.4.7, on my own and WPA-PSK works fine for me now.
Hrw
good to know - but for future please post such things also to openzaurus-devel@lists.sourceforge.net or add into OE bugtracker
enodr
QUOTE(spectral @ Apr 13 2006, 09:54 AM)
Just wish to inform everyone that I have succeeded with WPA-PSK
on 3.5.4. I earlier reported (and perhaps its the same issue reported by some
of the others) that I was getting "no WPA/RSN len" error.

The problem was because OZ feed was still using wpa_supplicant 0.2.6 which
is not compatible with the hostap version in use (version 0.3.9 before upgrade
and 0.4.7 after upgrade). I recompiled wpa_supplicant 0.4.8 which was released
together with hostap 0.4.7, on my own and WPA-PSK works fine for me now.
*


Great! I was just installing the SDK to build wpa_supplicant wink.gif Could you post the ipk?

Thanks.
Hrw
ipkg update;ipkg upgrade and you will get OZ official one.
enodr
I am still having troubles:

ipkg update; ipkg upgrade won't upgrade because the current installed package is called wpa-supplicant-nossl

Solution is:
ipkg remove wpa-supplicant-nossl -force-depends
ipkg install wpa-supplicant

But then when I run:
wpa_supplicant -i wlan0 -Dwext -c/etc/wpa_supplicant.conf -dd

I get the following error when it tries to connect to my network:
wpa_driver_wext_set_key: alg=2 key_idx=0 set_tx=1 seq_len=6 key_len=32
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Driver did not support SIOCSIWENCODEEXT
WPA: Failed to set PTK -> GROUP_HANDSHAKE

...
Hrw
thx for notice - will add conflict/replace for it

BTW - can you write HowTo about OZ 3.5.4x and WPA?
ant
thx for this suggestions! It's obvious but ... invisible!

BTW I see strange things : my wireless card D-Link DCF-660W is seen as eth0 as well as wlan0.

EDIT
cannot connect with:
wpa_supplicant -w -c/etc/wpa_supplicant.conf -Dwext -iwlan0 -dd

There is probably a bug involving /etc/network/interfaces
enodr
QUOTE(Hrw @ Apr 14 2006, 05:04 AM)
thx for notice - will add conflict/replace for it

BTW - can you write HowTo about OZ 3.5.4x and WPA?
*


I was editing the post while you were replying wink.gif Maybe Spectral can give feedback... I noticed wpa_supplicant is not compiled with hostap support but just generic wireless extensions. Dunno if that matters...

I'll be happy to post a WPA howto on OpenZaurus.org and OESF.org as soon as it works!
spectral
QUOTE(enodr @ Apr 14 2006, 05:14 AM)
QUOTE(Hrw @ Apr 14 2006, 05:04 AM)
thx for notice - will add conflict/replace for it

BTW - can you write HowTo about OZ 3.5.4x and WPA?
*


I was editing the post while you were replying wink.gif Maybe Spectral can give feedback... I noticed wpa_supplicant is not compiled with hostap support but just generic wireless extensions. Dunno if that matters...

I'll be happy to post a WPA howto on OpenZaurus.org and OESF.org as soon as it works!
*



The wpa_supplicant that I compiled was using the default defconfig
that came with the source, so hostap and wext is enabled.

I tried the updated wpa_supplicant from OZ feed and although
it didnt support "-Dhostap", specifying wext works fine for me.
So I am not sure if hostap support is the problem here coz
both "-Dhostap" and "-Dwext" works for me.

I am using a SMC2642 card (prism) which I had flashed
with updated firmware (NIC:1.0.0, PRI:1.1.1, STA:1.8.2).

Could you check if your Wifi card has the supported
firmware (STA>=1.7.0, if I remember correctly)?

Here is my wpa_supplicant.conf if its of any help
(I suggest your specify only TKIP and nothing-else):

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1

network={
ssid="Your SSID"
scan_ssid=1
proto=WPA
key_mgmt=WPA-PSK
pairwise=TKIP
group=TKIP
psk="Your PSK"
priority=0
}
ant
QUOTE(spectral @ Apr 14 2006, 04:03 PM)
...
(I suggest your specify only TKIP and nothing-else):
...


This is not enough...
I stumble in the same error as enodr reported:
...
wpa_driver_wext_set_key: alg=2 key_idx=0 set_tx=1 seq_len=6 key_len=32
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Driver did not support SIOCSIWENCODEEXT
WPA: Failed to set PTK -> GROUP_HANDSHAKE
...

Hrw, please recompile wpa_supplicant with ALL drivers (hostap, wext, ...).

TIA

Ant
enodr
I use the same wpa_supplicant.conf file.

My card is Planex GW-CF11X
Firmware version: NIC 1.0.0 PRI: 1.1.2 STA: 1.8.4

I just found a funny error in dmesg, maybe the clue to the problem:
ieee80211_crypt_tkip: could not allocate crypto API michael_mic

I have to find Michael_mic now!!
enodr
Yeah!

Michael_mic was in the kernel module feed for OZ3.5.4.1alpha2 (it's a crypto module)

I can now enjoy safe wifi surfing!!

Hrw: do you think I should write an howto, as I guess thing will change with next release (list of default module?). All the ieee80211 modules + rc4 + michael_mic should be in the default hdimage.
spectral
QUOTE(enodr @ Apr 14 2006, 07:48 AM)
I use the same wpa_supplicant.conf file.

My card is Planex GW-CF11X
Firmware version: NIC 1.0.0 PRI: 1.1.2 STA: 1.8.4

I just found a funny error in dmesg, maybe the clue to the problem:
ieee80211_crypt_tkip: could not allocate crypto API michael_mic

I have to find Michael_mic now!!
*


This is perculiar coz I never had that MIC problem.
I dont even had ieee80211_crypt _tkip loaded, instead
I see hostap_crypt_tkip loaded.....
ant
QUOTE(enodr @ Apr 14 2006, 05:03 PM)
Michael_mic was in the kernel module feed for OZ3.5.4.1alpha2 (it's a crypto module)


installed the module but...
...
wpa_driver_wext_set_key: alg=2 key_idx=0 set_tx=1 seq_len=6 key_len=32
Driver did not support SIOCSIWENCODEEXT
WPA: Failed to set PTK to the driver
...
ant
Hrw, please recompile wpa_supplicant with ALL drivers (hostap, wext, ...)

TIA
ant
QUOTE(enodr @ Apr 14 2006, 05:03 PM)
Yeah!
...


enodr, waiting for an how-to, please post meanwhile your

/etc/network/interfaces

TIA

Ant
enodr
QUOTE(ant @ Apr 14 2006, 09:23 AM)
Hrw, please recompile wpa_supplicant with ALL drivers (hostap, wext, ...)

TIA
*


Spectral: you are using OZ3.5.4? That must be the reason

Ant: If you are running OZ3.5.4.1alpha2 you need to install the following modules from the 3.5.4.1alpha2 feed:
http://ewi546.ewi.utwente.nl/tmp/hrw/3.5.4...st/alpha2/feed/ (put_your_flavour_here)/
- kernel-module-ieee80211-*
- kernel-module-michael-mic

If it is still not working please post all the details here (dmesg results, wpa_supplicant -v, try to run wpa_supplicant with -dddd for more debugging output, ... post your wpa_supplicant.conf file, wifi card model + firmware version, hostap version, etc...)
ant
QUOTE(enodr @ Apr 14 2006, 08:03 PM)
Ant: If you are running OZ3.5.4.1alpha2 you need to install the following modules from the 3.5.4.1alpha2 feed:
http://ewi546.ewi.utwente.nl/tmp/hrw/3.5.4...st/alpha2/feed/ (put_your_flavour_here)/
- kernel-module-ieee80211-*
- kernel-module-michael-mic


this sucker was missing from alpha2:

kernel-module-ieee80211-2.6_2.6.16-r5_c7x0.ipk


EDIT - FINALLY WORKS

in the logs I found finally the missing module was FOR ME "kernel-module-arc4-2.6_2.6.16-r5_c7x0.ipk".
I'm connecting to a Zyxel router, WPA-PSK TKIP.

So far, in alpha2 some crypto modules are missing: it depends from your AP which are to load...I didn't need michael-mic but arc4 instead of it.
I'm doubtful about "kernel-module-ieee80211-2.6_2.6.16-r5_c7x0.ipk". This one should be needed by all other ieee modules.
nax
Yes it really works now. I'm attaching my wpa start script (you can copy it into /etc/init.d/wpa_supplicant.sh). Then you have to allow wpa (add line WPA_ENABLE=true to file /etc/default/wpa) and now you can add last 2 line into /etc/network/interfaces:

CODE
# Wireless interfaces
iface wlan0 inet dhcp
       up /etc/init.d/wpa_supplicant.sh start
       down /etc/init.d/wpa_supplicant.sh stop


Now wpa_supplicant is started in daemon mode if you insert your wifi card and it is stopped after eject.
spectral
QUOTE(enodr @ Apr 14 2006, 11:03 AM)
QUOTE(ant @ Apr 14 2006, 09:23 AM)
Hrw, please recompile wpa_supplicant with ALL drivers (hostap, wext, ...)

TIA
*


Spectral: you are using OZ3.5.4? That must be the reason





Yes I am using OZ3.5.4 and not the updated alphas.
I suppose we now have a WPA solution for the 3.5.4.x OZ tree.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.