Help - Search - Members - Calendar
Full Version: Mounting My 6gb Drive
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
Cresho
I must of spent a good 3 hours trying to find the commands to return my permissions so i can edit stuff through the file manager in the zaurus.

what happends is after using my bluetooth, i close the lid and suspends. when i open the lid and start it up, i loose my internal drive.

so i then
su
mount /dev/hda3 /hdd3

my drive is back but i can't write to it.

then i try
chown 700 /hdd3

and i dont get any write access.

i tried chown -R root:root /hdd3

but its not working at all.

any Ideas? i need to enable access permission to user, group, others with show, write and enter under ownership of user and group to root to return the original state of the disk. The only way i can fix this at the moment is by rebooting it.
DaemonsGR
Did you try just t reboot?
Cresho
yeah rebooting it works just fine but my commands fail at the terminal. I'd rether type it in instead of waiting for a reboot.
sidmoraes
QUOTE(Cresho @ Apr 27 2006, 09:47 AM)
yeah rebooting it works just fine but my commands fail at the terminal.  I'd rether type it in instead of waiting for a reboot.
*



Did you tried "mount -o remount,rw /hdd3" ?
Cresho
doesnt work..

i su then do
mount -o remount,rw /hdd3
and nothing. isnt in fstab

then i do
mount /dev/hda3 /hdd3
and then i do
mount -o remount,rw /hdd3

seems to work but then i can't do nothing with file manager.
Meanie
QUOTE(Cresho @ Apr 28 2006, 09:53 AM)
doesnt work..

i su then do
mount -o remount,rw /hdd3
and nothing.  isnt in fstab

then i do
mount /dev/hda3 /hdd3
and then i do
mount -o remount,rw /hdd3

seems to work but then i can't do nothing with file manager.
*


actually, you need to do the following:

mount -o rw,noatime,umask=000,iocharset=utf8 /dev/hda3 /hdd3

note the umask=000 option. that's the important one
also, you should fix your bluetooth scripts and find and replace

cardctl eject

with

cardctl eject 0

probably want to do the same thing for the all the instances of cardctl in the bluetooth scripts. on a c1000 where there is no internal microdrive unmounting everything or just the first cf device has the same result but on a c3x00, the microdrive suffers if cardctl is not more specific.
Cresho
thanks meanie!

I just got around screwing around with the zaurus again and made a patch ontop of the patch that was made. Made an ipk for myself. Anyway, it's working and my internal drive doesn not mysteriously dissapear anymore.

Do you have any idea why the cacko version of bluetooth network does not work for the sharprom? I kinda want to get that to work on the sharprom. Is it because of the tetsu kernel?

i did a few files just like this.
r45bluetooth
s90bluetooth
bluetooth
serial

i was having problems with cardctl 0 because i did not realize i had to place the 0 like "cardctl susp 0". i was "cardctl 0 susp" and gaved me some problems. Too funny! laugh.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.