Help - Search - Members - Calendar
Full Version: Kde Multisynk Crash With Opie
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
wylbur
running opie 1.2.1 with OZ 3.5.4.1-alpha2 on SL-C3200. Trying to sync with KDE Kontact v1.2 (KDE 3.5.2 kubuntu-dapper).

I setup the opie-kontact link as described in the docs, and I click sync in Kontact there's some action: I get a very, very quick flash of "kitchensync" on the Z, then it's gone and Kontact is hung.

When I do the same thing using multisynk directly from the cmd line, I find that multisynk crashed due to SIGSEVG 11.

The interesting part of the stack trace is below. Anyway, this is a multisynk bug, not a an opie problem, but I wonder if anyone else has seen it? If so, have they found a workaround? Is anything obviously wrong with what I'm doing?

TIA -- wylbur.


KCrash handler]
#6 0xb6fa8c39 in KSync::Syncee::setMerger () from /usr/lib/libksync2.so.0
#7 0xb617c075 in KSync::QtopiaSocket::readAddressbook ()
from /usr/lib/libqtopiakonnector.so
#8 0xb617f1e5 in KSync::QtopiaSocket::flush ()
from /usr/lib/libqtopiakonnector.so
#9 0xb617f3b0 in KSync::QtopiaSocket::call ()
from /usr/lib/libqtopiakonnector.so
#10 0xb617f4bf in KSync::QtopiaSocket::process ()
from /usr/lib/libqtopiakonnector.so
#11 0xb617f57e in KSync::QtopiaSocket::qt_invoke ()
from /usr/lib/libqtopiakonnector.so
#12 0xb77c4e29 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#13 0xb77c58c4 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#14 0xb7b92069 in QSocket::readyRead () from /usr/lib/libqt-mt.so.3
#15 0xb79f26b6 in QSocket::sn_read () from /usr/lib/libqt-mt.so.3
#16 0xb7b92151 in QSocket::qt_invoke () from /usr/lib/libqt-mt.so.3
#17 0xb77c4e29 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#18 0xb77c5738 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#19 0xb7b58bef in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#20 0xb77e516e in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#21 0xb775adc6 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#22 0xb775afc2 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#23 0xb7416d7d in KApplication::notify () from /usr/lib/libkdecore.so.4
#24 0xb76ec0ef in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#25 0xb774c8e3 in QEventLoop::activateSocketNotifiers ()
from /usr/lib/libqt-mt.so.3
#26 0xb76ffedb in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#27 0xb77738b7 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#28 0xb77737da in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#29 0xb77598d5 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#30 0x0804d760 in ?? ()
#31 0xbff269d8 in ?? ()
#32 0xbff26abc in ?? ()
#33 0x00000001 in ?? ()
#34 0x00000000 in ?? ()
arzgi
QUOTE(wylbur @ Apr 28 2006, 10:18 AM)
running opie 1.2.1 with OZ 3.5.4.1-alpha2 on SL-C3200. Trying to sync with KDE Kontact v1.2 (KDE 3.5.2 kubuntu-dapper).

I setup the opie-kontact link as described in the docs, and I click sync in Kontact there's some action: I get a very, very quick flash of "kitchensync" on the Z, then it's gone and Kontact is hung.

TIA -- wylbur.

*


I just use passwordless ssh/scp and works well from KO/Pi and Ka/Pi's synchronize menu.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.