Help - Search - Members - Calendar
Full Version: Standalone Pocket Workstation -problem With Fbvnc
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Zaurus - Everything Development > X/Qt
hi there, i just installed pocket workstation v0.18-big into a 400mb loop image on my sd card, then booted it through a small modification to my alt-boot script...

after loading im at "sh-2.05b#' prompt, which is in the debain rootfs

did the ./INSTALL.d/ and answered yes to all, also tried doing it saying yes to all without the last two...

Vncserver command seems to run ok,

but when running the Fbvnc command i get:

fbvnc: ConnectToTcpAddr: connect: Network is unreachable
fbvnc: unable to connect to VNC server
Cannot connect: Network is unreachable
/usr/local/bin/Fbvnc: line 68: chvt: command not found

so either the server isnt running correctly or the client cant find the server...

if i do a ifconfig i get nothing, if i do a ifconfig -a i get mention of irda0 and lo both seemingly totally unconfigured ... whether they (more specifically lo) need to be or not ???


well i tryed:

ifconfig lo netmask up

then ifconfig shows it with those assigned details smile.gif not sure whether that'l help as id need to do that before i run the server and client. so im going to have reconfigure it and restart it... but now its just like my big computationer... wink.gif
well it did help, it got further, but now compains that it cant access /dev/fb0 which doesnt exist ...

i noticed it in the opie root, so i figure you need something running in the background to run debian , something that has the fb0 thingy happening...

so im going to try copying opie's fb0 into the debian loop image see if that works, if not ill try mounting and booting debian from within opz...

why you may ask, well i like the challenge somewhat and im heading for the world of java hopefully ... smile.gif


well it got past fb0, and then started asking for a tty02 which i could find anywhere not even on i386 etch, so into hentges i go...
well it worked, after booting my hentges opie loop image but , interupting opie from starting up a the last minute by hitting a key at the given prompt...

then i did the following;

mkdir -p /mnt/loop
losetup /dev/loop1 /media/card/boot-images/xxx-rootfs.bin
mount /dev/loop1 /mnt/loop

cd /mnt/loop

answer yes too all, except last 2 thought could have said yes to them... and your in smile.gif

(notice there was a lo device running in ifconfig automatically, must have been started up opz.. smile.gif
next problem, does anyone know how to make my usb0 interface dhcp rather than static ??

as in /etc/networking/interfaces it just says some stuff about if.up if.down (8) ...

any way i might try some more things tommorow, as im getting tired again and i been typing in bash terminal soo much the past few days that whenever i go to start typing in the forum here i keep hitting "TAB" to finish my word or line ... tongue.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.