Help - Search - Members - Calendar
Full Version: Wifi Card Stopped Registering Properly
OESF Portables Forum > Everything Else > Archived Forums > Zaurus General Forums > General Support and Discussion > Security and Networking
I have posted this problem in a different thread, but wanted to give it its own for more visibility.

I flashed my 5500 to tkrom 2 alpha 3, with the async kernel, and /home on SD script. Everything went fine until I put my wifi card in. It was recognised correctly, but I didn't get the little network monitor icon on the taskbar with the option to connect, and the led on the card would come on, and stay on, whereas, when it is recognised correctly, it will flash a few times, then go off until I connect. Running opera would bring up a connection box, but it would have no entries, even though the network settings were all correct.

I reflashed back to the Sharp ROM, and everything was OK.

I decided to give tkrom another try, and this time I tried the wifi card after every step. I flashed the rom then tried it...flashed the async kernel, and tried again, and finally ran the prep-home-sd script using the -c option to copy my network settings across to the new /home.

The wifi card came up every time, and behaved as it should. I did a few resets, with and without the card in, to see if it caused a problem. It was still working.

After a few days of messing around (installing different software), it is now not working again. The card is being recognised as usual, but now network connection icon, and the light comes on and stays solid again.

Any help would be most appreciated smile.gif
I've got the same problem. I'm usin' the stock sharp rom on a 5500, with a dlink 660w. Same situation, sometimes I can get it to register by playing with cardctl.. Suspending it, restarting it, ejecting it, and then I can connect to my wireless briefly-- but that usually ends with a white screen and a lockup of the z, untill i pull out the wifi card, and then it all goes back to normal. =/
That usually happens when the card is broken. I have gone through three wireless cards. They usually end where the led will stay on or they will just not connect any more. Time for a new card I guess.
Same thing happened with the DCF660W that came with Cortana: Worked for about a week, then after that, would just do exactly what you're describing. You've been lucky so far, I tried to connect to a Wireless Access Point at my college, and it hasn't worked since. :/

Time to replace the card before you have to replace everything alse with it.

Better get a spare, too. They're becoming a bit few and far between now that most modern devices have inbuilt wifi |Cough| Albert |cough|
Well...after reflashing again...I have now had mine working flawlessly for nearly a month.

It would appear that the problem (for me at least) was being caused by the async kernel. I left it out this time around, and as I say, it has worked fine.

I've seen this kind of connectivity problem all over the forums, and believe it has something to do with the process daemaens (or whatever) getting a bit whaky and messing up the interfaces.

For me, I thought it was Opera, but NeIC does it also....I'm working on a script for myself to automate the aggravating process of trying to get connected once things get messed up.

The surest solution if cardctl reset 0 doesn't work for me has been to kill the offending pppd process (and maybe also a chat process as well), on a Sharp ROM 2.38 using dialup...different than this thread, but maybe this idea will help.

The pid's may need to be extracted from a 'ps ax' listing...not necessarily just /var/run/ or /var/run/

and look at /tmp/qpe-pppd-log or the equivalent on your system...if there are lines following the one showing "status = 0x0" then something's wrong, for me it's usually some stupid process trying to erase a non-existent /var/run/ file.

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.