Help - Search - Members - Calendar
Full Version: White Screen On Install!? Help
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > OpenBSD
DaemonsGR
Hello,
I tried to install the latest snap but when I do cp bsd.rd /proc/zboot I get 1-2 fades from black to white and then only white screen! I have to remove the battery to boot linux!

I have c3100 with pdaxrom beta3 and I run the install from the console (no X loaded).

thnx
Tasos
DaemonsGR
No one had any bad luck with OpenBSD? The loader keep crashing after insmod and cp bsd.rd /proc/zboot!!!
iamasmith
I haven't come across this although I only have an SL-C3000.

I have used OpenBSD with Cacko 1.23b1 and now use my mini rootfs that allows me to use the whole disk. I suspect that there is some kernel tweak that the boot loader has some problems with.

During boot the Zaurus boot loader attempts to clear MMU and memory effectively returning the device to a clear memory state before booting the OpenBSD kernel. It may be that some extra initialization is being performed in the PDAXROM kernel that is not being handled by the OpenBSD boot loader.

I suggest that you try posting to arm@openbsd.org and see if anyone has an answer for this..

-Andy
bruce
I saw this behavior exactly once (for what its worth) the first time I loaded -current on my sl-3200 (which I boot using -beta3 pdaxrom).

The only obvious difference from all the other times where I have loaded openbsd with "cp /bsd.rd /proc/zboot" without problem was that I happen to do it from an xterm while the system was running a lot of other applications instead of from the console on an unloaded system.

I've never seen any kind of lockup booting via zboot.
DaemonsGR
I "fixed" it by using 3.9 release kernel to boot(install) and tgz from snapshot! smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.