Help - Search - Members - Calendar
Full Version: Pdaxrom 1.1.0beta 4 And New Bootloader
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
Pages: 1, 2, 3, 4
sashz
new bootloader, Kernel 2.6, fbpanel dry.gif

http://mail.pdaxrom.org/node/78

please read "step-by-step" instruction before flashing.
cortez
hmm, extreme testers only....
This is too tempting, will certainly give it a try later wink.gif
sashz
QUOTE(cortez @ May 9 2006, 11:48 PM)
hmm, extreme testers only....
This is too tempting, will certainly give it a try later  wink.gif
*


You always can restore original stuff from backup wink.gif
Xromer
QUOTE(sashz @ May 10 2006, 08:51 AM)
QUOTE(cortez @ May 9 2006, 11:48 PM)
hmm, extreme testers only....
This is too tempting, will certainly give it a try later  wink.gif
*


You always can restore original stuff from backup wink.gif
*



EHEHEHEH!! You told me and you did it!! HIHIHI!! You are the best!
Now, extreme testers only, what do it means?
You hadn' t time to test it deep or have not yet tested?
Do you think i can begin to pass the all Contrib on the Beta4 or i have to wait some?
New Builder and SDK?
Tell me what you think i have to do, because now with the Beta2 it's stable enough, if it' s like that i' ll have no problems to begin working on it. laugh.gif
I would like to pass directly to Beta4.
GO ON LIKE THAT!
BYEZ!
sashz
extreme means no one tested it yet - just me! smile.gif For me it work ok.
I need another testers.
For your stuff, ill write overlay documentation at evening.
danboid
What advantages does this new bootloader bring over whatever beta3 used?

Sashz just mentioned overlay so I'm presuming that video acceleration is in? Whoop! biggrin.gif

What difference is there in the amount of free memory available with this 2.6 kernel over 2.4? I don't mind losing a few meg RAM for extra speed though.

Its very annoying for us C3000 owners always having to wait for a port when an exciting new distro like this gets released- where are you Thc? iamsmith? Get porting asap pretty please! sad.gif

Can't wait to hear how the new zpsx runs under beta4!
badog
Sl-6000 need 1.1bate4 PDAXROM too.
seiichiro0185
Hi,

I just tried beta 4 on my C1000, but only the first step (C+D+power. green light for ~20 sec.) works. The second step (ON+power, release after 10 sec.) doesn't work, The zaurus wont turn on and no emergency-system is booting. only thing working is C+D+power and diagnostic menu. I did everything exactly as it's written on the page. Any hint what could be the problem?

seiichiro0185
cal
Could someone post a screenshot of the new hotness, so those of us who can't help with the extreme testing can see what we are missing?
Xromer
QUOTE
extreme means no one tested it yet - just me! smile.gif For me it work ok.
I need another testers.
For your stuff, ill write overlay documentation at evening.


Right Sash,if it' s so, this evening i' ll begin installation and port of my stuff.
BYEZ! laugh.gif
Mickeyl
Good work Sash! UBoot should rock. I'm going to give that a try on my C3000. Do you have an idea what would be necessary to make it work on other models (tosa for one)?
sashz
QUOTE(seiichiro0185 @ May 10 2006, 02:46 AM)
Hi,

I just tried beta 4 on my C1000, but only the first step (C+D+power. green light for ~20 sec.) works. The second step (ON+power, release after 10 sec.) doesn't work, The zaurus wont turn on and no emergency-system is booting. only thing working is C+D+power and diagnostic menu. I did everything exactly as it's written on the page. Any hint what could be the problem?

seiichiro0185
*


Okay, probably new bootloader flashed ok.
1) eject battery
2) unplug power adapter
3) Press and hold ON button ("ON" , not "OK", as before in sharp loader).
4) Hold "ON" button and plug power adapter.
5) Hold "ON" about 10-15 sec

emergency linux must booting

after as you boot emergency linux, you can insert battery and close battery cover smile.gif
omro
QUOTE(seiichiro0185 @ May 10 2006, 02:46 AM)
Hi,

I just tried beta 4 on my C1000, but only the first step (C+D+power. green light for ~20 sec.) works. The second step (ON+power, release after 10 sec.) doesn't work, The zaurus wont turn on and no emergency-system is booting. only thing working is C+D+power and diagnostic menu. I did everything exactly as it's written on the page. Any hint what could be the problem?

seiichiro0185
*


I had exactly the same problem with my C1000, am wondering if there is a typo within the instructions or a missed step?

Luckily the NAND restore worked perfectly so no harm done.

QUOTE(sashz @ May 10 2006, 04:34 AM)
Okay, probably new bootloader flashed ok.
1) eject battery
2) unplug power adapter
3) Press and hold ON button ("ON" , not "OK", as before in sharp loader).
4) Hold "ON" button and plug power adapter.
5) Hold "ON" about 10-15 sec

emergency linux must booting
*


Nope nothing. Should the emergency boot just pop up during the button holding of step 5?

I have removed the battery and the SD card. I have the CF card (FAT16) with both files from the site unzipped onto the root.

Everything else, up to this point, works as described on the website.
sashz
QUOTE(Mickeyl @ May 10 2006, 04:27 AM)
Good work Sash! UBoot should rock. I'm going to give that a try on my C3000. Do you have an idea what would be necessary to make it work on other models (tosa for one)?
*


Currently i added Cxx00 and C7x0/860. Probably for tosa need add tosa NAND flash driver. That easy with one from kernel sources. I'll look later.
fiferboy
QUOTE(omro @ May 10 2006, 04:36 AM)
QUOTE(seiichiro0185 @ May 10 2006, 02:46 AM)
Hi,

I just tried beta 4 on my C1000, but only the first step (C+D+power. green light for ~20 sec.) works. The second step (ON+power, release after 10 sec.) doesn't work, The zaurus wont turn on and no emergency-system is booting. only thing working is C+D+power and diagnostic menu. I did everything exactly as it's written on the page. Any hint what could be the problem?

seiichiro0185
*


I had exactly the same problem with my C1000, am wondering if there is a typo within the instructions or a missed step?

Luckily the NAND restore worked perfectly so no harm done.

QUOTE(sashz @ May 10 2006, 04:34 AM)
Okay, probably new bootloader flashed ok.
1) eject battery
2) unplug power adapter
3) Press and hold ON button ("ON" , not "OK", as before in sharp loader).
4) Hold "ON" button and plug power adapter.
5) Hold "ON" about 10-15 sec

emergency linux must booting
*


Nope nothing. Should the emergency boot just pop up during the button holding of step 5?

I have removed the battery and the SD card. I have the CF card (FAT16) with both files from the site unzipped onto the root.

Everything else, up to this point, works as described on the website.
*



I have the exact smae problem on my C1000. Has anyone gotten this to work so far? If so, what model are you using and did you do anything different from the instructions? I have tried with the battery switch in both positions, holding the "ON" button for different lengths of time, anything I can think of.

I am eager to hear from anyone who has successfully flashed.
jpearn
Hi,

I've just tried on my 3200 and can get the bootloader on, but it's not Emergency booting . . .

Any ideas ??

Thanks

Jason.
emip
QUOTE(jpearn @ May 10 2006, 02:40 PM)
Hi,

I've just tried on my 3200 and can get the bootloader on, but it's not Emergency booting . . .

Any ideas ??

Thanks

Jason.
*


On my C3100 I have exactly the same problem too.
anunakin
-I have used poweroff command to turn off my SL-C3100...

-Next I put my SD Card... with FAT16 ... but cant install bootloader because both LEDs flashing, my SD card dont have factory format... any tip? I have tried with a MMC and RSMMC ....

-Now I cant turn on my Z! any help?
omro
On the mail.pdaxrom.com Sashz mentions that he's found the error and is correcting it. So shouldn't be long.
andresgriego
This is cool, thanks sashz!

I'll be looking into it tonight!

Awesome!
InSearchOf
Man I wish I would have read indept first... I have a unusable Zaurus... and I'm too lazy to walk upstairs and pull my NAND off my my server and copy it to my Microdrive...
So.....
I think I will just wait for sash's return...
sad.gif sad.gif sad.gif
Sorearse
QUOTE(sashz @ May 10 2006, 09:37 PM)
QUOTE(Mickeyl @ May 10 2006, 04:27 AM)
Good work Sash! UBoot should rock. I'm going to give that a try on my C3000. Do you have an idea what would be necessary to make it work on other models (tosa for one)?
*


Currently i added Cxx00 and C7x0/860. Probably for tosa need add tosa NAND flash driver. That easy with one from kernel sources. I'll look later.
*



Where can I downoad the C7x0/860 beta4 ? I would love to help out with the testing effort.
adf
I7ll give it a shot.....maybe this weekend, maybe sooner. Been looking forward to 2.6. Haven't a clue what advantage we'll see with uboot. mickeyl's enthusiasm is encouraging, though
sashz
I working for fix this problem. Please wait :-)
MONVMENTVM
today i'll buy another SD card extra for testing beta4 biggrin.gif


Just looking forward to see 2.6 running.
sashz
QUOTE(MONVMENTVM @ May 10 2006, 09:36 PM)
today i'll buy another SD card extra for testing beta4  biggrin.gif


Just looking forward to see 2.6 running.
*


wait for testing, i need fix some problems...
baallrog
perhaps my question is stupid but why the testers doesn't test the new release on sd card instead of the internal memory of the Zaurus ?
The new boot loader is just a new way to boot your Zaurus ...

i have another question : the 2.6 kernel package with the beta4 is video accelerated?? rolleyes.gif

very big thank you for your work sash !!!

you make me love this rom !!!
sashz
QUOTE(baallrog @ May 10 2006, 11:00 PM)
perhaps my question is stupid but why the testers doesn't test the new release on sd card instead of the internal memory of the Zaurus ?
The new boot loader is just a new way to boot your Zaurus ...

i have another question : the 2.6 kernel package with the beta4 is video accelerated?? rolleyes.gif

very big thank you for your work sash !!!

you make me love this rom !!!
*


1)yes, i'll think about booting from card for testing.
2)yes, qvga and overlay included.
omro
QUOTE(sashz @ May 10 2006, 11:03 PM)
QUOTE(baallrog @ May 10 2006, 11:00 PM)
perhaps my question is stupid but why the testers doesn't test the new release on sd card instead of the internal memory of the Zaurus ?
The new boot loader is just a new way to boot your Zaurus ...


1)yes, i'll think about booting from card for testing.


I'm assuming that this would only work if you've upgraded your zaurus to the new boot loader and keep with that? So if that's right, you'd only be able to do that when you're settled on using a version of pdaXrom that uses the new boot loader?

If that's the case, when the stable version is out and people are using that rather than the betas, it'll make beta testing the next version a lot easier right?
w14
Sashz,

Can you point me at the 2.6 kernel sources? I'd like to rebuild Bestcrypt ...

Thanks,

Mike.
danboid
QUOTE(sashz @ May 11 2006, 07:03 AM)
QUOTE(baallrog @ May 10 2006, 11:00 PM)
perhaps my question is stupid but why the testers doesn't test the new release on sd card instead of the internal memory of the Zaurus ?
The new boot loader is just a new way to boot your Zaurus ...

i have another question : the 2.6 kernel package with the beta4 is video accelerated?? rolleyes.gif

very big thank you for your work sash !!!

you make me love this rom !!!
*


1)yes, i'll think about booting from card for testing.
2)yes, qvga and overlay included.
*



Fantastic news! Good work sashz- I can't wait to see this new release running.

What about cpu scaling?

Am I right in thinking that uboot will bring us a unified pdaxrom for cxx00 including C3000?
Hrw
danbold: under 2.6 Zaurus models are more united then under 2.4:

- c7x0 kernel handle c700/c750/c760/c860/sl-7500
- cxx00 kernel can handle c1000/c3000/c3100/c3200

In OE/OZ we splitted cxx00 into :

- akita (c1000) which boot from flash
- spitz (c3000/c3100/c3200) which boot from microdrive and does not use flash

How Sashz will use it is his choice.
sashz
QUOTE(danboid @ May 11 2006, 01:29 AM)
What about cpu scaling?


yes.
baallrog
sashz .. i love you rolleyes.gif

sorry ...

cpu scaling + video accelerated ... tongue.gif cool.gif

My Zaurus is not a pda, it's a real computer !!!!

can we boot the new beta on sd or cf card without replace the original boot ?

the problem mentionned by a lot of people is fix or not ? It's hard to wait for testing the new release !!!!!!!

thank you very much !!!
gromituk
Could someone please explain CPU scaling? I presume it's not the same as overclocking, which you can do already! Which devices support it?

And is there any graphics acceleration possible on the 7x0/8x0 models or is it only the 1000+ models?

Thanks.
anunakin
QUOTE(gromituk @ May 11 2006, 10:29 AM)
Could someone please explain CPU scaling?  I presume it's not the same as overclocking, which you can do already!  Which devices support it?

And is there any graphics acceleration possible on the 7x0/8x0 models or is it only the 1000+ models?

Thanks.
*


If you application need more CPU the kernel do overclock or if you not need CPU this goes slow and save battery... nice not? wink.gif
gromituk
Ah thank you - so it's dynamic overclocking, and underclocking - nice indeed!
baallrog
sashz, cpu scaling is already set up in the rom or do we need to set up manually?
the kamp-idled is th daemon who manage the cpu scaling?

thanks
MONVMENTVM
ok I bought a 512MB SD Card now and tried to flash... as the others explained the bootloader thing works but emergency linux doesnt boot (as I thought before).

Is it necessary to install a backup again for the next try (after you fix it) or should I leave it for now until you release the fix? I don't need the Zaurus at the moment so I am lazy to install a backup again wink.gif
daniel3000
QUOTE(gromituk @ May 11 2006, 01:26 PM)
Ah thank you - so it's dynamic overclocking, and underclocking - nice indeed!
*


Very nice, but my experiences with frequent lockups when overclocked let me wish that there should be a configurable overclocking limit!

Under normal working conditions I didn't have these lockups, but when overclocked, then plugging in an USB device and at the same time starting a program, or similar conditione, which CAN happen but are rather rare I guess.

daniel
MONVMENTVM
oh... it seems that there are news on the blog of beta4... it has a new title:

QUOTE
pdaXrom 1.1.0beta 4 and new bootloader - for extreme testers !with serial cable! only wink.gif
InSearchOf
Serial Cable only????

I guess when I get home... beta3 is going back on... 24hr no Zaurus... I can't take it no more...

Late
emip
I don't understand. Why is a serial cable needed?
flavien
QUOTE
Pdaxrom 1.1.0beta 4 And New Bootloader, SL-Cxx00 yet, for extreme testers only


Could you rename topic please ?

SL-Cxx00 = SL-C1000 / SL-C3000 / SL-C3100 / SL-C3200

Thanks you
InSearchOf
ok... I have a slight idea....

Back when I ran the Familiar Distro on my Ipaq 5550... you would install the boot loader... then after that was loaded you would do a key combo (Direction button + Soft reset)... and it would boot into the (I assume) emergancy console... they you would terminal into the device and upload the jffs image via the terminal using YModem ...

Might be going the same route... or just a way to go about it... for the time being....
anunakin
sashz!

1- where we need serial cable? for restore?

2- Have you used a SD or CF card to install beta4, and what is you Z model?
adf
cpu scaling and overlay? A tremendous gain. I'm dying to try it. However I don't have a serial cable for my 3100, and it doesn't seem like peole are having a lot of success yet.

will this support 4 gig sd? (in theory, even though it likely hasn't been tested)
MONVMENTVM
thats the problem... it seems that nobody has a serial cable (why should people do wink.gif )

So we have to wait until sashz fixes it... hopefully soon because I'm also dying to try.


btw. I'm restoring a Backup now because I think it will not be ready today and tomorrow I'll need the zaurus again.
MONVMENTVM
oh no... my c3100 doesnt boot after restore. d+m menu still works but the zaurus doesnt boot. it's like beta4 after installing the bootloader... nothing happens.

Damn I tried it a second time... no boot-up. do I have to restore the old bootloader also?
sashz
http://mail.pdaxrom.org/node/78

new u-boot uploaded,
instruction updated
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.