Help - Search - Members - Calendar
Full Version: Symbol Cf Wifi Drivers Missing?!
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Sharp Zaurus > 5x00 General discussions
I have an 5500 with Sharp Rom 3.10. My Symbol CF low power WiFi (Rev A) was working well w/ a variety of APs. One day I was playing w/ kphone and the Z totally locked up! I removed the CF card and rebooted machine. During the reboot I saw a lot of messages from the fsck about bad inodes and stuff. When the Z was back up the CF no longer worked! I re-installed the spectrum24.ipk driver and now the WiFi card is recognized Ok and I can connect fine when WEP is off but WEP no longer works.

To debug this I turn on the logging and observed /var/log/messages. I see that when the symbol CF card is installed cardmgr tries to load modules orinoco.o and hermes.o but fails to find them. My rom image is 2.4.18...... and the only orinoco and hermes files i have are under an older install 2.4.6.... Tried to copy the older modules into the new branch of the tree but insmod says they are not compatible with the newer kernel I am running.

So....can anyone point me to a source for orinoco.o and hermes.o that are right for the 2.4.18-rmk7-pxa3-embedix (Sharp 3.10) version?

Update on the problem I previously requested help with....

I found a number of orinoco-modules.....ipk files on the ipkgfind site including one for the 2.4.18-rmkX-pxa3 kernel version. Downloaded it to the Z but the sw install did not see it. It turns out that the ipk is in debian 2.0 format and requires to be extracted with "ar" then repack with "tar" to make a valid ipk which the software install utility will recognize. After doing all this I was able to install the orinoco drivers which now provide..

orinoco.o (0.13e version)

Now when I insert the Symbol WLAN card (Rev A), I see no error messages about not finding orinoco.o and hermes.o module (good!). Sadly, WEP still does not work!

Although there are no missing drivers reported in /var/log/messages I do see that the previous kernal archive has a spectrum_cs.o file which is not in the latest kernel version.

Any advice from the experts on getting WEP working (again) with the Symbol CF appreciated.

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.