Help - Search - Members - Calendar
Full Version: Xqt For 6000
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Sharp Zaurus > 6000 - Tosa
Meanie
Just in case you have not noticed yet, there is a new version of X/Qt available for Sharp/Cacko ROM that can run many of the apps available for pdaXrom. This version should display all the apps in the right resolution and size for the 6000 but haven't tested that since I don't have a 6000.
http://www.users.on.net/~hluc/myZaurus/jumbo/pdaxqtrom.html
trichmon
Thanks man. I gave this a try today and I get a missing libiconv.so.2


todd
Meanie
QUOTE(trichmon @ May 21 2006, 08:06 AM)
Thanks man.  I gave this a try today and I get a missing libiconv.so.2


todd
*


thanks for testing it. does the 6000 have a ldconfig command?
libiconv.so.2 should be under /usr/lib
trichmon
it does have the ldconfig command. I started over to make sure that i didnt miss anything. The installer seems to have trouble finding libiconv.so.w as well.

The sharp rom does not seem to have that library by default. I cant seem to find it in the cacko or zug feed either.
Meanie
QUOTE(trichmon @ May 21 2006, 02:27 PM)
it does have the ldconfig command.  I started over to make sure that i didnt miss anything.  The installer seems to have trouble finding libiconv.so.w as well. 

The sharp rom does not seem to have that library by default.  I cant seem to find it in the cacko or zug feed either.
*


do you have writable /usr/lib directory?
and is /usr/lib defined in /etc/ld.so.conf?
trichmon
QUOTE(Meanie @ May 20 2006, 08:37 PM)
QUOTE(trichmon @ May 21 2006, 02:27 PM)
it does have the ldconfig command.  I started over to make sure that i didnt miss anything.  The installer seems to have trouble finding libiconv.so.w as well. 

The sharp rom does not seem to have that library by default.  I cant seem to find it in the cacko or zug feed either.
*


do you have writable /usr/lib directory?
and is /usr/lib defined in /etc/ld.so.conf?
*



Im not sure if Im answering this correct but if you mean can I write to the /usr/lib dir in the sharp rom the answer is yes

Yes it is listed in /etc/ld.so.conf

Todd
Meanie
QUOTE(trichmon @ May 21 2006, 03:01 PM)
QUOTE(Meanie @ May 20 2006, 08:37 PM)
QUOTE(trichmon @ May 21 2006, 02:27 PM)
it does have the ldconfig command.  I started over to make sure that i didnt miss anything.  The installer seems to have trouble finding libiconv.so.w as well. 

The sharp rom does not seem to have that library by default.  I cant seem to find it in the cacko or zug feed either.
*


do you have writable /usr/lib directory?
and is /usr/lib defined in /etc/ld.so.conf?
*



Im not sure if Im answering this correct but if you mean can I write to the /usr/lib dir in the sharp rom the answer is yes

Yes it is listed in /etc/ld.so.conf

Todd
*



you should have symbolic links for libiconv.a libiconv.so libiconv.so.2 and libiconv.so.2.2.0 under /usr/lib
ldconfig should then be able to load libiconv.so.2 and the apps should then work
trichmon
QUOTE(Meanie @ May 20 2006, 09:23 PM)
QUOTE(trichmon @ May 21 2006, 03:01 PM)
QUOTE(Meanie @ May 20 2006, 08:37 PM)
QUOTE(trichmon @ May 21 2006, 02:27 PM)
it does have the ldconfig command.  I started over to make sure that i didnt miss anything.  The installer seems to have trouble finding libiconv.so.w as well. 

The sharp rom does not seem to have that library by default.  I cant seem to find it in the cacko or zug feed either.
*


do you have writable /usr/lib directory?
and is /usr/lib defined in /etc/ld.so.conf?
*



Im not sure if Im answering this correct but if you mean can I write to the /usr/lib dir in the sharp rom the answer is yes

Yes it is listed in /etc/ld.so.conf

Todd
*



you should have symbolic links for libiconv.a libiconv.so libiconv.so.2 and libiconv.so.2.2.0 under /usr/lib
ldconfig should then be able to load libiconv.so.2 and the apps should then work
*



That got a little farther. Now i get this error when I run startx

fluxbox:error while loading shared libraries: libiconv.so.2: cannot load shared object file: Error 21

Todd
trichmon
here is the output of my ldconfig command

ldconfig: Cannot mmap file /usr/lib/libesd.so.

ldconfig: Cannot mmap file /usr/lib/libfltk-utf8_forms.so.

ldconfig: Cannot mmap file /usr/lib/libImlib.so.1.

ldconfig: Cannot mmap file /usr/lib/libid3tag.so.

ldconfig: Cannot mmap file /usr/lib/libORBit-imodule-2.so.0.

ldconfig: Cannot mmap file /usr/lib/libbonoboui-2.so.0.

ldconfig: /usr/lib/libimlib-bmp.so is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libgnutls-extra.so.11.

ldconfig: Cannot mmap file /usr/lib/libmad.so.

ldconfig: /usr/lib/libimlib-gif.so is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libgoffice-1.so.

ldconfig: Cannot mmap file /usr/lib/libgnomecanvas-2.so.0.

ldconfig: Cannot mmap file /usr/lib/libssl.so.

ldconfig: Cannot mmap file /usr/lib/libpoppler.so.1.

ldconfig: Cannot mmap file /usr/lib/libpoppler-qt.so.

ldconfig: /usr/lib/libgnomeprint-2-2.so.0.1.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libpoppler.so.1.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libcharset.so.1.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libbz2.so.1.0.2 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libgnome-keyring.so.0.

ldconfig: /usr/lib/libimlib-png.so is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libimlib-ppm.so is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libiconv.so.2.

ldconfig: Cannot mmap file /usr/lib/libscim-1.0.so.8.

ldconfig: Cannot mmap file /usr/lib/libgpg-error.so.

ldconfig: /usr/lib/libgnomeprintui-2-2.so.0.1.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libgnomeui-2.so.0.1000.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libgoffice-1.so.1.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libgnutls-extra.so.

ldconfig: /usr/lib/libgdk_imlib.so.1.9.15 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libgcrypt.so.11.

ldconfig: /usr/lib/libimlib-xpm.so is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libXutf8.so.0.

ldconfig: Cannot mmap file /usr/lib/libxd640.so.

ldconfig: /usr/lib/libaudiofile.so.0.0.2 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libscim-x11utils-1.0.so.

ldconfig: /usr/lib/libtasn1.so.2.0.9 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libXutf8.so.

ldconfig: Cannot mmap file /usr/lib/libgsf-gnome-1.so.

ldconfig: Cannot mmap file /usr/lib/libtasn1.so.

ldconfig: Cannot mmap file /usr/lib/libgnomeprintui-2-2.so.

ldconfig: /usr/lib/libgnutls-openssl.so.11.0.10 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libstdc++.so.5.

ldconfig: Cannot mmap file /usr/lib/libstdc++.so.6.

ldconfig: /usr/lib/libstartup-notification-1.so.0.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libgnutls.so.

ldconfig: Cannot mmap file /usr/lib/libtasn1.so.2.

ldconfig: Cannot mmap file /usr/lib/libpopt.so.0.

ldconfig: Cannot mmap file /usr/lib/libORBitCosNaming-2.so.0.

ldconfig: Cannot mmap file /usr/lib/libgnutls-openssl.so.11.

ldconfig: /usr/lib/libao.so.2.1.2 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libscim-gtkutils-1.0.so.8.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libstdc++-3-libc6.2-2.so.3.

ldconfig: Cannot mmap file /usr/lib/libgnutls-openssl.so.

ldconfig: Cannot mmap file /usr/lib/libcairo.so.2.

ldconfig: /usr/lib/libgconf-2.so.4.1.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libiconv.so.2.2.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libbonobo-activation.so.

ldconfig: Cannot mmap file /usr/lib/libgcrypt.so.

ldconfig: /usr/lib/libgnutls.so.11.0.10 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libglade-2.0.so.

ldconfig: Cannot mmap file /usr/lib/libbonoboui-2.so.

ldconfig: /usr/lib/libbonobo-activation.so.4.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libgnome-2.so.

ldconfig: Cannot mmap file /usr/lib/libpcreposix.so.0.

ldconfig: Cannot mmap file /usr/lib/libart_lgpl_2.so.

ldconfig: /usr/lib/libexslt.so.0.8.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libglade-2.0.so.0.0.7 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libgnomevfs-2.so.0.1000.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libart_lgpl_2.so.2.

ldconfig: Cannot mmap file /usr/lib/libgnomeprintui-2-2.so.0.

ldconfig: /usr/lib/libid3tag.so.0.3.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libesd.so.0.

ldconfig: Cannot mmap file /usr/lib/libstartup-notification-1.so.

ldconfig: Cannot mmap file /usr/lib/libgnutls.so.11.

ldconfig: Cannot mmap file /usr/lib/libpoppler-qt.so.1.

ldconfig: /usr/lib/libstdc++.so.5.0.5 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libstdc++.so.6.0.3 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libfribidi.so.0.

ldconfig: Cannot mmap file /usr/lib/libesddsp.so.

ldconfig: /usr/lib/libgnutls-extra.so.11.0.10 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libgdk_imlib.so.

ldconfig: /usr/lib/libpcre.so.0.0.1 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libxslt.so.

ldconfig: Cannot mmap file /usr/lib/libungif.so.4.

ldconfig: Cannot mmap file /usr/lib/libstartup-notification-1.so.0.

ldconfig: Cannot mmap file /usr/lib/libcharset.so.

ldconfig: /usr/lib/libmad.so.0.2.1 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libmad.so.0.

ldconfig: Cannot mmap file /usr/lib/libgnomeui-2.so.

ldconfig: /usr/lib/libXutf8.so.0.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libstdc++-3-libc6.1-2.so.3.

ldconfig: Cannot mmap file /usr/lib/libxslt.so.1.

ldconfig: Cannot mmap file /usr/lib/libgsf-1.so.113.

ldconfig: /usr/lib/libgnome-2.so.0.1000.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libImlib.so.1.9.15 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libesddsp.so.0.2.34 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libiconv.so.

ldconfig: /usr/lib/libesd.so.0.2.34 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libgpg-error.so.0.

ldconfig: Cannot mmap file /usr/lib/libesddsp.so.0.

ldconfig: /usr/lib/libORBit-2.so.0.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libORBit-2.so.

ldconfig: Cannot mmap file /usr/lib/libcairo.so.

ldconfig: Cannot mmap file /usr/lib/libscim-x11utils-1.0.so.8.

ldconfig: Cannot mmap file /usr/lib/libopencdk.so.

ldconfig: Cannot mmap file /usr/lib/libaudiofile.so.

ldconfig: Cannot mmap file /usr/lib/libfltk-utf8_images.so.

ldconfig: /usr/lib/libpoppler-glib.so.1.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libopencdk.so.8.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libImlib.so.

ldconfig: /usr/lib/libgcrypt.so.11.1.1 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libbonoboui-2.so.0.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libscim-1.0.so.8.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libpoppler-qt.so.1.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libbonobo-2.so.0.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libfltk-utf8_forms.so.1.1 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libpoppler-glib.so.

ldconfig: Cannot mmap file /usr/lib/libcrypto.so.

ldconfig: /usr/lib/libimlib-tiff.so is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libgoffice-1.so.1.

ldconfig: Cannot mmap file /usr/lib/libssl.so.0.

ldconfig: Cannot mmap file /usr/lib/libstdc++.so.

ldconfig: Cannot mmap file /usr/lib/libscim-1.0.so.

ldconfig: /usr/lib/libungif.so.4.1.3 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libscim-x11utils-1.0.so.8.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libgdk_imlib.so.1.

ldconfig: /usr/lib/libgsf-gnome-1.so.113.0.2 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libao.so.2.

ldconfig: Cannot mmap file /usr/lib/libbonobo-2.so.0.

ldconfig: /usr/lib/libgpg-error.so.0.1.2 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libORBit-imodule-2.so.

ldconfig: /usr/lib/libORBitCosNaming-2.so.0.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libgnomecanvas-2.so.0.600.1 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libscim-gtkutils-1.0.so.8.

ldconfig: Cannot mmap file /usr/lib/libpcre.so.0.

ldconfig: Cannot mmap file /usr/lib/libexslt.so.0.

ldconfig: Cannot mmap file /usr/lib/libpcre.so.

ldconfig: Cannot mmap file /usr/lib/libbonobo-2.so.

ldconfig: Cannot mmap file /usr/lib/libpcreposix.so.

ldconfig: /usr/lib/libpopt.so.0.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libgconf-2.so.

ldconfig: Cannot mmap file /usr/lib/libgnomecanvas-2.so.

ldconfig: Cannot mmap file /usr/lib/libopencdk.so.8.

ldconfig: /usr/lib/libxslt.so.1.1.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libpoppler-glib.so.1.

ldconfig: Cannot mmap file /usr/lib/libgnomevfs-2.so.0.

ldconfig: Cannot mmap file /usr/lib/libpopt.so.

ldconfig: Cannot mmap file /usr/lib/libORBitCosNaming-2.so.

ldconfig: Cannot mmap file /usr/lib/libbz2.so.1.0.

ldconfig: /usr/lib/libimlib-ps.so is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libaudiofile.so.0.

ldconfig: Cannot mmap file /usr/lib/libgnome-2.so.0.

ldconfig: Cannot mmap file /usr/lib/libfribidi.so.

ldconfig: /usr/lib/libgnome-keyring.so.0.0.1 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libORBit-imodule-2.so.0.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libgsf-gnome-1.so.113.

ldconfig: Cannot mmap file /usr/lib/libgconf-2.so.4.

ldconfig: /usr/lib/libpcreposix.so.0.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libexslt.so.

ldconfig: Cannot mmap file /usr/lib/libcrypto.so.0.

ldconfig: /usr/lib/libcharset.so.1 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libungif.so.

ldconfig: /usr/lib/libfribidi.so.0.0.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libfltk-utf8_images.so.1.1 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libao.so.

ldconfig: Cannot mmap file /usr/lib/libglade-2.0.so.0.

ldconfig: Cannot mmap file /usr/lib/libpoppler.so.

ldconfig: Cannot mmap file /usr/lib/libgnomeprint-2-2.so.

ldconfig: Cannot mmap file /usr/lib/libfltk-utf8.so.

ldconfig: Cannot mmap file /usr/lib/libgnome-keyring.so.

ldconfig: /usr/lib/libimlib-jpeg.so is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libgnomevfs-2.so.

ldconfig: Cannot mmap file /usr/lib/libgnomeprint-2-2.so.0.

ldconfig: /usr/lib/libcairo.so.2.2.2 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libxd640.so.1 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libgsf-1.so.113.0.2 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libgsf-1.so.

ldconfig: Cannot mmap file /usr/lib/libscim-gtkutils-1.0.so.

ldconfig: Cannot mmap file /usr/lib/libid3tag.so.0.

ldconfig: Cannot mmap file /usr/lib/libgnomeui-2.so.0.

ldconfig: Cannot mmap file /usr/lib/libbonobo-activation.so.4.

ldconfig: /usr/lib/libfltk-utf8.so.1.1 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/lib/libbz2.so.

ldconfig: Cannot mmap file /usr/lib/libORBit-2.so.0.

ldconfig: /usr/lib/libart_lgpl_2.so.2.3.16 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libbluetooth.so.1 is not a symbolic link

ldconfig: /usr/local/lib/libgmodule.so is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/local/lib/libgmodule-1.2.so.0.0.10 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/local/lib/libImlib2.so.

ldconfig: /usr/local/lib/libgthread-1.2.so.0.0.10 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/local/lib/libglib.so.

ldconfig: /usr/local/lib/libgthread-1.2.so.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/local/lib/libImlib2.so.1.2.1 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/local/lib/libImlib2.so.1.

ldconfig: /usr/local/lib/libgthread.so is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/local/lib/libgiblib.so.1.0.6 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/local/lib/libglib-1.2.so.0.0.10 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/local/lib/libgiblib.so.

ldconfig: Cannot mmap file /usr/local/lib/libglib-1.2.so.0.

ldconfig: /usr/local/lib/libgmodule-1.2.so.0 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: Cannot mmap file /usr/local/lib/libgiblib.so.1.
Meanie
oh gosh, seems like ldconfig does not like most of the libraries

what version is ldconfig?

ldconfig --version
trichmon
QUOTE(Meanie @ May 20 2006, 10:07 PM)
oh gosh, seems like ldconfig does not like most of the libraries

what version is ldconfig?

ldconfig --version
*



(gnu libc) 2.2.2
Meanie
QUOTE(trichmon @ May 21 2006, 04:16 PM)
QUOTE(Meanie @ May 20 2006, 10:07 PM)
oh gosh, seems like ldconfig does not like most of the libraries

what version is ldconfig?

ldconfig --version
*



(gnu libc) 2.2.2
*



that is really bizare. it doesnt complain about any of the libraries under /opt/QtPalmtop/lib but all thw ones under /usr/lib

did you run out of space by any chance?
trichmon
good call. I have 424 bytes left in / after I run the installer. Not sure what I can remove. Most of my stuff is installed on sd card.

Todd
trichmon
Ok so was wrong (sorry its late for me) and I have over 8megs of space after the install.

Todd
Meanie
QUOTE(trichmon @ May 21 2006, 05:38 PM)
Ok so was wrong (sorry its late for me) and I have over 8megs of space after the install. 

Todd
*


i am really scratching my head here about what could be wrong.
could you get me a dump of your file structure?

find / -print > somefile

and also give me the output for

ls -la /usr/lib/

df -h

mount
trichmon
ls -la /usr/lib

lrwxrwxrwx 1 root root 18 Feb 17 2004 /usr/lib -> /home/root/usr/lib


mount
/dev/root on / type jffs2 (ro)
/proc on /proc type proc (rw)
/dev/ram1 on /dev type minix (rw)
/dev/mtdblock3 on /home type jffs2 (rw,noatime)
none on /dev/shm type tmpfs (rw)
none on /dev/pts type devpts (rw)
usbdevfs on /proc/bus/usb type usbdevfs (rw)
/dev/mmcda1 on /usr/mnt.rom/card type ext2 (rw)
/dev/loop0 on /home/system/var/mnt/pdaXqtrom-base type cramfs (rw)
/dev/loop1 on /home/system/var/mnt/pdaXqtrom-apps type cramfs (rw)
/dev/hda1 on /usr/mnt.rom/cf type vfat (rw,noatime)

/dev/root 28.0M 27.6M 424.0k 99% /
/dev/ram1 44.0k 29.0k 15.0k 66% /dev
/dev/mtdblock3 29.0M 20.7M 8.3M 71% /home
none 1.0M 244.0k 780.0k 24% /dev/shm
/dev/mmcda1 961.0M 165.5M 746.7M 18% /usr/mnt.rom/card
/dev/loop0 116.1M 116.1M 0 100% /home/system/var/mnt/pdaXqtrom-base
/dev/loop1 171.0M 171.0M 0 100% /home/system/var/mnt/pdaXqtrom-apps
/dev/hda1 486.1M 168.4M 317.6M 35% /usr/mnt.rom/cf

output of find command attached
Meanie
QUOTE(trichmon @ May 22 2006, 03:14 AM)
ls -la /usr/lib

lrwxrwxrwx    1 root    root          18 Feb 17  2004 /usr/lib -> /home/root/usr/lib


mount
/dev/root on / type jffs2 (ro)
/proc on /proc type proc (rw)
/dev/ram1 on /dev type minix (rw)
/dev/mtdblock3 on /home type jffs2 (rw,noatime)
none on /dev/shm type tmpfs (rw)
none on /dev/pts type devpts (rw)
usbdevfs on /proc/bus/usb type usbdevfs (rw)
/dev/mmcda1 on /usr/mnt.rom/card type ext2 (rw)
/dev/loop0 on /home/system/var/mnt/pdaXqtrom-base type cramfs (rw)
/dev/loop1 on /home/system/var/mnt/pdaXqtrom-apps type cramfs (rw)
/dev/hda1 on /usr/mnt.rom/cf type vfat (rw,noatime)

/dev/root                28.0M    27.6M    424.0k  99% /
/dev/ram1                44.0k    29.0k    15.0k  66% /dev
/dev/mtdblock3          29.0M    20.7M      8.3M  71% /home
none                      1.0M    244.0k    780.0k  24% /dev/shm
/dev/mmcda1            961.0M    165.5M    746.7M  18% /usr/mnt.rom/card
/dev/loop0              116.1M    116.1M        0 100% /home/system/var/mnt/pdaXqtrom-base
/dev/loop1              171.0M    171.0M        0 100% /home/system/var/mnt/pdaXqtrom-apps
/dev/hda1              486.1M    168.4M    317.6M  35% /usr/mnt.rom/cf

output of find command attached
*


so far I cannot find anything wrong sad.gif

can you also show me

ls /home/root/usr/lib/*

I am suspecting a corruption on your file system.
you might want to delete all the links that ldconfig is complaining about, and maybe fsck your sd/cf as well and then try again
amdonati
Sorry Meanie, but I am a bit lost.
On my 6000 should I install the latest pdaxqtrom-base image or should I instead install all the IPK in the base feed in order to have the latest X/QT you are speaking about here?

Thank you,
Cheers,
Adalberto
Meanie
QUOTE(amdonati @ May 22 2006, 09:58 PM)
Sorry Meanie, but I am a bit lost.
On my 6000 should I install the latest pdaxqtrom-base image or should I instead install all the IPK in the base feed in order to have the latest X/QT you are speaking about here?

Thank you,
Cheers,
Adalberto
*


all you need is to install pdaxqtrom-base and pdaxqtrom-apps

the ipk files are for those who want to do it the hard way and install and configure each package themselves...
trichmon
meanie: that did the trick. redownloaded the files from your page and formated my sd card. Only problem i have now is with the embed feature. When i run apps with the embed flag it says

debug: there are 0 embedded processesses
debug: no embedded processesses
debug: setting display to :1.0
launching dillo embedded - please wait a moment...

then nothing.
Meanie
QUOTE(trichmon @ May 23 2006, 01:51 AM)
meanie: that did the trick.  redownloaded the files from your page and formated my sd card.  Only problem i have now is with the embed feature.  When i run apps with the embed flag it says

debug: there are 0 embedded processesses
debug: no embedded processesses
debug: setting display to :1.0
launching dillo embedded - please wait a moment...

then nothing.
*


yes, i just realised from another post that there is a little bug. if you look under /opt/QtPalmtop/bin there are two files Xqt-rootless1 and Xqt-rootless2
they should be Xqt-rootless-1 and Xqt-rootless-2
just rename them
if you want to disable the rootless feature for th3e desktop icons and have them launch into the full xqt session, then simply remove the file /etc/X11/app-defaults/Xembed

btw, do the apps come up in the right size? is the default terminal size ok?
trichmon
that did the trick.


no the window that opens is shaped for a clamshell so its not very functional. But really close. And running them with xlauncer appname runs fine.

Thanks
amdonati
QUOTE(Meanie @ May 22 2006, 04:19 AM)
all you need is to install pdaxqtrom-base and pdaxqtrom-apps
*


Great,
Thanks,
Adalberto
eji
This looks fantastic. I'm going to let the more adventurous Tosa users play around with it and report back on any bugs (especially with the 3000 automounter IPK), and then I'll feel more comfortable about installing it.

Thanks, Meanie.
adf
QUOTE(eji @ May 24 2006, 12:35 PM)
This looks fantastic. I'm going to let the more adventurous Tosa users play around with it and report back on any bugs (especially with the 3000 automounter IPK), and then I'll feel more comfortable about installing it.

Thanks, Meanie.
*

I have a 6000 (and a 3100) Been playing with cacko/pdxqt on the 3100. It is nice. On your tosa, I think you're gonna want tetsu's kernel, the commbattery applet, and prbably spend as little time messing around with versions of libsdl. My 6k is on pdaxrom beta1.1 (ironic, 'cuz meanie's project interested me more for the 6000 than the 3100 -and in the end it will be pdaxqt on the 6 and the newest pdax o the 3100, I think) At any rate, maybe someone has recent experience w/ tetsu and libsdl?
trichmon
meanie your page talks about a version xqt that comes as a tar.gz file that I can just extract to sd. But i could not find it on your site. Is it still available?

Thanks
Todd
Meanie
QUOTE(trichmon @ Jun 8 2006, 07:20 AM)
meanie your page talks about a version xqt that comes as a tar.gz file that I can just extract to sd.  But i could not find it on your site.  Is it still available?

Thanks
Todd
*


I haven't build the tar.gz file yet. I plan to only build it for the final release only.

also, I think it is better for 6000 users to disable embedded mode because embedded mode does not allow window resizing.
just run:

# su
# xembed off

if anyone finds problems with the keymapping, please use xev to determine the right key codes and send me the updated xmodmaprc file so I can include it.
also, if the window size is incorrect, post a screenshot of the offending app and I will try to fix, but it is not always possible. the screensize for xembedded mode apps cannot be changed thus is recommend to disable xembedded mode.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.