Help - Search - Members - Calendar
Full Version: Kphone On 1.1.0beta1
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
johnsutton
I'm trying to get kphone v4.04 going on a c1000 running 1.1.0beta1.

I've managed to get a few calls to test numbers connected and actually heard stuff but I've yet to be able to speak to anyone. The problem seems to be to do with the OSS sound system and /dev/dsp. The really big problem is that whenever you place a call, kphone hangs _for_some_minutes_ at:

CallAudio: Opening OSS device /dev/dsp for Input and Output

After this long delay, it sometimes connects the call and sometimes timesout, but this delay makes it virtually impossible to experiment with different settings to see if something in the config will fix it.

Has anyone got kphone going recently? I see from previous posts that people have had it going in the past on previous versions of pdaxrom.

TIA
John
ratki
I'm using 1.1.0beta1 on SL-C750. KPhone 4.0.4 works without any problem.

Tamás
zedkatuf2
QUOTE(ratki @ May 20 2006, 08:33 PM)
I'm using 1.1.0beta1 on SL-C750. KPhone 4.0.4 works without any problem.

Tamás
*


Could you post your ipk of this somewhere, as I'm having similar problems with my version.

zedkatuf.
karlto
QUOTE(johnsutton @ May 20 2006, 12:12 AM)
... The problem seems to be to do with the OSS sound system and /dev/dsp.  The really big problem is that whenever you place a call, kphone hangs _for_some_minutes_ at:

CallAudio: Opening OSS device /dev/dsp for Input and Output

I believe that pdaXrom generally uses the esound daemon, rather than directly opening the device. Trying to open it directly normally fails as other things (the daemon) are busy using it and have it locked.

I imagine there are two options - kill all other sound daemons, programs that use it etc before running kphone, or get a version of kphone that uses esound. I wonder if the one ratki has is a different ipk to yours?

(ps - all of this is conjecture, I have not even tried kphone - just had similar problems with the gpe apps and sound)
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.