Help - Search - Members - Calendar
Full Version: Dhh1 Error!
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
xamindar
I have this strange problem all of a sudden. The reason I'm starting a new topic is because it seems to be a little different than the other hard drive errors.

I simply rebooted my zaurus last night, I hadn't done anything strange at all.
First of all, I recently went back to the original japanese sharp rom with tetsus kernel. When It booted up last night everything looked fine until it got to the mounting the hard drive part. It listed all the partitions then stopped with an error "hdd1 error!!".

Now I have tried going into the d+m menu and the flash menu but it seems to not work any more. If I hold D+M down it just tried booting normaly. And if I try holding down the OK button and turning it on it doesn't even turn on, nothing happens. I will continue trying, by taking the battery out for a few minutes and the like but I'm really worried.

Has anyone had this problem? I have never messed with the internal hard drive partitions besides formatting the 3rd (data) partition a couple of times.

EDIT: ok, it just went into the mainanence menu (OK+on) woohoo, lets see what I can do. unsure.gif

EDIT2: It's running the disk checker right now. It gave errors with hda1 (how did it get messed up?!?) but the other partitions seemed fine. It did not fix the errors though, is there a way to get it to fix them?
daniel3000
QUOTE(xamindar @ May 29 2006, 09:23 PM)
EDIT2:  It's running the disk checker right now.  It gave errors with hda1 (how did it get messed up?!?) but the other partitions seemed fine.  It did not fix the errors though, is there a way to get it to fix them?
*


If you boot into the B+D emergency console, you can do a

fsck.ext2 -v -f -c /dev/hda1

That will ask you in case of errors if they should be fixed. The -c dies an additional check for bad blocks. Takes long, but may be worth it in case of flash memory hardware failures.

Good luck!

daniel
DoTheDog
The other thing to check is to make sure you have a hdimage2.tgz hdlist1.dat in the /hdd1/.sys/ folder. If they are not there you will get the hdd1 error as well.
bam
you can always add a fsck to your rc.rofilesys to check it on every re-boot, I have instructions on my site on how to do this. oh wait you have cacko...you have to remount / as rw then change /sbin/hddmount and add the fsck to that script, again its on my site smile.gif
xamindar
QUOTE(DoTheDog @ May 29 2006, 05:09 PM)
The other thing to check is to make sure you have a hdimage2.tgz hdlist1.dat in the /hdd1/.sys/ folder. If they are not there you will get the hdd1 error as well.
*


Is that true on the 3100? I didn't think it used those first two partitions at all. I might have erased the data on them at some point. But that doesn't explain why it worked fine for at least 10 reboots until giving this hdd1 error.

Dang, I'm still having trouble getting into the B+D menu. blink.gif

EDIT: hmm, I booted the cacko instalation script and went into the console and ran that fsck command. It seems to think the partition is ext3 and that it can not find the journal blink.gif . I'm just going to fdisk the thing ans refoemat it.

EDIR2: OK, I reformated it ext2 and fsck'd it to make sure. Rebooted and I still get an hd1 error. "EXT3: No journal on filesystem". So is it supposed to be ext3? An 8md ext3 partition doesnt make sense.
bam
actually it checks them on reboot and mounting, you could remove the checking script in rc.rofilesys, but I'm lazy, ah hek here is what I did, havent had an issue since:


remount / as rw - open the terminal
#sudo mount -o remount,rw /

in /home/root/rc.d/rc.rofilesys add the following
around Line 333 you will see, echo "HDD found at /dev/${IDE1}", below it add:
e2fsck -p /dev/${IDE1}1 > /var/log/fsck-hdd.log

then around Line 349 you will see, echo "Mounted /hdd1", below it add:
e2fsck -p /dev/${IDE1}2 >> /var/log/fsck-hdd.log

therefore everytime you reboot it will perform a nice e2fsck and log it to a log

oh, btw I repartitioned and made my /hdd2 256mb(actually should have made it 512mb but oh well, I use it to clean up my ~ for frequently modified files, I just symlink it back to its "original" location, also I have dev-img, gcc and python images mounted there to.
Cresho
xamindar, i had the same problem when I cleared my hardisk in the D+M menu. If you have no expirience with fdisk or booting up into terminal from scratch or navigating through directories in the terminal, you are in for a long long night of madness.

anyway, i live in southern california, los angeles area, if you live around the area, we can get together and i can fix your hardisk partition. If you flash cacko 1.23, you will have no problems but using the sharprom, it looks to make sure your partition is in order before it booots. If the partitions are not in order, you will get that problem with the hd error.

or, if you want, if you are really having problems, we can meet up in msn and i can help you restore your partitions. I have time since its summer time.
xamindar
Hey thanks for the help guys. Cresho, I might take you up on that msn offer. I have no problem with navigating Linux though. I have used it sense 1998. It is just a matter of understanding how the zaurus hardware works. I had a busy day today with my family but every little chance I got I took a crack at the Z. I eventually got back into the D+M menu (I forgot I had to hold the buttons down while I put the battery back in) and I formatted the drive, ran a read/write test which took a couple hours dang it! Anyway, it seems fine. I just neet to know a couple of things:

1-What are the filesystems on the three partitions? I know the third one is fat, but from the errors I got the first two are ext3. Ext3 doesn't make sense to me though.
2-Does it matter what the partition sizes are as long as there are three? I assume it doesn't.
3-Isn't there some hard drive restore file that I can use through the NAND restore menu?

It's just so stupid that the roms (yes cacko does too) will not boot with a messed up first or second hard drive partition. I guess it does use it in some way.
Cresho
okay...lets start off. with the basic downloads. THis is going to take a while. Since i am working on updating a few things at zaurusthemes and also the emulator zip file, ill be updating this particular post with the absolute stuff you need to get started.


start
-----------------------------------------------------------------------------
first off, download this
http://www.trisoft.de/download/SLC3100SYSPART.zip
copy the unziped stuff to a compact flash.


secondly, download
http://www.trisoft.de/pdf/c3000qse.pdf
and go to page 35 and learn how to get into "boot-command line"


now we need to look at a few partitions.
for the c-3100, your internal hardrive partitions should look like this.
according to the readme.txt within the slc3100syspart.zip, your partitions should all look like this
SL-C3100 HDD-Partition table:
/dev/hda1 Start 1 End 20 Blocks 10048+ id 83 System Linux
/dev/hda2 Start 21 End 40 Blocks 10080 id 83 System Linux
/dev/hda3 Start 41 End 7936 Blocks 3979584 id c System Win95 FAT32 (LBA)

use primary and su. If you are having problems using fdisk, ill post the commands. Delete all partitions in your disk and create from scratch each partition blocks according to the hda1 1-20 hda2 21-40 both system linux and hda3 41-7936 win95 fat32 (lba). make sure you are su "superuser" and umount the drives. read the readme for the extra info.

after you set up your 3 partitions and checked if they all comply to the trisoft's suggestion, you need to put some files in the partition.

copy the contents of hdd1sys into the /hdd1/.sys or /dev/hdd1/.sys
copy the contents of hdd2sys into the /hdd2/.sys or /dev/hdd2/.sys
which ever works cuz i can't remember unless i tried it.
reboot and check if it worked.



being updated. just looking for my stuff! Finished 1:25am waiting for comments....rechecking post @ 1:45am pst
-----------------------------------------------------------------------------
end

trisoft made it possible for me cuz these files are not anywhere to be found. so far the only ones i seen post these files so far.
xamindar
Hey thanks. On my end I just rebuilt the partitions by going to the console from the cacko install script. /dev/hdc1 and /dev/hdc2 are the same size as they should be (both 9mb) and formatted as ext3. Then I formatted /dev/hdc3 using mkfs.vfat. I really don't know the difference between mkfs.msdos and mkfs.vfat. But I guess whatever I did was wrong because I get the error "Error!! HDD is not initialized!" when I try to boot up (sharp rom).

Thanks for the help, checking it out right now.

EDIT: GREAT! The DB option is a lot easier. smile.gif

EDIT2: Ok, i assume I am getting the new error because those .sys files are not on the hard drive. I'll follow the readmy of the files you posted and see if that helps. Thanks again! biggrin.gif
Cresho
QUOTE(xamindar @ May 29 2006, 11:54 PM)
Ok, i assume I am getting the new error because those .sys files are not on the hard drive.  I'll follow the readmy of the files you posted and see if that helps.  Thanks again! biggrin.gif
*



Bingo!
xamindar
That's it! I officially HATE Open Zaurus! I do not have a cf card reader so instead I am trying to use my old 5600 as the reader to get that hard drive info. I made the grave mistake of putting OZ on it. OZ doesn't seem to use samba, while connected to my pc, I can't use sftp to get to it, only ssh. Konquir on OZ CAN'T EVEN DOWNLOAD A ZIP FILE!!! So I had to use wget, no biggie. Now guess what, there isn't even an unzip program included. Lets see, does the default feed include unzip? HELL NO! So now I have to search for one. That wont even happen unless it just happens by chance to connect its self to one of the few access points near me that are open. MAN I'm frustrated. When this is all over it's back to the sharp rom for both my Z's.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.