Help - Search - Members - Calendar
Full Version: Not Creating Empty Archive
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > OpenZaurus/Opie/Qtopia
ShiroiKuma
I think I'm doing something fundamentally wrong with Bitbake.

I tried to compile Gnushogi. Made the bb file. Ran bitbake. It downloaded the file, then quickly ran and finished configure and compile, i.e. didn't do anything, since it's impossible this fast and then, it says:
CODE
NOTE: Not creating empty archive for gnushogi-1.3-r0

Why?

What did I do wrong?
JohnX
Did you put the line:
CODE
inherit autotools

in your .bb file?
ShiroiKuma
QUOTE(JohnX @ Jun 5 2006, 12:36 AM)
Did you put the line:
CODE
inherit autotools

in your .bb file?
*

Right, I did make that mistake... smile.gif
Trying again now.
ShiroiKuma
In the meantime, I'm trying also on the Z. But compilation stops at xshogi, complaining:
CODE
/usr/local/lib/libXaw.so: undefined reference to 'XUnsetICFocus'
and undefined reference to XGetIMValues, and XSetICValues and so on...

Searching the web I've found an old message in OE archives mentioning that full libX11 is needed for this compilation, and that it comes about because of using a stripped libX11, well I have libx11-6 and libx11-dev installed, but nothing... Is there anything else that causes these undefined references, or is this libx11-6 not full?
ShiroiKuma
This is the post in OE archives, I've found.

I get exactly the same undefined reference errors.

I thought that it's since xshogi is so old, from 1997 or so... So I went and recompiled all of libX11, and installed, admittedly not a wise thing to do. Anyhow didn't help and on top of that, the GPE install got messed and wouldn't login after reboot.

So am wondering, is there another way to get this xshogi to compile, the gnushogi engine part compiles, it's just the Xt/Athena widget, which is the graphical frontend, that complains about these undefined references.

Could it just be some includes thing, or so that I could amend to get it to compile. I had xshogi on pdaXrom, so it must be doable, isn't it?

How can I go about making the compile go through?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.