Help - Search - Members - Calendar
Full Version: Sd Card Woes On Sl-b500
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > 5x00 Hardware
AntiPasta
Well, it seems like I'm amongst the legions of people having problems with their SD card on their 5x00... I read the other topics but my problem is a bit different than the others, I think.

When I got my Z (B500, OZ3.5.4, OPIE 1.2.1), I tried using my cheapo MMC with it - which didn't work. The automount window never popped up, and dmesg reported loads of timeout errors (I can specify those if you're interested).

So I did some research, found out a lot of people use Kingston SD's in their Z, went out and bought a Kingston 512mb. I tried it in the store, OPIE popped up the automount window (allowing one to choose which files to scan for etc.), tried a 'mount' in the console and the card was mounted. So I figured it worked.

Took it home, decided to reformat it to ext2 (did a mke2fs /dev/mmcda1), but the card never functioned properly. It would mount, but upon doing a 'touch /media/card/testfile' I would get "Input/Output Error". Tried numerous other things, such as reformatting in my PC, didn't get satisfactory results.
Once I did manage to format it in my PC, create a textfile on it (using the PC), and reading that on the Zaurus - however, when I placed another file on it using the PC the Z wouldn't read the card.
Fdisk sometimes works perfectly, sometimes I get 'Couldn't read /dev/mmcda' errors.

So I tried the instructions here. Once again the 'new storage media detected' window pops up, but still I can't use the card properly.

So just now I fired up fdisk, removed all partitions, removed & reinserted the card (without umounting, I realize now), restarted fdisk and suddenly it shows 4 partitions not ending on cylinder boundaries and having different logical & physical locations??

Meanwhile, dmesg reports occasional stuff like "sd_write_single(237032) : select error" and "pxa_sd_wait_response: responce time out (cmd=07 MMC_STAT=0x2142)"

Anyone have a clue? I already took contact spray to the SD slot, to no avail, edited fstab like someone suggested, and all the above.
AntiPasta
Odd, I just stuck the card in my PC and suddenly found a ".opiestorage" file on it... so apparently the Z was able to write to it at one point, however it refuses to mount now - still gives me the four bogus partitions.
Ferret-Simpson
Tried running it from Sharp rom? Could be a bug in the OZ SD driver.

Maybe your card is screwed!?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.