Help - Search - Members - Calendar
Full Version: Dead (?) 5500 [solved]
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Sharp Zaurus > 5x00 General discussions
I've got "small" problem with my SL-5500 - it's not booting. It don't even try to boot. Battery and AC are working well, I can start diag menu or flash zaurus (it takes about 3 minutes). It was working, and once after inserting battery it just won't start. I've already tryed flashing with OZ 3.5.4, and Sharp Ospack 2.37, 3.13 and 3.1. Everytime the same - don't boot, screen is off, no light, no sound, nothing. Is there any chance to repair it??

In diag menu when I press "v" I see something like that:
CPU      : SA1110 B5
ROM      : USA 3.10
Board    : 01
ROM C.S. : 9f6d
Model    : 0002

BOOTSHP2 : 20020126 785a
CF       : 20020126 fd5d
COLLIE   : 20020221 e44d
ZIMAGE   : 20030509 97ed
ROMDISK  : 20030426 ad7c

This one is for Sharp OS 3.1, but BOOTSHP2, CF and COLLIE checksums aren't changeing after flash, so I think that there can be something wrong with them.
Could anybody send checksums from working SL5500??


I flashed with Sharp's ROM 1.02, and in my diag menu new (4th) page appeared. On that page I get to Flash Tools -> Erase Factory Default. After that I flashed it with OZ - and it works biggrin.gif
Two things: Are you sure the "On" switch works? I guess it does if you can get to the maint. menu, Never used a 5500.

Try a NAND flash?
QUOTE(Ferret-Simpson @ Jun 17 2006, 12:03 AM)
Two things: Are you sure the "On" switch works? I guess it does if you can get to the maint. menu, Never used a 5500.

Both Power button and replace battery switch works.

QUOTE(Ferret-Simpson @ Jun 17 2006, 12:03 AM)
Try a NAND flash?

There is no NAND backup/restore option in SL-5500, AFAIK it's last model without that.

At the moment I can get to Repair FS console of Sharp's OS when I flash Z with battery switch set to "normal operation". Right after flashing SHARP logo appears and is going up to make place for console showing:
INIT: version 2.78 booting
e2fsck 1.19, 13-Jul-2000 for EXT2 FS 0.5b, 95/08/09
Couldn't find ext2 superblock, trying backup blocks...

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with alternate superblock:
   e2fsck -b 8193 <device>

ext2fs_check_if_mount: No such file or directory while determinating whether /dev/mtdblock1 is mounted.
e2fsck Invalid argument while trying to open /dev/mtdblock1

*** An error occured during
*** the file system check.
*** Dropping you to a shell;
*** the system will reboot
*** when you leave the shell.
/etc/passwd: root password garbled
Give root password for maintence (or type Control-D for normal startup):

I hit enter and see:
(Repair FS) \# #

I've tryed "e2fsck -b 8193 /dev/mtdblock1" but it gives me the same info - "The superblock could not be read (...)"

It still don't respond for pressing power button.
Anyone have an idea what to do with that?
I'm getting the exact same error on a 5500... did you manage to get this one solved?

Any info would be much appreciated.. I'm gonna try a few things now, anything works i'll post back
I've been playing with this one for a day or 2 now and decided its dead.. though i can reflash and can see the EXACT same error messgae as the poster above bnothing will boot and i cant seem to do anything from thew recovery console to pewrsuade this collie to bark any longer.

I've tried a few reflashes with OZ and that doesnt seem to be working any better.

Can abnyone tell me what part of nmemory the /dev/mtdblock1 device is referring too? Is it possible a mem resize form OZ could cause this error?

sambartle, have you tryed my solution from the end of first post? You can download old ROM 's from Zaurus User Group
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.