Help - Search - Members - Calendar
Full Version: Updated Ruby And Rubygems Ipk
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > User Request for Applications
Sy Ali
http://rubyforge.org/projects/ruby/
http://rubyforge.org/projects/rubygems/

Ruby is up to 1.8.4, and an ipk file for rubygems would be handy.

I try a manual installation of RubyGems, and I get a string of errors.

The most interesting one seems to be:
QUOTE
/opt/QtPalmtop/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29: in `require': libcrypto.so.0.9.6: cannot load shared object file: No such file or directory - /opt/QtPalmtop/lib/ruby/1.8/arm-linux/digest/md5.so (LoadError)


I'm going to check with the ruby-talk mailing list.. maybe I can solve the install problem.
melee
QUOTE(Sy Ali @ Jun 19 2006, 10:07 AM)
Ruby is up to 1.8.4, and an ipk file for rubygems would be handy.


Hi

1.8.4 is already posted on this site thanks to FabianE

http://www.oesf.org/forums/index.php?showtopic=18415&st=45#

seems to include gems

Melee
Sy Ali
fabianE reports:
I've compiled Ruby 1.8.4 including ri, gems and irb with auto-complete enabled. You can download it at http://mail.pdaxrom.org/contrib/fabian/ .

However, running "gem" gives:
QUOTE
/home/QtPalmtop/bin/gem:3 in `require': no such file to load -- rubygems (LoadError)


if I cd into

CODE
/home/QtPalmtop/lib/ruby/site_ruby/1.8


and I run it, I get a different error:

QUOTE
./rubygems.rb:51: warning: already initalized constant RubyGemsPackageVersion
./rubygems.rb:53: warning: already initalized constant DIRECTORIES


I'm not entirely sure if I have it working or not. =)

...

I've been using Cacko 1.23 so far, but perhaps I should switch over to pdaXrom 1.1.0beta4
Sy Ali
Installing rubygems from source hasn't worked out. I can get it to install, although I get an error with the post-install. 'gem' runs, but I cannot instally any gems with it. I get:

ERROR: Error installing gem (filename)[.gem]: invalid date
fabianE
Hello,

the reason is probably that you use Cacko Rom, and not pdaxrom. My version of ruby was compiled for the later, so it probably won't work.

If you have another install of ruby for your rom and have problems with installing gems, you may lack some development packages or additional libraries.

Regards,

Fabian

QUOTE(Sy Ali @ Jun 24 2006, 12:05 AM)
Installing rubygems from source hasn't worked out.  I can get it to install, although I get an error with the post-install.  'gem' runs, but I cannot instally any gems with it.  I get:

ERROR:  Error installing gem (filename)[.gem]: invalid date
*
Sy Ali
Ruby 1.8.6 is out.

I'm using weeXpc now, which is pdaXrom-based, so I'll try rubygems one more time.
Sy Ali
Using ruby 1.8.4, I was able to get rubygems 0.9.4 working.

It gave some odd warnings while I ran the setup, and it paused for a *long* time and then gave 'terminated', but running 'gem' seems to work.,
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.