Help - Search - Members - Calendar
Full Version: Gpe/opie Not Starting On Sl4
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > SIMpad forum
McClean
Hi,

im a newbee in useing the simpad. When i got it (about 2 weeks ago) i first testet and upgraded winCE.
Then i tried the current GPE snapshot (installed using the CF method). All works fine. After playing with GPE i tried the current OPIE image. I used eflash root and eflash home - then i flashed the image like the first time. But it dont works. There are different error messages when doing reset multiple times:

- Kernel bad magic
- Kernel uncompress error
- or just freezing after printing "loading kernel" or "uncompressing kernel"


I tried to flash the old gpe image and some other versions of gpe -> same behavier. What can i do to get the pad working again?


Greetings,
McClean
Snappy
Question:

there are two things that can be/is flashed 1) bootloader and 2) rom

AFAIK, there was a new bootloader that is needed to support >= 0.91 of oz rom or something, that could be something.

Maybe you can start by telling us the exact files you flashed with, and their version/build. smile.gif
mr_nice
Hi, which description did you followed?
McClean
Hi,

thanks for your reply, sorry for my bad english. Here are some detailed infos about my simpad-setup:


I followed this guide (http://handhelds.org/moin/moin.cgi/SimPad):

1. format the CF card using the vfat (or windows FAT) format
2. copy the rootfs.jffs2 file corresponding to the image you want to install (bootstrap-image-*-simpad.rootfs.jffs2, gpe-image-*-simpad.rootfs.jffs2 or opie-image-*-simpad.rootfs.jffs2) on the CF card, and rename it to rootfs.jffs2
3. connect the SIMpad to a PC running a terminal emulator (Hyper Terminal on MS Windows, minicom on Linux...) and set the connection to 115200 baud 8 databits no parity 1 stopbit (115200 8N1).
4. instert the CF card with a PCMCIA adapted in the SIMpad
5. reset the SIMpad, and immediately press a key (not "Enter") in the terminal. This should give you the "boot>" prompt
6. Once in a boot prompt, type "copy hda1:/rootfs.jffs2 root"
7. after flashing is finished, you may want to type "eflash home" if you already did an installation using the hh.org bootloader and you want to erase the home partition
8. type "boot" in the terminal emulator

--> this works the first time i flashed the image, for reflashing a image i did:

- eflash root
- eflash home
- then point 1 to 6 and 8

-----------------------------------------------------------------
Software Versions:

- gpe-image-v0.8.4-rc2-simpad.rootfs.jffs2
- opie-image-v0.8.4-rc2-simpad.rootfs.jffs2
- blupdater: Serial log says:
>> Compaq OHH BootLoader, Rev 2-21-13 [BIG_KERNEL] [MD5] [MONO]
>> 04-11-20_15:58
>> Last link date: Sat Nov 20 15:58:14 GMT 2004
>> Contact: bootldr@handhelds.org


Greetings,
McClean
mr_nice
Wow, I have no idea.
Normaly eflash isn't needed.
I think you shuld try to fetch someone from the bootldr team. You can try this on the mailinglist bootldr@handhelds.org. The discription how to get it is on http://www.handhelds.org/email_lists.html . You can also try to get one of them in their irc channel (#handhelds.org on irc.handhelds.org)

Please rereport us about the results.
regards
nice
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.