Help - Search - Members - Calendar
Full Version: Busybox Commands In Rc.local
OESF Forums > General Forums > General Support and Discussion > Software
daniel3000
Hello,

I try to activate my swap file from rc.local.

I have created a file /etc/rc.d/rc.local (renaming the old one of Cacko 1.23 to another name) and filled it with the commands:

CODE
#!/bin/sh
irattach /dev/ttyS1
swapon /hdd3/.swapfile


the irattach command is executed well.
however, the swapon command just returns

CODE
swapon: swapon: No such file or directory


/sbin/swapon is a link to /bin/busybox.
irattach is a binary in /usr/sbin/irattach.

I tried copying the link for swapon into /usr/sbin, to no avail.
I tried the command
/bin/busybox swapon /hdd3/.swapfile
in rc.local, to no avail.

Does anyone know what I have to do to make rc.local activate my swap file?

Thank you!
daniel
bam
its because your hdd's are not mounted yet. try adding it to hddmount script in /sbin
daniel3000
QUOTE(bam @ Jun 21 2006, 07:49 PM)
its because your hdd's are not mounted yet. try adding it to hddmount script in /sbin
*


Thanks bam!
adding the swapon command to the end of hddmount indeed works.

On the C3000, rc.local worked for this. too, so I thought it would work on the 3100 too. But not so, probably because the hard disk of the C3000 holds parts of the ROM so all the file systems are mounted earlier on the C3000 thn on the C3100.

daniel
bam
this is one of the reasons I moved back to the stock rom. I prefer to handle stuff in rc.d rather than any other places, and the hddmount dealie just bugged me. also I had to install ssl onto the cacko rom, seems it didnt have it preinstalled...odd.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.