Help - Search - Members - Calendar
Full Version: Av500 As Usb Disk For Pc Boot ?
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Archos forum

Is it possible or has anyone ever tried to use the AV500 as an USB hard drive for booting Linux or Windows XP from it when it is attached to a PC that supports booting from USB?

Any tipps how to approach this would be very welcome.

My first worry is that I might loose the standard mult media functions on the AV500 or that it even does not start at all anymore when I start messing with it.

As a start I ran testdisk and found already some special things in respect to the formatting of the hardrive on the AV500. In the FAT it says 240 heads/cylinders instead of 255 and the partition is marked as primary bootable but it isn't.

TestDisk 6.4, Data Recovery Utility, June 2006
Disk /dev/sdb - 99 GB / 92 GiB - CHS 12128 255 63
Current partition structure:
Partition Start End Size in sectors
check_FAT: Incorrect number of heads/cylinder 240 (FAT) != 255 (HD)
1 P FAT32 LBA 0 1 1 12127 254 63 194836257 [AV500]
No partition is bootable

TestDisk 6.4, Data Recovery Utility, June 2006
Disk /dev/sdb - 99 GB / 92 GiB - CHS 12128 255 63
Partition Start End Size in sectors
* FAT32 LBA 0 1 1 12127 254 63 194836257 [AV500]

Structure: Ok. Use Up/Down Arrow keys to select partition.
Use Left/Right Arrow keys to CHANGE partition characteristics:
*=Primary bootable P=Primary L=Logical E=Extended D=Deleted
Keys A: add partition, L: load backup, T: change type, P: list files,

Any tipps are most welcome.

Well it seems there is a good chance to boot on OS from the Archos AV500 and have it still working as a PMP when not connected via USB to a PC.

Before I started to make any changes I analyzed the MBR, the partition boot sectors, and all the surrounding sectors.

There is one partition in the partition table. It is marked as "not bootable" (0x00)

Note: sector counting starts with 0. Sector 0 does contain the MBR.

In sector 6 we can find a standard fat 32 back-up boot sector "MSWIN4.1" with standard boot code, and the continuation of this boot code in sector 8.

However in the real boot sector 63 there is a non-standard boot sector. Non standard in respect to the boot code that is present in sector 63 and the boot code that continues in sector 65. The backup boot sectors for the partition can be found in sector 69-71 and is the same as in sector 63-65.

The BIOS Parameter Block has several differences with the BPP stored in back-up boot sector #6. Most interesting is that the number of heads is only noted with 240 instead of 255.

Without any changes to the Archos hard drive. When the PC is set to boot from USB it displays the error message from the MBR "error loading OS".

After setting the partition to "bootable" (0x80) in the MBR, the boot process continues to the partition boot sector and displays the message "Invalid system disk" "Replace disk, and then press any key"

After I copied the required MS-DOS files into the Archos root directory the error still comes up. It does not start DOS.

As a next attempt I have copied the boot code from Sector 6-8 to the sector 63-65. The BIOS parameter block was not copied. I kept the old BPB in sector 63.

And now the PC is starting MS-DOS from the Archos hard drive. Perfect.

After disconnecting the AV500 from the PC and testing out all the PM functions, switching it on and off it seems it all all still working as normal. No side effects with the new boot code in the boot sector.

Next I'll work on getting Win XP onto the Archos and make the PC boot from it.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.