Help - Search - Members - Calendar
Full Version: Kphone - No Audio
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > 5x00 General discussions
sibble-comp-oesf
Okay, SL-5500 runing OZ 3.5.3 (opie), have kphone installed and setup with FWD (freeworlddialup), I can make and receive calls on it, but I get no audio for the calls.

I know audio is working in general as I can play mp3's with XMMS just fine.

I've tried with both standard stereo headphones and my cellular headset with a 2.5mm to 3.5mm adaptor, but no joy. I've also tried the r/w audio mode and ro/wo mode in kphone without success. I've tested on a desktop running X-Lite and it works for both sending and receiving audio so I know it's not a firewall issue, plus kphone shows the call has been connected, I just can't hear anything. This is testing with the fwd echo server.

Any suggestions?

Haven't been able to find anything on the board about this specific problem.

Thanks
sibble-comp-oesf
Okay, further testing revealed I had missed adding /dev/dsp1 under the audio configuration for Kphone, now I can do the echo test but I get back nothing but VERY LOUD static.

More testing and it looks like both a h/w and software problem.

I took other Z running sharp rom 3.1, installed kphone with same config and same headset and adaptor. When I do the echo test I hear noise only when I speak and it sound kinda like my voice, so I restart kphone and use the gsm codec instead of G711u. This works perfectly on the sharp rom based unit, I hear myself clearly.

I replicate settings on the OZ 3.5.3 based Sl5500 and still getting the noise. I then start moving the adaptor (and hence the jack itself) around and I now get the result that I get an echo back of my extremely distored voice, bump the adaptor and back to all noise. :-( But no amount of jiggling gives me a clear echo. So I guess I'll have to replicate my OZ setup to the sharp rom based one and then open up the OZ unit and resolder or replace the audio jack. It works perfectly fine for playing music so I am guessing either the circuit that controls switching from stereo output to mono output and mic input may be hosed.

Any other ideas?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.