Help - Search - Members - Calendar
Full Version: Compiling Qt Apps Under Beta4
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
ZDevil
Just finished a trip so now have some brief leisure to try compiling stuff for Beta4.

Those on the top of my list are:
-- SCIM (the one in the current Beta4 Cxx0-860 is just the older build which still depends on libiconv)
-- All the QT apps I compiled months ago (VYM, TuxCards, Portabase, Qbedic, FreeNoteQT),in the hope that they can take SCIM as the inputmethod. Some of them have been updated such as VYM that includes a lot of new nice features.
-- Other essential and updated stuff: less, mrxvt 0.5, leafpad 0.8.9, JPilot w/ GTK2 support, nano, etc.

But found that some QT stuff (such as moc and uic) are missing in the current zgcc-3.4.6 and even Meanie's mod 3.4.5-2. So many useful QT apps cannot compile onboard.

And I am just wondering if pgas's "QT-enhanced" version of zgcc-3.3.2 (http://zaurus.spy.org/feeds/cacko/pdaXrom/misc/pgas/gcc-qt/) can still do the job for Beta4. Don't wanna do too many unnecessary trial and errors.

All replies are much appreciated. Thanks! smile.gif
Meanie
QUOTE(ZDevil @ Jun 29 2006, 02:10 AM)
Just finished a trip so now have some brief leisure to try compiling stuff for Beta4.

Those on the top of my list are:
-- SCIM (the one in the current Beta4 Cxx0-860 is just the older build which still depends on libiconv)
-- All the QT apps I compiled months ago (VYM, TuxCards, Portabase, Qbedic, FreeNoteQT),in the hope that they can take SCIM as the inputmethod. Some of them have been updated such as VYM that includes a lot of new nice features.
-- Other essential and updated stuff: less, mrxvt 0.5, leafpad 0.8.5, JPilot, nano

But found that some QT stuff (such as moc and uic) are missing in the current zgcc-3.4.6 and even Meanie's mod 3.4.5-2. So many useful QT apps cannot compile onboard.

And I am just wondering if pgas's "QT-enhanced" version of zgcc-3.3.2 (http://zaurus.spy.org/feeds/cacko/pdaXrom/misc/pgas/gcc-qt/) can still do the job for Beta4. Don't wanna do too many unnecessary trial and errors.

All replies are much appreciated. Thanks!  smile.gif
*



I got an even more updated gcc image with moc, qmake, uic as well as qt designer... for pdaxrom, but my upload speed currently is too slow...
ZDevil
Oh that's wonderful! Could you please to upload it to some file sharing space for the time being? I think it is a much needed toolchain for many desparate users and contributors. smile.gif
Meanie
QUOTE(ZDevil @ Jun 29 2006, 05:28 AM)
Oh that's wonderful! Could you please to upload it to some file sharing space for the time being? I think it is a much needed toolchain for many desparate users and contributors.  smile.gif
*


it's currently being uploaded to my pdaxrom section. have fun. unfortunately, if you have any problems with the image, then you are on your own and need to fix it yourself. i dont run pdaxrom anymore...
ZDevil
Sorry for not responding right away.
I was struggling with Beta4 for quite a while before falling back to Beta3.
I tried your zgcc-3.4.5-4.squashfs in your feed. However when trying to mount it I got this error:
CODE
mount: wrong fs type, bad option, bad superblock on /dev/loop0, missing codepage, or too many mounted file systems


While mounting other images appear to be fine.

Thanks anyway, Meanie!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.