Help - Search - Members - Calendar
Full Version: Dead C3100 After Flashing Cacko Rom 1.23
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
XplosS
Hello.

Firstly, I'd like to apologize for my "engrish" since I'm spanish. Sorry about that.

Well, the problem is that I have installed the latest version of Cacko ROM (1.23), but, although I've followed carefully all the steps required in order to obtain a correct installation, it shows me a great bunch of errors when I boot the Zaurus.

Some lines, with the following text, appear:

"jffs2_scan_eraseblock(): Magic bitmask #x#### not found at #x########: #x#### instead" ("#" means a random number).

It keeps appearing during one minute, before the console input shows up. Here, I tried some commands (startx, start, qtstart... I'd like to point out I'm a newbie), without success. Also, no application is installed (tried to run fdisk, what I think is a common app in every ROM, and it gave me an unknown command answer).

I've reinstalled the same ROM twice, and keeps giving me the same errors. What should I do?

Thank you for your help.

PS: I cannot try any other ROM, since I have no SD Card slot for my computer (I was using the Zaurus as SD slot).
PS2: Previously, I had pdaXrom installed.
Jon_J
You need to mention what model of Zaurus you are flashing.
You should go to Trisoft's site and get an original NAND backup file for your Zaurus.
http://www.trisoft.de/en_downloads.htm
Make sure you get the correct NAND for your model of Zaurus.
Follow instructions carefully to return your Zaurus back to the original Sharp ROM.
It's also best to use a CF card.
Get a card reader for CF & SD, they're cheap nowdays.

If you had pdaXrom installed, your "Flash" partition may not be the correct size for Cacko.
You may need to read the pdaXrom forum, or ask a question there about returning from pdaXrom to Cacko.

When flashing Cacko, make sure to follow step 11 thru 13 carefully.
This is the section where you re-partition your "Flash"

Below is a paste of Maslovsky's post for Cacko Full, NOT Lite
-----------------------------------------------------------------------------------------
IMPORTANT: This ROM requries a flash partition at least 32 MBytes in size!
Make sure to repartition your internal flash before updating ROM!


Installation:

1. Extract the 3 files - initrd.bin tools.tar updater.sh - to the root of your CF or SD/MMC card.
2. Make sure that Zaurus isn't plugged into AC power.
3. Remove battery for at least 5 seconds.
4. Replace battery (replace battery cover, lock cover), plug in AC power.
5. Press and hold the "OK" button on the keyboard.
6. Turn the power on, you should see the Japanese service menu.
7. Now Plug in the Power Cord. (You will get an error if it isn't plugged in!)
8. Select option 4 (flash/update).
9. You then have several options including CF and SD
10. Choose either CF or SD, depending on which media you put the files on.

11. Select "3 NAND Flash Utils"
12. Select "1 Resize root partition"
13. Enter 32 when prompted for root partition size.
12. Flash will be repartioned and Zaurus will reboot.

13. Repeat steps 2-10 again and wait for the menu start menu.
14. Now select "1 Install new ROM" and wait. Reboot your Zaurus when ROM installaiton is complete.
-------------
(Note) On my SL-C3100, there seemed to be one more step:
After step 10, Select Left Box 'Y' for Yes.
XplosS
Thank you for your reply. I'm buying a multicard reader this afternoon, so I'll try to reflash it with the original NAND data that you comment.

I'll post the results later.

Thank you again for that address. wink.gif

PS: By the way, it's a SL-C3100. smile.gif
Cresho
use fat 16 partition on cf card or sd card. fat 32 will not work.

use nand restore to restore your zaurus.

http://downloads.conics.net/pda/zaurus-sl-...ND-original.zip

http://downloads.conics.net/pda/zaurus-sl-...ND-original.zip
Snappy
btw, you may want to change your title ... its technically not dead since it still boots up ... wink.gif ... the misleading title may scare of potential Cacko users, or worse yet, potential Zaurus users. smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.